1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk 8.3 to 8.3 upgrade package

Discussion in 'Plesk for Linux - 8.x and Older' started by ogeorgi, Dec 26, 2007.

  1. ogeorgi

    ogeorgi Guest

    0
     
    Hi everybody,

    [Update]
    Sorry, I guess I have put this topic in wrong forum, should be troubleshooting section.
    [/Update]

    I did the 8.3 Plesk (12/18/07) upgrade last week when it was available first time. Then - when I tried to upgrade another system over Christmas days 8.3 upgrade was no longer available. So I checked this morning - and it was up again.

    Checking Plesk 8.3 upgrade on machines having 8.3 installed right now I can see some new packages (12/24/07) - these are:
    # Base packages of Plesk
    # Plesk Updater
    # Plesk API [former Plesk Agent]
    # Plesk migration manager
    # Plesk Backup Manager

    But now when I try to upgrade system to these I get a license error:
    (German message) Fehler: Installation wurde nicht gestartet: (error: installation was not started)
    Failed to check whether a new license key is available.
    The installation will not continue.
    Not all packages were installed.
    Please, contact product technical support..

    License check in Plesk says everything is OK (valid until June 29, 2008).

    OK, what to do now? Contact technical support of my provider or SWSoft Plesk support?

    More information - I got "Plesk autoupdate failure report" sent by Autoinstaller:
    ...
    Need key update for component base from version 1.0.0-suse10.0.build83071218.20 to '8.0'
    Downloading the file PSA_8.3.0/plesk_getkeyinfo.sh: 100% done.
    Exchanging information with licensing server.base
    Ask KA server for key update: product=PleskLogin current key number=PLSK003294690007 to version=1.0.0
    Warning: your license key for the base component cannot be upgraded.
    ERROR: Failed to check whether a new license key is available.
    The installation will not continue.
    Not all packages were installed.
    Please, contact product technical support.



    Oliver
     
  2. dash

    dash Regular Pleskian Staff Member

    28
    40%
    Joined:
    Sep 26, 2007
    Messages:
    204
    Likes Received:
    47
    As a workaround you can use autoinstaller from console (/usr/local/psa/admin/sbin/autoinstaller). It will say something like "Warning: your license key for the base component cannot be upgraded." Do you want to continue?
    It's just a cosmetic warning
    just type "Yes" and the update will be installed.

    The bug is reproduced only in 8.3.0-Base component -> 8.3.0-Base component update from CP.
    Fixed autoinstaller will be publicly available soon.
     
Loading...