1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk and Godaddy - SSL issues

Discussion in 'Plesk for Linux - 8.x and Older' started by psingh, Dec 15, 2007.

  1. psingh

    psingh Basic Pleskian

    23
    57%
    Joined:
    Dec 15, 2007
    Messages:
    33
    Likes Received:
    0
    Hi,

    I have received 2 "crt" files, from godaddy and followed instructions as has been provided by cert provider for plesk. Everything went smooth. Please scroll down for instructions sent by godaddy cert.

    Secondly, i logged in to Plesk control panel,

    from -

    Domains >
    Hosting > Setup >

    on Physical hosting setup page for domain

    on IP Address drop down : i selected " exclusive ip " and also did "Cert: Repository of domain"

    But as i do it, when i browse my URL i receive following problem:


    I don't know that next to do now ? any suggestions ??
    If i revert back to shared ip, page start to show up..??..
    Please click on two attached files below on the thumbnail to see screen shots.

    Any suggestion will be appreciated.

    Regards,
    PSingh
     

    Attached Files:

  2. Monica@

    Monica@ Guest

    0
     
  3. psingh

    psingh Basic Pleskian

    23
    57%
    Joined:
    Dec 15, 2007
    Messages:
    33
    Likes Received:
    0
  4. webboy

    webboy Guest

    0
     
    Are you using a single directory to house your https and http files? If not you may want to change that setting. It looks like the https is looking at the index file in the https docs file. You will need to have an exclusive IP for the ssl to work properly.

    Something does seem seriously wrong with your configuration. Are you in a shared hosting environment or is this your own VPS? I found many problems on a dns stuff lookup.

    Are you .com or .net? Your SSL is for .com and your nameservers are .net. Things are extremely confusing here. Both .net and .com are registered to the same company.

    m************.com has nameservers:
    557.m**********s.net
    ecz1.m**********s.net
    ecz2.m**********s.net

    m***********.net has nameservers
    NS2.LIVEBRAIN.CO.IN
    NS1.LIVEBRAIN.CO.IN

    Your domain appears to be hosted on this IP: 72.167.96.192 not 72.167.115.3.

    Hope this helps.

    Sam O'Clair
    Velocity Website Hosting, LLC
    hostsales@velocityhostingservice.com
     
  5. psingh

    psingh Basic Pleskian

    23
    57%
    Joined:
    Dec 15, 2007
    Messages:
    33
    Likes Received:
    0
    Thanks O'Clair for quick response:

    I hope you will write me back.


    Will it make any difference.

    When I complete all configuration as per documentation. SSL still shows up for Plesk not for my .com domain.

    I appreciate your help and hope to get solutions..

    Regards,
    P S
     
  6. webboy

    webboy Guest

    0
     
    Your certificate is set up for the IP 72.167.115.3 and when I type in https://72.167.115.3 I get that it is registered to your domain name. Currently your domain is resolving to IP 72.167.96.192 and thats why you are still getting the plesk certificate mismatch. You will need to load up the site onto the IP 72.167.115.3 for the ssl to work properly.
     
  7. psingh

    psingh Basic Pleskian

    23
    57%
    Joined:
    Dec 15, 2007
    Messages:
    33
    Likes Received:
    0
    problem is 100 % diagnosed.. but need a solution..

    Hi webboy,

    I appreciate your response..

    You are exactly getting where i am stuck now!! problem is 100 % diagnosed.. but need a solution... !!!

    On plesk Control Panel:

    as i do this, I suppose my hosting is switched from *.*.96.192 to **.**.115.3 ( I am sure this is it)

    Is there any thing more i need to do more than this..

    Even after this when i browse httpS://www.mySite.com my cert does not show up, but Old one comes up.
    However, when i Browse https://**.**.115.3/ it shows up, it's picking from right SSL cert.

    I am really confused.

    any idea :D :) :( :D :d) :q)
     
  8. webboy

    webboy Guest

    0
     
    Hi P S,

    After checking the dns records your www record is still resolving to 72.167.96.192. This means that your actual files are hosted here and not under 72.167.115.3. Your really not that far away from having this fixed! Without really seeing what is going I have thought of this solution.

    On set up options you should be able to change the IP address of the domain from a drop down menu. When you go to your Plesk control panel for the domain what IP appears for the domain? That will give us the confirmation that the URL is pointing to the correct IP. Your DNS zone for the account should update automatically.



    Step 1. FTP the website files directly to the IP number 72.167.115.3. So on your FTP program you will use these settings:

    Host Name = 72.167.115.3
    Username= *******
    Password= *******

    Step 2: Check to see if your www record is now pointing to 72.167.115.3 by using http://www.dnsstuff.com/ and clicking on tools. When you get this to happen you should be all set.

    3. If you would like me to help out I will have some time today after 12PM. Sometimes a fresh set of eyes on the problem will see the solution. You can email me at hostsales@velocityhostingservice.com and I will get back to you with my phone number. Just set up a temporary password for the domain and I can go in and take a look. Just change back when I am complete.

    Sam
     
  9. psingh

    psingh Basic Pleskian

    23
    57%
    Joined:
    Dec 15, 2007
    Messages:
    33
    Likes Received:
    0
    It worked.. but requires patience..

    Hey Friends,

    In fact it did work after couple of hours.

    It was because of IPS (DNS) cache resolving to the old IP.

    It's up and Operational Now.

    Thanks for everyone for their valued input.

    Regards
     
  10. EdwinL

    EdwinL Guest

    0
     
    You might have just solved my problem. Done everything and site wouldn't work. Seems an obvious mistake but when there're numerous steps involved ... am waiting for the DNS to propagate.

    In any case it was a step I missed. Appreciate posting your solution although this was sometime back.

    thanks
    Ed
    Jabez Neworks, Inc.
    Web Solutions, E-commerce, and SEO Consulting
     
Loading...