1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk can affect ntpd service?

Discussion in 'Plesk for Linux - 8.x and Older' started by LooseCannon@, Jan 3, 2007.

  1. LooseCannon@

    LooseCannon@ Guest

    0
     
    Greetings all.

    I've spent a while searching for answers here, but can't see anything closer than this thread. As that thread suggests, this seems to be an operating system issue and not related to Plesk.

    However, we've run out of ideas for checking the system (Linux Red Hat ES4). Our server host can see nothing different to their many other servers, exceot for ours having Plesk.

    We have already applied a fix regarding our VM ware, which worked. Unfortunately, the problem has reappeared and the same VM ware + Linux problem no longer seems at fault.

    So this is a general question, to try to avoid going down the wrong route(s) of enquiry.

    Can Plesk adversely or corruptly affect the ntpd service or system time?

    Any ideas would be appreciated.

    LC
     
  2. wagnerch

    wagnerch Guest

    0
     
    Nope, works fine for me. How about you describe your issue and post your ntpd.conf?
     
  3. LooseCannon@

    LooseCannon@ Guest

    0
     
    Thanks wagnerch.

    Ok, so maybe no finger pointing towards Plesk. Good news really, as the Linux/network stuff should be within reach. Our situation is as follows:

    The ntpd service is running.

    Our /etc/ntp.conf file contains:
    server 192.168.24.11
    server 192.168.24.10

    Having logged the time error since yesterday, it seems to be approx ((0.5696*HRS)*POWER(1.00146,HRS)) mins per hour. Eg, for a 24 hour period, the server time will fall behind GMT by approx 13 mins. Ie, it's not a fixed difference per hour, but is increasing and that increase seems as fixed proportion. I trully hope no genuine mathematicians pass this way. :p

    We are running on a virtual machine. As already note, our hosts beleive they've already fixed a time issue with that.

    Other info or ideas?

    LC
     
  4. wagnerch

    wagnerch Guest

    0
     
    If that is your complete ntpd.conf file then that is your problem, you have to add restrict lines for each and every server to allow it to send back responses.

    For example,

    server 128.4.40.12 prefer #louie.udel.edu
    server 130.126.24.53 #ntp-0.cso.uiuc.edu
    server 130.126.24.24 #ntp-1.cso.uiuc.edu
    server 130.126.24.44 #ntp-2.cso.uiuc.edu

    restrict 128.4.40.12 nomodify noquery notrap
    restrict 130.126.24.53 nomodify noquery notrap
    restrict 130.126.24.24 nomodify noquery notrap
    restrict 130.126.24.44 nomodify noquery notrap
     
  5. wagnerch

    wagnerch Guest

    0
     
    Also, you probably should run ntpq and verify the servers are synchronizing (usually takes 10~15 minutes, depending on how you setup ntpd.conf it could be an hour or two)

    ntpq> peers
    remote refid st t when poll reach delay offset jitter
    ==============================================================================
    *louie.udel.edu 18.145.0.30 2 u 351 1024 377 65.039 -0.165 757.847
    ntp-0.gw.uiuc.e 128.174.38.133 2 u 517 1024 377 1235.85 569.662 582.802
    +ntp-1.gw.uiuc.e 128.174.38.133 2 u 398 1024 377 63.822 -10.728 749.576
    +ntp-2.gw.uiuc.e 128.174.38.133 2 u 518 1024 377 295.275 99.313 112.452
    LOCAL(0) LOCAL(0) 10 l 33 64 377 0.000 0.000 0.004


    If your not synchronized or reading clocks it is pretty obvious.
     
  6. LooseCannon@

    LooseCannon@ Guest

    0
     
    Thanks wagnerch.

    I confess I had to review the online manual for ntpq. I've only sorted Windows sntp before now. Great reference. :tup:

    ntpq> pe
    remote refid st t when poll reach delay offset jitter
    ==============================================================================
    cassini.titanin 204.34.198.40 2 u 46 64 377 0.913 1328.05 880.771
    artemis.titanin 204.34.198.40 2 u 51 64 377 0.803 1403.09 860.896

    A short while previously, I did run this with -n to check the ip addresses. These did agree with server ip's in ntp.conf. However, now I'm preplexed, as I get:

    ntpq> pe -n
    ***Version must be either 4 or 6

    Anyrate, I digress and it seems ok because:

    .. # traceroute 192.168.24.11
    traceroute to 192.168.24.11 (192.168.24.11), 30 hops max, 38 byte packets
    1 cassini.titaninternet.co.uk (192.168.24.11) 1.720 ms 0.854 ms 0.888 ms

    .. and artemis is 192.168.24.10

    So the time servers and dns/network is working?

    Or, does this information not confirm any responses from the time servers are being actioned, as you imply?

    NB: the time difference almost disappeared overnight, but has again begun to grow.
     
  7. LooseCannon@

    LooseCannon@ Guest

    0
     
    Plesk time sync

    Ref: Server / System Time [System]

    1. Should one tick the 'Synchronise system time' box and hence enter an ip/dns for a time server? One can of course, but what's the recommendation or 'best' option?
    2. If yes to 1, can and should one enter multiple time servers and how? I'd guess [192.168.24.10;192.168.24.11]

    We have tried with and without ticking this Plesk time sync option. No effect on our time discepency problem has been noted, but advice here might help.
     
  8. wagnerch

    wagnerch Guest

    0
     
    Yes, once you start seeing offsets and jitter it is starting to synchronize the clock. Now if the offset is too large then you will see an error in your syslog to that effect, in those cases you need to shutdown ntpd and run "ntpdate <server>" manually to force a synchronization.
     
  9. wagnerch

    wagnerch Guest

    0
     
    Re: Plesk time sync

    Based on what the help screen says that option will likely setup the ntpd.conf file for you and start the ntpd server. Since you appear to have it working then I would just leave it unchecked and setup the ntpd service manually, that is what I did.
     
  10. LooseCannon@

    LooseCannon@ Guest

    0
     
    Hmmm, I'll check the syslog. Thanks for the pointer.

    At least the service looks like it's functioning.
     
  11. LooseCannon@

    LooseCannon@ Guest

    0
     
    Re: Re: Plesk time sync

    I UN-ticked the Plesk sync option, then stopped & started ntpd. No change to ntp.conf throughout.

    I wonder what the Plesk sync setup actually does...

    No matter at the moment. I might bump this thread if it remains a concern/issue.

    Armed with ntpq and with an eye on the syslog, I'll keep the situation review.

    Thanks for your assistance wagnerch. :tup:
     
  12. LooseCannon@

    LooseCannon@ Guest

    0
     
    Update:

    Our time service seems to have settled down, but we're not sure why.

    By ref to the syslog and periodic checks of the service and ntpq, our initial conclusion is that:
    - the service stops inappropriately sometimes, eg leaving the pid
    - during this time the drift exceeds an acceptable 'sanity' limit amd cannot recover without manually setting/sync with `ntpdate`.

    We've added the following to ntp.conf:
    Have we found any Plesk invlovement?

    No. Changing the System Time / Synchronize settings seems to have no effect. Well, we couldn't find any.

    Questions: Does Plesk 7.5 system time syncronisation actually function? If so, how does it affect ntp, as it does not touch ntp.conf?
     
Loading...