1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Plesk Firewall - Please Help!

Discussion in 'Plesk for Windows - 8.x and Older' started by softpac2000, Jun 6, 2005.

  1. softpac2000

    softpac2000 Guest

    0
     
    I am getting this error when I click on the firewall icon in Plesk 7.5.3 for Windows:

    winfwmng failed: Object reference not set to an instance of an object.

    --------------------------------------------------------------------------------

    0: C:\Program Files\SWsoft\Plesk\admin\plib\firewallmng.php:30 psaerror(string "winfwmng failed: Object reference not set to an instance of an object.") 1: C:\Program Files\SWsoft\Plesk\admin\plib\firewallmng.php:79 firewallmng->_call(string "<command><show><interfaces/></show></command>") 2: C:\Program Files\SWsoft\Plesk\admin\plib\firewall\InterfaceList.php:30 firewallmng->get_interfaces() 3: C:\Program Files\SWsoft\Plesk\admin\plib\class.cList.php3:69 interfacelist->fetchinterfacelist() 4: C:\Program Files\SWsoft\Plesk\admin\plib\class.cList.php3:88 interfacelist->fetchlist() 5: C:\Program Files\SWsoft\Plesk\admin\plib\firewall\FirewallMainForm.php:47 interfacelist->init() 6: C:\Program Files\SWsoft\Plesk\admin\htdocs\server\firewall.php:48 firewallmainform->assign(boolean true, boolean true)

    Does anyone know how to fix this?...

    Thanks in advance!
    Ricardo...:cool:
     
  2. botsman

    botsman Guest

    0
     
    Try to go server>component managem,ent>firewall and choose None, then go back and choose firewall again.
     
  3. lordElrond

    lordElrond Guest

    0
     
    I tried this and still getting errors. I tried a clean install and still does the same thing.

    ERROR
    winfwmng failed: Object reference not set to an instance of an object.
    0: C:\Program Files\SWsoft\Plesk\admin\plib\firewallmng.php:30 psaerror(string "winfwmng failed: Object reference not set to an instance of an object.") 1: C:\Program Files\SWsoft\Plesk\admin\plib\firewallmng.php:40 firewallmng->_call(string "<command><show><opmode/><profile type="current"/></show></command>") 2: C:\Program Files\SWsoft\Plesk\admin\htdocs\server\firewall.php:9 firewallmng->firewall_get_status()
     
  4. lordElrond

    lordElrond Guest

    0
     
    Another system error

    Run-Time error: Run-Time error: Execute winfwmng.exe "<?xml version=\"1.0\" encoding=\"UTF-8\"?><command><set><default config=\"default\"/></set></command>" failed: Object reference not set to an instance of an object.

    at (defpackagemng::setDefault line 271)
    at execute console command --set(vconsoleapp::start line 128)
    at execute "C:\Program Files\SWsoft\Plesk\admin\bin\defpackagemng.exe" --set "--type=firewall" "--default=winfw"(vconsoleapp::run line 138)
    Execute file name: C:\Program Files\SWsoft\Plesk\admin\bin\defpackagemng.exe
     
  5. softpac2000

    softpac2000 Guest

    0
     
    Thank you all for your replies!...

    I have found what the problem is!...

    If you have a Firewire port (1394), go to Network Connections, in the Windows Control Panel, and disable the Firewire Adapter (1394).

    I guess Plesk can't handle Firewire just yet!

    That will do the trick!..

    Hope this helps!
    Ricardo...:cool:
     
  6. lordElrond

    lordElrond Guest

    0
     
    Thanks for the info. Whats the best procedure or practice here? Windows 2003 Standard edition and Plesk 7.5.3.

    Can sp1 be applied to the current build?
     
  7. softpac2000

    softpac2000 Guest

    0
     
    You should be able to apply Windows Server 2003 SP1 with no problem at all!

    But then again! With Plesk you never know what can happen!

    So make sure you do a full system backup before you do so!

    Ricardo...:cool:
     
Loading...