1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk installation on Debian and Ubuntu

Discussion in 'Plesk for Linux - 8.x and Older' started by projuri, Sep 7, 2006.

  1. projuri

    projuri Guest

    0
     
    Hello,

    I'was trying to install Plesk on Debian/testing, but I got many conflicts. For example, php doesn't work:
    Code:
    ERROR: PleskFatalException
    Unable to get default language.
    
    0: /opt/psa/admin/plib/common_func.php3:172
    	psaerror(string 'Unable to get default language.')
    1: /opt/psa/admin/plib/countries.php3:293
    	locale_list()
    2: /opt/psa/admin/plib/common_func.php3:1458
    	locale_exists(string 'en-US')
    3: /opt/psa/admin/plib/class.Session.php:158
    	Session->Session()
    4: /opt/psa/admin/auto_prepend/auth.php3:149

    I can't install Debian/Stable becouse installation kernel can't recognize SATA controller and I was thinging about installing Ubuntu, but I have found installation only for Ubuntu 5.10, isn't too old? Will it work with Ubuntu 6.06 LTS. I hope that ubuntu does support my SATA controller.

    Any comments will be helpful.

    Thank you
     
  2. projuri

    projuri Guest

    0
     
    I got this message when I was trying to install Plesk 8.0.1 for Ubuntu 5.10 on Ubuntu Server 6.06.
    Code:
    The following packages have unmet dependencies:
      drweb-daemon: Depends: libssl0.9.7 but it is not installable
      ppwse: Depends: libssl0.9.7 but it is not installable
             Depends: php4 (>= 4.1) but it is not installable
             Depends: php4-cli but it is not installable
             Depends: php4-curl but it is not installable
      psa: Depends: libboost-filesystem1.33.0 (< 1.32.0+1.33.0-cvs20050727-99) but it is not installable
           Depends: libboost-filesystem1.33.0 (>= 1.32.0+1.33.0-cvs20050727-0) but it is not installable
           Depends: libssl0.9.7 but it is not installable
           Depends: webalizer but it is not installable
           Depends: psa-php4-configurator but it is not going to be installed or
                    psa-php5-configurator but it is not going to be installed
      psa-appvault-coppermine: Depends: php4-gd but it is not installable
      psa-appvault-gallery: Depends: php4-gd but it is not installable
      psa-courier-imap: Depends: libssl0.9.7 but it is not installable
      psa-courier-imap-add: Depends: libssl0.9.7 but it is not installable
      psa-hotfix3: Depends: libssl0.9.7 but it is not installable
      psa-migration-manager: Depends: libboost-filesystem1.33.0 (< 1.32.0+1.33.0-cvs20050727-99) but it is not installable
                             Depends: libboost-filesystem1.33.0 (>= 1.32.0+1.33.0-cvs20050727-0) but it is not installable
                             Depends: libboost-program-options1.33.0 (< 1.32.0+1.33.0-cvs20050727-99) but it is not installable
                             Depends: libboost-program-options1.33.0 (>= 1.32.0+1.33.0-cvs20050727-0) but it is not installable
                             Depends: libboost-regex1.33.0 (< 1.32.0+1.33.0-cvs20050727-99) but it is not installable
                             Depends: libboost-regex1.33.0 (>= 1.32.0+1.33.0-cvs20050727-0) but it is not installable
                             Depends: libssl0.9.7 but it is not installable
      psa-proftpd: Depends: libssl0.9.7 but it is not installable
      psa-qmail: Depends: libssl0.9.7 but it is not installable
      psa-spamassassin: Depends: spamassassin (>= 3.0.2) but it is not installable
                        Depends: spamc but it is not installable
      psa-tomcat-configurator: Depends: tomcat4 but it is not going to be installed
                               Depends: tomcat4-webapps but it is not going to be installed
                               Depends: tomcat4-admin but it is not going to be installed
                               Depends: j2sdk1.4 but it is not installable
                               Depends: libapache2-mod-jk2 but it is not installable
      sitebuilder: Depends: sitebuilder-core-php4 but it is not going to be installed or
                            sitebuilder-core-php5 but it is not going to be installed
    
     
  3. projuri

    projuri Guest

    0
     
    I have written a letter to SWSoft support and I got the answer:

     
  4. R2K_

    R2K_ Guest

    0
     
    I had the same problem with unrecognized hardware.
    Used a custom debian sarge installer, see http://kmuto.jp/b.cgi/debian/d-i-2616.htm
    Basically, a standard Debian Sarge netinstall image, but with a newer (2.6.16) kernel from backports.org, which supports more hardware.

    Worked great for me.
     
Loading...