1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk, MX records, Exchange Server, No mailboxes

Discussion in 'Plesk for Linux - 8.x and Older' started by JointTech, Mar 12, 2007.

  1. JointTech

    JointTech New Pleskian

    22
    57%
    Joined:
    Mar 12, 2007
    Messages:
    12
    Likes Received:
    0
    I have clients (like myself) that use an Exchange server inhouse. So I have an MX record pointing to an A record that points to my office server. (this is in the Plesk DNS for the domain)

    So I have no mailboxes in Plesk for any domain that uses Exchange.

    However If I send a message through plesk server From a domain on Plesk to a domain on Plesk (but with no mailboxes) Plesk says hey there are no mailboxes at that domain.

    I have a lot of clients that use my plesk server as an SMTP server. (with authentication) So anytime a client that uses plesk server to send emails sends one to me it gets bounced because plesk doesnt check the actual MX record it just looks at the domain. If I setup mailboxes on my domain and try to send. It will go through but the mail will go to the mail box at plesk and not back to my exchange server.

    So then I have to setup a POP connector in Exchange to get all the mail from my clients. Is there a way to tell Plesk to check the actual MX record before presuming that it controls mail for any domain that it hosts.
     
  2. dietcheese

    dietcheese Guest

    0
     
    I have the same situation.

    I suspect that for some reason the DNS settings in Plesk are not being activated. When I dig the domain in question on the server, DNS records that do not match the ones in Plesk come up.

    DC
     
  3. JointTech

    JointTech New Pleskian

    22
    57%
    Joined:
    Mar 12, 2007
    Messages:
    12
    Likes Received:
    0
    Actually, if you just go into the mail area in the domain click the button to disable mail. then Plesk will use the MX record and everything is fine.
     
  4. dietcheese

    dietcheese Guest

    0
     
    Tried that first, it doesn't work.

    I had just migrated from a 7.5.4 server to 8.1. During the migration plesk activated e-mail for all the domains that I had deactivated it for (thanks Plesk again for you migration manager nightmare). I went in and manually disabled it for all domains that used external mail services. Still no luck.

    Any other ideas?

    I think it has to do with DNS, which is coming up wrong when I >dig mx domain.com.

    DC
     
  5. dietcheese

    dietcheese Guest

    0
     
    For example:

    <lee@domain.com>:
    Sorry. Although I'm listed as a best-preference MX or A for that host, it isn't in my control/locals file, so I don't treat it as local. (#5.4.6)

    > dig mx domain.com

    ;; QUESTION SECTION:
    ;domain.com. IN MX

    ;; ANSWER SECTION:
    domain.com. 80946 IN MX 10 mail.domain.com.

    ;; AUTHORITY SECTION:
    domain.com. 80946 IN NS ns.domain.com.

    ;; ADDITIONAL SECTION:
    mail.domain.com. 80946 IN A 15.15.15.15
    ns.domain.com. 82631 IN A 15.15.15.15


    Plesk:

    15.15.15.15 / 24 PTR domain.com.
    ftp.domain.com. CNAME domain.com.
    owa.domain.com. A 25.15.15.15
    domain.com. NS dns.server1.com.
    domain.com. NS dns.server2.com.
    domain.com. A 15.15.15.15
    domain.com. MX (10) smtp1.msp.securence.com.
    domain.com. MX (10) smtp1.mke.securence.com.
    www.domain.com. CNAME domain.com.

    ???
     
  6. JointTech

    JointTech New Pleskian

    22
    57%
    Joined:
    Mar 12, 2007
    Messages:
    12
    Likes Received:
    0
    Hmm. Well I don't know anything about that unfortunately. I was having the problem only until I turned off mail for the domains with Exchange servers.
     
  7. dirty@

    dirty@ Guest

    0
     
    > domain.com. 80946 IN MX 10 mail.domain.com.
    > domain.com. 80946 IN NS ns.domain.com.
    >
    > Plesk:
    >domain.com. NS dns.server1.com.
    >domain.com. NS dns.server2.com.
    >domain.com. MX (10) smtp1.msp.securence.com.
    > domain.com. MX (10) smtp1.mke.securence.com.


    what is in your /etc/resolv.conf? check what domain's MX/NS are shown with

    # host -tmx domain.com 127.0.0.1
    and
    # host -tmx domain.com

    for me it seems that your box uses some external name server instead of local..
     
Loading...