1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk Panel - 500 Internal Server Error

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by AlecM, Aug 12, 2009.

  1. AlecM

    AlecM Guest

    0
     
    I'm getting a 500 Internal Server error, right after I login. I was searching the forums I ran a few commands that I saw frequently through SSH.

    Code:
    /usr/bin/sw-engine-cgi -c /usr/local/psa/admin/conf/php.ini -d auto_prepend_file=auth.php3 -u psaadm
    Code:
    HP Notice:  Undefined index:  REQUEST_URI in /usr/local/psa/admin/auto_prepend/auth.php3 on line 30
    PHP Warning:  file_get_contents(/etc/psa/.psa.shadow) [<a href='function.file-get-contents'>function.file-get-contents</a>]: failed to open stream: Permission denied in /usr/local/psa/admin/plib/common_func.php3 on line 385
    Status: 500 PleskFatalException
    Expires: Fri, 28 May 1999 00:00:00 GMT
    Last-Modified: Wed, 12 Aug 2009 19:59:45 GMT
    Cache-Control: no-store, no-cache, must-revalidate
    Cache-Control: post-check=0, pre-check=0
    Pragma: no-cache
    P3P: CP="NON COR CURa ADMa OUR NOR UNI COM NAV STA"
    Content-type: text/plain; charset=utf-8
    
    ERROR: PleskFatalException
    Unable to connect to database: get_admin_password() failed: file_get_contents() failed: mktime() [<a href='function.mktime'>function.mktime</a>]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead
    
    0: common_func.php3:108
    	psaerror(string 'Unable to connect to database: get_admin_password() failed: file_get_contents() failed: mktime() [<a href='function.mktime'>function.mktime</a>]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead')
    1: auth.php3:93
    
    Code:
    df -h
    Code:
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/vzfs              45G  8.3G   37G  19% /
    /dev/vzfs             100M  106K  100M   1% /tmp
    none                   16G  4.0K   16G   1% /dev
    tmpfs                  16G     0   16G   0% /usr/local/psa/handlers/before-local
    tmpfs                  16G     0   16G   0% /usr/local/psa/handlers/before-queue
    tmpfs                  16G     0   16G   0% /usr/local/psa/handlers/before-remote
    tmpfs                  16G     0   16G   0% /usr/local/psa/handlers/info
    tmpfs                  16G   80K   16G   1% /usr/local/psa/handlers/spool
    
     
  2. lvalics

    lvalics Silver Pleskian Plesk Guru

    36
    43%
    Joined:
    Jun 20, 2003
    Messages:
    965
    Likes Received:
    32
    Location:
    Romania
    See /etc/psa/.psa.shadow file, that keep the password, seems is not there??
     
  3. Maa

    Maa Guest

    0
     
    Yep.
    Error states that psaadm lacks permissions for .psa.shadow

    Is it present there?

    I have picture like this:

    # ls -la /etc/psa/.psa.shadow
    -rw------- 1 psaadm psaadm 6 Apr 17 07:51 /etc/psa/.psa.shadow
     
Loading...