1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk Restore - Fails everytime :(

Discussion in 'Plesk for Windows - 8.x and Older' started by LeaUK, Aug 12, 2007.

  1. LeaUK

    LeaUK Guest

    0
     
    Has anyone had success with the restore facility?

    I'm trying to restore to a VM, same HDD partitions and drive letters etc.

    Plesk restore successfully restores a few domains, but most it simply fails. Am I doing something wrong?

    Regards
    Lea
     
  2. LeaUK

    LeaUK Guest

    0
     
    I'm going to try and hot image both partitions to get them across into the VM, then perhaps the restore will operate correctly from one VM to another identical.

    Lea
     
  3. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Please try to increase VM's memory.

    Which error message?
     
  4. LeaUK

    LeaUK Guest

    0
     
    sergius

    many thanks for your reply.

    error messages are as follows (not all domains but the majority):

    Unable to perform action 'Turn off domain xxx.uk'

    Error in execute ''domainmng' --turn-off "--domain-name=xxx.uk"':
    Execute usermng access off failed: Unable to get the user (xx) home: (2221) The user name could not be found.

    The users do not exist on the machine which confuses me - and confuses PLesk Restore. I suspect this is the problem.

    Is there a way to reset Plesk? Maybe reinstall then use Plesk Restore?

    Thanks
    Lea
     
  5. LeaUK

    LeaUK Guest

    0
     
    I recreated the VM to ensure all users were present.

    "Unable to perform action 'Turn off domain xxx.uk'"

    is now resolved. However I now receive:

    "Unable to perform action 'Reconfigure Web services for restored domains'"

    From the plesk logs:

     
  6. LeaUK

    LeaUK Guest

    0
     
    Resolved - I think!

    Problems all stemmed from a permissions issue.

    When the VM was created using P2V tool the drive hosting the Virtual Domains could not be incorporated to the VM image. Therefore the VM only had C:\

    This VM was then split into C: and D:\ using disk tools. D:\ stores the virtual domains.

    Of course D: did not have the correct Plesk permissions.

    Using Plesk Reconfigurator > Repair Plesk, permissions were reset correctly.

    However Restore continued to fail.

    This is due to the control panel having the domains loaded but the data NOT being present in the Virtual host folder.

    Virtual hosts domain data was copied from the physical 'host' to the VM and Plesk Reconfigurator > Plesk virtual host security application run. Many explanation marks!

    Run Plesk Restore again - no problems reported :)

    Plesk Control Panel reports no problems and can find all files.

    Hope this helps someone...
    Lea
     
  7. LeaUK

    LeaUK Guest

    0
     
    "Unable to perform action 'Turn off domain xxxx.co.uk'

    Plesk Restore reports:

    "Unable to perform action 'Turn off domain xxxx.co.uk'

    Error in execute ''domainmng' --turn-off "--domain-name=xxxx.co.uk"':
    Execute usermng access off failed: Unable to get the user (xxxx) home: (2221) The user name could not be found."


    I have only ever managed a full restore without issues once, and wonder what's going wrong.

    The message above is reported on around 10% of my domains!

    Even if I run the 'Check and Repair' before (which always shows problems unless it's run twice) a restore, the restore still fails.

    Please help as I would like to migrate domains across servers.

    Cheers
    Lea
     
  8. LeaUK

    LeaUK Guest

    0
     
    I could really do with some assistance here chaps. Any thoughts?

    Cheers
    Lea
     
  9. primoco

    primoco Guest

    0
     
    Hi how have resolved?
    You want migrate i want just restore on the same servers and have same problems.
     
  10. LeaUK

    LeaUK Guest

    0
     
    I ended up purchasing support as I have around 5 serious issues that require resolving.

    This one hasn't been resolved as yet, although to be fair I haven't raised it!

    Lea
     
Loading...