1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Plesk Stopped Working - Plesk Default Pool problem

Discussion in 'Plesk for Windows - 8.x and Older' started by eugenevdm, Jul 14, 2005.

  1. eugenevdm

    eugenevdm Silver Pleskian

    30
    68%
    Joined:
    Nov 11, 2003
    Messages:
    611
    Likes Received:
    0
    I installed Crystal Reports on my Plesk 7.5.3 server, and after a reboot that was required for the installation, Plesk and all our customer web sites stopped working.

    I get the following error in the event log every two minutes:

    A process serving application pool 'plesk(default)(pool)' failed to respond to a ping. The process id was '2288'.

    There appears to be a related event a few seconds after this one, namely:

    Application popup: Warning : Unknown(): Unable to load dynamic library 'C:\Program Files\SWsoft\Plesk\Additional\Php\extensions\php_curl.dll' - The operating system cannot run Warning.

    As a precaution to having many unhappy clients I removed Crystal Report to see what happens. BUT THE PROBLEM IS STILL THERE!

    Does anyone have experience with this problem?
     
  2. JAFO@

    JAFO@ Guest

    0
     
    Try to repair your plesk installation. (Add/remove programs / plesk / change / repair)
     
  3. eugenevdm

    eugenevdm Silver Pleskian

    30
    68%
    Joined:
    Nov 11, 2003
    Messages:
    611
    Likes Received:
    0
    Through hook and by crook I managed to sort this out.

    The big panic was that IIS didn't work, I wasn't worried about Plesk for the moment, but I didn't think about stopping Plesk services.

    Don't ask my what exactly made it work again, but amongst other things I tried:

    0. Removed Crystal and rebooted. No luck.

    1. Repairing Plesk via Add / Remove programs. This didn't seem to sort it out.

    2. Rebooting many times. This didn't do anything.

    3. Renaming the DLL. This didn't work.

    4. Checking permissions according to this:
    http://www.jsifaq.com/SUBQ/tip8400/rh8493.htm
    No luck here.

    5. Restoring IIS configuration using the Right Click servername, All Tasks - Restore option. No luck here.

    6. Removing PHP from the installation. No luck.

    7. Removing all ISAPI filters and Web extensions.

    Finally when I stopped the Plesk Managament service IIS started working. I stopped all the other Plesk services as well but stopping this one did the trick.

    I then started all the other services again, which made it start the Management service, but hereafter everything was fine.

    Panic over.
     
  4. louisen

    louisen Guest

    0
     
    I had this problem too. I installed Cyrystal Reports on Plesk 7.5 / Windows 2003 and some of my sites stopped working. Removing the ISAPI filters did the trick for me. I had the same message about php_curl.dll not being able to load, so when I saw php4isapi.dll listed as an ASAPI filter I removed it and my sites immediately began to work again.
     
  5. futec

    futec Guest

    0
     
    Hi there,

    I currently have the same problem. All websites works now *except* the PHP coded websites.

    I get the same messages but I cannot find where to remove the ISAPI filters. If I check at the properties of a single (not working) website I don't see any ISAPI filters there.

    Maybe I don't look in the right direction...

    Can anyone give me a hand?

    Thanks in advance.

    Regards,

    Futec

    EDIT:
    I disabled
    extension=php_curl.dll
    in php.ini and it is fixed!
     
  6. eugenevdm

    eugenevdm Silver Pleskian

    30
    68%
    Joined:
    Nov 11, 2003
    Messages:
    611
    Likes Received:
    0
    In retrospect I wouldn't recommend doing all that I stuff I did before ... there is an easier way ... it's documented elsewhere in this forum ... there is some weird registry setting which you have to make blank.
     
  7. louisen

    louisen Guest

    0
     
    This is for Win 2003, IIS 6. I'm not sure what it would be for other configurations.

    1) Log in to the server via remote desktop, then open up IIS manager.

    2) Go to web sites

    3) Right click on a PHP enabled website

    4) Select Properties.

    5) Click on ISAPI tab

    6) Remove php filters

    7) Repeat for all php websites
     
Loading...