1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

plesk update to 8.3.0

Discussion in 'Plesk for Linux - 8.x and Older' started by amit290, Feb 7, 2008.

  1. amit290

    amit290 Basic Pleskian

    24
    23%
    Joined:
    Dec 9, 2006
    Messages:
    56
    Likes Received:
    0
    Hi, I hope someone can help. I updated to Plesk 8.3.0 when it came out. I then had the problem of the installer unable to find my key, so I followed the KB 3543 instructions and now I'm able to get back into the updater.

    After logging into Plesk and going to "Update" I see an orange icon next to Plesk 8.3.0 and it says its updating or adding components. I've logged in via SSH and no autoinstaller is running. I've gone back to Plesk and clicked on Install. It says I'll get an email when everything has been installed but although it says "Success Report" in the email subject, the plesk updater still shows up as orange.

    Here is the success report e-mail I got

    It says at the bottom I didnt specify a component to install but the "Base Package" and "Plesk Updater" were automatically ticked and greyed out. I've also tried ticking Ruby on Rails for installation to see if this will somehow force everything else to be updated but it doesnt.

    Hope someone can help.
     
  2. pIeskyrabbit

    pIeskyrabbit Guest

    0
     
    ugh

    I have the exact same problem. Did you manage to find a solution? I am seeing some other problems with the server as a result of this this incomplete base install. There does not appear to be any way to back out of the upgrade.
     
  3. pIeskyrabbit

    pIeskyrabbit Guest

    0
     
    here are my responses... first "success" THEN "failure" right after

    Everytime I try to run the update now that I'm hosed in a bad 8.3.0 upgrade, I see the following two emails one after the other. The first is titled "Plesk autoupdate success report"

    Autoinstaller 3.3.0 (build at 2008-02-01 09:54 svn rev. 94250) started at (timezone EST) Sun Mar 9 12:55:04 2008
    Command line args: /usr/local/psa/admin/bin/autoinstaller --enable-xml-output --source-type=plesk --target=/root/psa --select-release-id=PLESK_8_3_0 --notify-email=trineorph-pleskconsole@yahoo.com --install-component=psa-autoinstaller --no-daemon

    Try to find rcfile...
    Autoinstaller rcfile not found.
    Checking hostname is sucessfull.
    Opsys detected as: os_name=FreeBSD os_vendor=FreeBSD version=6.2 arch=i386 environment=
    Final opsys (with overriding) is: os_name=FreeBSD os_vendor=FreeBSD version=6.2 arch=i386 environment=
    Downloading the file products.inf3: 100% done.
    Downloading the file plesk.inf3: 100% done.
    Downloading the file sitebuilder.inf3: 100% done.
    Downloading the file sso.inf3: 22%..100% done.
    repository: Get brief packages info for all sources
    Checking for installed packages...
    release PLESK_8_3_0 is actual
    release SB_4_1_0 is actual
    Release SB_3_0_0 contains no any build for this OS
    Release SB_3_0_1 contains no any build for this OS
    release SB_3_0_2 is actual
    release SB_4_0_0 is actual
    release SSO_2_0 is actual
    Select best build of PLESK_8_3_0 for current OS
    First fit build is current best: PSA_8.3.0/plesk-8.3.0-fr6.1-i386.inf3
    Select best build: finally choised PSA_8.3.0/plesk-8.3.0-fr6.1-i386.inf3
    Downloading the file PSA_8.3.0/plesk-8.3.0-fr6.1-i386.inf3: 100% done.
    No removers section in this build.
    No preferrers section in this build.
    Preparing ports for product installation:
    Removing unnecessary packages from the system.
    Remove package gcc_plesk_bsd if it installed...done
    Preparing ports for product installation:
    Notice: make.conf was restored from previous autoinstaller's backup.
    Set options for FreeBSD ports...
    done
    Deploying product ports...
    Downloading the file PSA_8.3.0/dist-pkg-FreeBSD-6.1-i386/ports/ports-common-1.0.0.tar.gz: 100% done.
    Downloading the file PSA_8.3.0/dist-pkg-FreeBSD-6.1-i386/ports/psa-ports-8.3.0.tar.gz: 34%..98%..100% done.
    done
    Installing port 'swsoft/ports-common'...done
    repository: Get brief packages info for all sources
    Detecting installed product components.
    Component base: mode up2date, installed=0, available=1202105081
    Component psa-autoinstaller: mode up2date, installed=0, available=1202105113
    Component postgresql: mode upgrade, installed=0, available=1198140769
    Component vault: mode upgrade, installed=0, available=1198140817
    Component docs: mode upgrade, installed=0, available=1198140813
    Component ppwse: mode upgrade, installed=0, available=1198140788
    Component api: mode up2date, installed=0, available=1202105091
    Component pmm: mode up2date, installed=0, available=1202105100
    Component sb-publish: mode install, installed=0, available=1198140957
    Component sbm: mode install, installed=0, available=1198141080
    Component miva: mode install, installed=0, available=1198140961
    Component mod-bw: mode install, installed=0, available=1198140966
    Component asp: mode up2date, installed=0, available=1198140780
    Component java: mode install, installed=0, available=1198140766
    Failed to retrieve the port creation time from /usr/ports/swsoft/mod_python/Makefile
    Component mod_python: mode install, installed=0, available=0
    Component ruby: mode install, installed=0, available=1198140944
    Component fcgi: mode upgrade, installed=0, available=1198140941
    Component php4: mode up2date, installed=0, available=1198140937
    Component php5: mode up2date, installed=0, available=1198140937
    Component psa-firewall: mode up2date, installed=0, available=1198141055
    Component psa-vpn: mode up2date, installed=0, available=1198141068
    Component psa-fileserver: mode up2date, installed=0, available=1198141050
    Component sshterm: mode upgrade, installed=0, available=1198140784
    Component watchdog: mode up2date, installed=0, available=1202105107
    Component mailman: mode upgrade, installed=0, available=1198140809
    Component kav: mode up2date, installed=0, available=1198141073
    Component drweb: mode upgrade, installed=0, available=1198140760
    Component spamassassin: mode upgrade, installed=0, available=1198140776
    Component rblsmtpd: mode up2date, installed=0, available=1198140757
    Component backup-ded: mode upgrade, installed=0, available=1202105095
    Component de-DE-locale: mode upgrade, installed=0, available=1200046051
    Component ja-JP-locale: mode upgrade, installed=0, available=1200046115
    Component es-ES-locale: mode upgrade, installed=0, available=1200046073
    Component ru-RU-locale: mode upgrade, installed=0, available=1200046131
    Component fr-FR-locale: mode upgrade, installed=0, available=1200046087
    Component it-IT-locale: mode upgrade, installed=0, available=1200046101
    Component zh-CN-locale: mode upgrade, installed=0, available=1200046148
    Component zh-TW-locale: mode upgrade, installed=0, available=1200046163
    Warning: following component(s) not found: 'psa-autoinstaller'
    You did not specify the components to install.
    Notice: make.conf was restored from previous autoinstaller's backup.
    Notice: remove orphaned temporary directory /usr/ports/tmp_extract_ports_R2zJUZ
    Notice: remove orphaned temporary directory /usr/ports/tmp_extract_ports_qEebd1
    Notice: remove orphaned temporary directory /usr/ports/tmp_extract_ports_yc1QeI
    Notice: remove orphaned temporary directory /usr/ports/tmp_extract_ports_r3tgEZ
    Notice: remove orphaned temporary directory /usr/ports/tmp_extract_ports_c0KwhA
    Notice: remove orphaned temporary directory /usr/ports/tmp_extract_ports_FywoKq
    Notice: remove orphaned temporary directory /usr/ports/tmp_extract_ports_omDbgr
    Notice: remove orphaned temporary directory /usr/ports/tmp_extract_ports_FiB86f
    Notice: remove orphaned temporary directory /usr/ports/tmp_extract_ports_nBqvSt
    Notice: remove orphaned temporary directory /usr/ports/tmp_extract_ports_SXXMkL
    Notice: remove orphaned temporary directory /usr/ports/tmp_extract_ports_vGcnr2
    Notice: remove orphaned temporary directory /usr/ports/tmp_extract_ports_VSEt6v
    Notice: remove orphaned temporary directory /usr/ports/tmp_extract_ports_qeCCkQ
    Notice: remove orphaned temporary directory /usr/ports/tmp_extract_ports_ZRz5T4
    ---
    Plesk autoinstaller.
     
  4. pIeskyrabbit

    pIeskyrabbit Guest

    0
     
    Two minutes later...

    Two minutes later I get another email except the title is now "Plesk autoupdate failure report" -- talk about confusing...

    Autoinstaller 3.3.0 (build at 2008-02-01 09:54 svn rev. 94250) started at (timezone EST) Sun Mar 9 12:55:21 2008
    Command line args: /usr/local/psa/admin/bin/autoinstaller --enable-xml-output --source-type=plesk --target=/root/psa --select-release-id=PLESK_8_3_0 --notify-email=trineorph-pleskconsole@yahoo.com --install-component=base --install-component=backup-ded

    Try to find rcfile...
    Autoinstaller rcfile not found.
    Checking hostname is sucessfull.
    Opsys detected as: os_name=FreeBSD os_vendor=FreeBSD version=6.2 arch=i386 environment=
    Final opsys (with overriding) is: os_name=FreeBSD os_vendor=FreeBSD version=6.2 arch=i386 environment=
    Downloading the file products.inf3: 100% done.
    Downloading the file plesk.inf3: 100% done.
    Downloading the file sitebuilder.inf3: 100% done.
    Downloading the file sso.inf3: 22%..100% done.
    repository: Get brief packages info for all sources
    Checking for installed packages...
    release PLESK_8_3_0 is actual
    release SB_4_1_0 is actual
    Release SB_3_0_0 contains no any build for this OS
    Release SB_3_0_1 contains no any build for this OS
    release SB_3_0_2 is actual
    release SB_4_0_0 is actual
    release SSO_2_0 is actual
    Select best build of PLESK_8_3_0 for current OS
    First fit build is current best: PSA_8.3.0/plesk-8.3.0-fr6.1-i386.inf3
    Select best build: finally choised PSA_8.3.0/plesk-8.3.0-fr6.1-i386.inf3
    Downloading the file PSA_8.3.0/plesk-8.3.0-fr6.1-i386.inf3: 100% done.
    No removers section in this build.
    No preferrers section in this build.
    Preparing ports for product installation:
    Removing unnecessary packages from the system.
    Remove package gcc_plesk_bsd if it installed...done
    Preparing ports for product installation:
    Set options for FreeBSD ports...
    done
    Deploying product ports...
    Downloading the file PSA_8.3.0/dist-pkg-FreeBSD-6.1-i386/ports/ports-common-1.0.0.tar.gz: 100% done.
    Downloading the file PSA_8.3.0/dist-pkg-FreeBSD-6.1-i386/ports/psa-ports-8.3.0.tar.gz: 41%..100% done.
    done
    Installing port 'swsoft/ports-common'...done
    repository: Get brief packages info for all sources
    Detecting installed product components.
    Component base: mode up2date, installed=0, available=1202105081
    Component psa-autoinstaller: mode up2date, installed=0, available=1202105113
    Component postgresql: mode upgrade, installed=0, available=1198140769
    Component vault: mode upgrade, installed=0, available=1198140817
    Component docs: mode upgrade, installed=0, available=1198140813
    Component ppwse: mode upgrade, installed=0, available=1198140788
    Component api: mode up2date, installed=0, available=1202105091
    Component pmm: mode up2date, installed=0, available=1202105100
    Component sb-publish: mode install, installed=0, available=1198140957
    Component sbm: mode install, installed=0, available=1198141080
    Component miva: mode install, installed=0, available=1198140961
    Component mod-bw: mode install, installed=0, available=1198140966
    Component asp: mode up2date, installed=0, available=1198140780
    Component java: mode install, installed=0, available=1198140766
    Failed to retrieve the port creation time from /usr/ports/swsoft/mod_python/Makefile
    Component mod_python: mode install, installed=0, available=0
    Component ruby: mode install, installed=0, available=1198140944
    Component fcgi: mode upgrade, installed=0, available=1198140941
    Component php4: mode up2date, installed=0, available=1198140937
    Component php5: mode up2date, installed=0, available=1198140937
    Component psa-firewall: mode up2date, installed=0, available=1198141055
    Component psa-vpn: mode up2date, installed=0, available=1198141068
    Component psa-fileserver: mode up2date, installed=0, available=1198141050
    Component sshterm: mode upgrade, installed=0, available=1198140784
    Component watchdog: mode up2date, installed=0, available=1202105107
    Component mailman: mode upgrade, installed=0, available=1198140809
    Component kav: mode up2date, installed=0, available=1198141073
    Component drweb: mode upgrade, installed=0, available=1198140760
    Component spamassassin: mode upgrade, installed=0, available=1198140776
    Component rblsmtpd: mode up2date, installed=0, available=1198140757
    Component backup-ded: mode upgrade, installed=0, available=1202105095
    Component de-DE-locale: mode upgrade, installed=0, available=1200046051
    Component ja-JP-locale: mode upgrade, installed=0, available=1200046115
    Component es-ES-locale: mode upgrade, installed=0, available=1200046073
    Component ru-RU-locale: mode upgrade, installed=0, available=1200046131
    Component fr-FR-locale: mode upgrade, installed=0, available=1200046087
    Component it-IT-locale: mode upgrade, installed=0, available=1200046101
    Component zh-CN-locale: mode upgrade, installed=0, available=1200046148
    Component zh-TW-locale: mode upgrade, installed=0, available=1200046163
    Warning: following component(s) not found: 'base'
    KeyUpdateChecker::doCheck: no components for check key update

    Getting packages to installation list:
    Get packages to installation from selected component backup-ded
    Check package set before installation
    Starting installation of packages
    Adding product ports descriptions to ports index...
    done
    Updating ports binary index.
    Updating the packages database using the pkgdb utility...
    Set options for FreeBSD ports...
    done
    Removing conflicting packages...
    Update system packages (it can take a long time)...
    Starting installation of packages
    ===> Install pre-depends for psa-backup-manager-8.3.0_94282:
    ===> Create list of depends for: psa-backup-manager-8.3.0_94282
    ................................................................................................................................................................................................................................................................................Very deep recursion
    *** Error code 1

    Stop in /usr/ports/swsoft/psa-backup-manager.
    *** Error code 1

    Stop in /usr/ports/swsoft/psa-backup-manager.
    *** Error code 1

    Stop in /usr/ports/swsoft/psa-backup-manager.
    *** Error code 1

    Stop in /usr/ports/swsoft/psa-backup-manager.
    *** Error code 1

    Stop in /usr/ports/swsoft/psa-backup-manager.
    *** Error code 1

    Stop in /usr/ports/swsoft/psa-backup-manager.
    *** Error code 1

    Stop in /usr/ports/swsoft/psa-backup-manager.
    *** Error code 1

    Stop in /usr/ports/swsoft/psa-backup-manager.
    *** Error code 1

    Stop in /usr/ports/swsoft/psa-backup-manager.
    *** Error code 1

    Stop in /usr/ports/swsoft/psa-backup-manager.
    *** Error code 1

    Stop in /usr/ports/swsoft/psa-backup-manager.
    *** Error code 1

    Stop in /usr/ports/swsoft/psa-backup-manager.
    *** Error code 1

    Stop in /usr/ports/swsoft/psa-backup-manager.
    *** Error code 1

    Stop in /usr/ports/swsoft/psa-backup-manager.
    *** Error code 1

    Stop in /usr/ports/swsoft/psa-backup-manager.
    *** Error code 1

    Stop in /usr/ports/swsoft/psa-backup-manager.
    *** Error code 1

    Stop in /usr/ports/swsoft/psa-backup-manager.
    Notice: make.conf was restored from previous autoinstaller's backup.
    ERROR: Errors occurred during installation of a package from the port swsoft/psa-backup-manager.
    Attention! Your software might be inoperable.
    Please, resolve the above problem and try installing the packages again.
    If you cannot resolve the problem on your own, contact product technical support for assistance.


    ---
    Plesk autoinstaller.
     
  5. amit290

    amit290 Basic Pleskian

    24
    23%
    Joined:
    Dec 9, 2006
    Messages:
    56
    Likes Received:
    0
    Nope never found a solution ! I got my server upgraded from a Fedora Core 4, to CentOS5 a couple of weeks ago so although not a resolution, it did fix the problem for me :)
     
  6. pIeskyrabbit

    pIeskyrabbit Guest

    0
     
    Indeed. I'm on the O/S that the PLESK install team recommended. Are any of those folks on here? I'm thinking a ticket may do a better job that just asking the forum in general.
     
  7. Highland

    Highland Guest

    0
     
    Have you tried upgrading via yum instead?
     
  8. Smarti

    Smarti Guest

    0
     
    ME too! same problem driving me nuts on fedora 6 platform, just so happened I upgraded to plesk 8.3 from 8.2 on same day as yum update, so I assumed it was the yum update giving me trouble.

    My server has been bouncing over 200 emails a day from my server telling me sitebuilder is trying to run a cron job and a directory is missing: (I dont use sitebuilder never have)

    Subject: Cron <apache@www> /usr/sbin/moodle-cron
    Content-Type: text/plain; charset=UTF-8
    Auto-Submitted: auto-generated
    X-Cron-Env: <SHELL=/bin/sh>
    X-Cron-Env: <HOME=/var/www>
    X-Cron-Env: <PATH=/usr/bin:/bin>
    X-Cron-Env: <LOGNAME=apache>
    X-Cron-Env: <USER=apache>

    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/sitebuilder3.so' - /usr/lib/php/modules/sitebuilder3.so: cannot open shared object file: No such file or directory in Unknown on line 0
    <html><body><table align="center"><tr><td style="color:#990000; text-align:center; font-size:large; border-width:1px; border-color:#000000; border-style:solid; border-radius: 20px; border-collapse: collapse; -moz-border-radius: 20px; padding: 15px"><p>Error: Database connection failed.</p><p>It is possible that the database is overloaded or otherwise not running properly.</p><p>The site administrator should also check that the database details have been correctly specified in config.php</p></td></tr></table></body></html>

    first I thought it was the yum update but finally figured out " remembered plesk" few hours ago..

    Orange tag on updater - base packages green but ticked tries to update but doesn`t

    plesk updater tries to update but gives fatal error even though green but ticked:

    AutoInstallerManager::install() failed: domxml_open_mem() failed: Welcome to the SWsoft Product Installation Wizard===============================================================================Plesk(tm) software simplifies the configuration and management of UNIX- andLinux-based web servers. Feel the power of Plesk(tm).SWsoft has developed this installer to assist you with installing or upgradingthe Plesk(tm) software onto your server. IMPORTANT NOTES:New installations of Plesk(tm) should be performed on cleanservers only; Specifically only the Operating System with the Networking optionshould be installed for new installations.This installer can also be used to upgrade existing product installations to thelatest versions. We highly recommend that a backup of the system be performedprior to upgrading your software.SWsoft, Inc. will not be held liable for damages as a result of installing Plesk(tm)on a server with anything other than a fresh installation of the operatingsystem for which the Plesk(tm) installation was intended. By using this installer youagree to the terms and conditions as described onhttp://www.swsoft.com/en/company/terms/ and those of the Plesk End Users LicenseAgreement.N) Next page; Q) Cancel installingSelect action [N]: <?xml version="1.0" encoding="UTF-8" standalone="yes" ?><autoinstaller status="error" error_message="End of user input.
    Not all packages were installed.
    Please try installing packages again later.
    Please, resolve the above problem and try installing the packages again." />

    --------------------------------------------------------------------------------

    0: /usr/local/psa/admin/plib/common_func.php3:158
    psaerror(string 'AutoInstallerManager::install() failed: domxml_open_mem() failed: Welcome to the SWsoft Product Installation Wizard===============================================================================Plesk(tm) software simplifies the configuration and management of UNIX- andLinux-based web servers. Feel the power of Plesk(tm).SWsoft has developed this installer to assist you with installing or upgradingthe Plesk(tm) software onto your server. IMPORTANT NOTES:New installations of Plesk(tm) should be performed on cleanservers only; Specifically only the Operating System with the Networking optionshould be installed for new installations.This installer can also be used to upgrade existing product installations to thelatest versions. We highly recommend that a backup of the system be performedprior to upgrading your software.SWsoft, Inc. will not be held liable for damages as a result of installing Plesk(tm)on a server with anything other than a fresh installation of the operatingsystem for which the Plesk(tm) installation was intended. By using this installer youagree to the terms and conditions as described onhttp://www.swsoft.com/en/company/terms/ and those of the Plesk End Users LicenseAgreement.N) Next page; Q) Cancel installingSelect action [N]: <?xml version="1.0" encoding="UTF-8" standalone="yes" ?><autoinstaller status="error" error_message="End of user input.
    Not all packages were installed.
    Please try installing packages again later.
    Please, resolve the above problem and try installing the packages again." />')
    1: /usr/local/psa/admin/htdocs/server/autoinstaller_install.php:115

    anybody care to comment....seems like a bug to me. (on second yum update as of today no fix)
     
  9. tiramisu_

    tiramisu_ Guest

    0
     
    rpm-based and port-based systems differ.

    generally, if you updated Plesk with the latest version of installer from ftp://download1.swsoft.com/Plesk/Plesk8.3

    and that was successful, report was 'success'

    then you may just check this with: --show-components option of installer

    i believe in this case all is fine with your Plesk

    but 'error' report means there is smth wrong

    for *bsd system it is better to follow recommended instructions.
     
  10. pIeskyrabbit

    pIeskyrabbit Guest

    0
     
    My problem is still outstanding. I was able to manually run all my updates, so it's not that. I suspect there is something wrong with the version of DBD:mySQL (or at least now that this library is included in the version of PERL that I was upgraded to by PLESK) and this causes my CGI applications that rely on it to fail (core dump with a segmentation fault error of 11). The error_log indicates the header information was missing, but that appears to also be due to the core dump. Very frustrated.
     
Loading...