1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk upgrade from 8.6 to 9.01 on CentOS 5 not working

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by Eric Way, Apr 25, 2009.

  1. Eric Way

    Eric Way Guest

    0
     
    When I run the updater to try to upgrade my Plesk control panel to 9.0.1 from 8.6.0, I get this error:

    Warning: unresolved requires '/usr/bin/lp' from redhat-lsb-3.1-12.3.EL.el5.centos.i386 (s 0x8a83250 source=0x8735d18 P:27 R:154)
    Warning: unresolved requires '/usr/bin/lpr' from redhat-lsb-3.1-12.3.EL.el5.centos.i386 (s 0x8a83250 source=0x8735d18 P:27 R:154)
    A dependency problem is found: an older version of required package psa-9.0.1-cos5.build90090127.18.i586 (b 0x94f1e18 source=0x88019a0 P:3636 R:87) is installed (psa-8.6.0-rhel5.build86080722.01.i586 (s 0x916dc18 source=0x8735d18 P:3868 R:123)) . After upgrade procedure the dependency 'psa-security = 8.0' of package psa-watchdog-2.0.3-rhel5.build86080722.01.i586 (s 0x8a1c0f8 source=0x8735d18 P:273 R:38) will be unresolved. Try to add to removable list psa-watchdogFailed to check whether it is necessary to upgrade psa-watchdog-2.0.3-rhel5.build86080722.01.i586 (s 0x8a1c0f8 source=0x8735d18 P:273 R:38) along with upgrade of psa-8.6.0-rhel5.build86080722.01.i586 (s 0x916dc18 source=0x8735d18 P:3868 R:123) by psa-9.0.1-cos5.build90090127.18.i586 (b 0x94f1e18 source=0x88019a0 P:3636 R:87)Problem occured during searching indirect dependencies for package psa-9.0.1-cos5.build90090127.18.i586 (b 0x94f1e18 source=0x88019a0 P:3636 R:87)ERROR: Unable to proceed with the installation until the package psa-watchdog-2.0.3-rhel5.build86080722.01.i586 (s 0x8a1c0f8 source=0x8735d18 P:273 R:38) is removed from the system.
    Not all packages were installed.
    Please, resolve the above problem and try installing the packages again.
    If you cannot resolve the problem on your own, contact product technical support for assistance.

    ^^^
    I'm running centos 5. The lp and lpr commands appear to be installed and functioning on my system.
     
  2. 105547111

    105547111 Silver Pleskian

    32
    30%
    Joined:
    Jul 13, 2006
    Messages:
    643
    Likes Received:
    2
    I see it mainly is winging about psa-watchdog.

    So remove psa-watchdog then try the upgrade. Then you simply add in watchdog from the installer afterwards.
     
Loading...