1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

POP-Before SMTP "database is locked"

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by aubergine22, Jan 14, 2009.

  1. aubergine22

    aubergine22 Guest

    0
     
    Hello,

    i just updated Plesk from a 8.x to 9.0.
    Nearly everything works, but pop-before-smtp doesnt work anymore.

    The problem is a bit strange:

    When i access the psa database manually with phpmyadmin i can insert and delete rows from the table "smtp_poplocks" withour any problems. So i think this is a problem in/with the courier-imap configuration.

    relaylock does have the same problem:

    Does anyone have an idea?

    best regards

    Dominik
     
  2. dvdpa

    dvdpa Guest

    0
     
    I am having the same issue...
    update_smtp_lock: Unable to prepare SQL statement, smtp-lock will not work: database is locked

    ????


    Chuck
     
  3. CCHickman

    CCHickman Regular Pleskian

    25
    40%
    Joined:
    Oct 11, 2003
    Messages:
    112
    Likes Received:
    0
    I wanted to add that I'm receiving this also...

    I cannot be certain if this was due to the 9.0.0.2 > 9.0.1 upgrade, but I have been noticing it in the past few days only.

    I also looked at the DB, removed and added lines -- there doesn't appear to be anything wrong with the database.

    I'm curious -- I'm running CentOS4 and MySQL 5.x -- are the other users having this problem running the stock version of MySQL or a newer one?
     
  4. CCHickman

    CCHickman Regular Pleskian

    25
    40%
    Joined:
    Oct 11, 2003
    Messages:
    112
    Likes Received:
    0
    Same problem here... have tried switching to postfix which has its own issues (not to mention the inability to use short names for logon) ... seems that rebooting / reinstalling qmail temporarily fixes it .. but then I get:

    Jan 30 18:00:01 metroplex360 relaylock: /var/qmail/bin/relaylock: Unable to delete expired smtp_poplocks: database is locked

    Like aubergine, I also cleared my MySQL database and the DB looks fine...
     
  5. CCHickman

    CCHickman Regular Pleskian

    25
    40%
    Joined:
    Oct 11, 2003
    Messages:
    112
    Likes Received:
    0
    Solution!

    Here's a great solution that I've found --

    Simply disable the POP3-Lock Authentication method and leave SMTP Authentication checked.

    I'm having no problems now whatsoever - just a slightly longer delay as the POP3-Lock Authentication method is faster.

    Hopefully the SW-Soft developers will have received non-forum trouble tickets on this to where it has been noted for 9.0.2.
     
  6. dash

    dash Regular Pleskian Staff Member

    28
    40%
    Joined:
    Sep 26, 2007
    Messages:
    204
    Likes Received:
    47
    Sirs, thanks for reports,

    Jan 14 12:01:37 server1 relaylock: /var/qmail/bin/relaylock: Unable to delete expired smtp_poplocks: database is locked
    Such errors in maillog are fully inessential.

    update_smtp_lock: Unable to prepare SQL statement, smtp-lock will not work: database is locked
    This error means that "smtp after pop authorization" will not work for exactly this pop3 session, but not for all pop3 sessions.

    The bug will be fixed in future releases.
     
  7. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
Loading...