1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

POP Mail Time Out, with slow connection

Discussion in 'Plesk for Linux - 8.x and Older' started by Swakoo, Nov 8, 2005.

  1. Swakoo

    Swakoo Guest

    0
     
    some of my users are in china now and have problem checking their mail. Apparently the mail client (Outlook in this case) will just download mail until it halts halfway... then error showing that they were disconnected from the email server.

    My guess is the China connection caused them to timeout.. but weird thing is.. why would it be able to download mail until the same one before it halts... its happening to 2 of my users over there, though I am not sure (and doubt so) that its because of the same mail...

    saying that... what is the way i can trace or better still, rectify the problem.

    I'm thinking of some reason

    1) Poor connection that causes timeout

    2) A particular mail that causes it

    I've look through the log but don't find much.. or maybe.. i dunno what I am looking for.

    Is there anyway to increase timeout duration for POP? What does qmail use to send mail?

    Many thanks!
     
  2. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    Outlook has a problem with certain headers, especially ones with no "From" or "Subject" fields. Have your clients log into webmail, find the message(s) with the bad header and delete & purge it.

    Hope it helps
     
  3. Swakoo

    Swakoo Guest

    0
     
    hi there

    so meaning to say, with a slow connection the above mentioned will be a problem.

    Cos I don't have such problem outside china; just in china... and with the user over in china now being some of my bosses... i don't think they will buy that China connection is poor thus the problem.. as one of my bosses is downloading from more establish pop accounts like Gmail with no problem....

    I'm asking him to check the above... but is there anyway to toggle the timeout value for pop mail in qmail?
     
  4. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    I don't think the timeout is caused by qmail. According to the qmail.org site qmail-pop3d has a 20 minute timeout. It could be that your client needs to adjust his Outlook timeout settings. But from what you said -

    it seems like the problem I detailed earlier.
     
  5. Swakoo

    Swakoo Guest

    0
     
    ahh.. so the process sending mail is qmail-pop3d, not sendmail? anyway to toggle the timeout on qmail?

    hmm because my boss went china twice recently (including this time) and both time he has problem...

    its hard to tell him its Outlook fault when he has no problem here.. though i just did heheheh :D

    bosses... hiak:rolleyes:
     
  6. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    Plesk uses qmail, not sendmail. Being the timeout is set at 20 minutes, I'd have a hard time justifying setting it any higher.
     
  7. Swakoo

    Swakoo Guest

    0
     
    yeah true... but where can this setting be changed, for informational sake :)

    What else do you reckon i can try find out.. and see whats wrong.. cos chances are when he comes back to office and check it will be no problem.

    The last time he went china, this happen, he came back and mail was flowing in normally again.

    Slow connection such a pain?
     
  8. ShadowMan@

    ShadowMan@ Guest

    0
     
    First, you should change his Outlook - Account - Advanced settings, there is a place to change the Outlook timeout from the default of 1 min. to a higer value. Just change it, don't even tell him or try explaining to him why. It will NOT affect anything when he is at the office. China's networks are prone to very high latency.

    Second, have you looked at creating/editing the following files:

    timeoutsmtpd
    Number of seconds qmail-smtpd will wait for each new buffer of
    data from the remote SMTP client. Default: 1200.

    timeoutconnect
    Number of seconds qmail-remote will wait for the remote SMTP
    server to accept a connection. Default: 60. The kernel normally
    imposes a 75-second upper limit.

    These, of course, are global and will affect the whole email system for all users, not just the boss while in China, so I do not recommend changing these unless really necessary. And actually timeoutconnect should not have any affect on Outlook connections (too tired to think properly), it should only affect outbound smtp connections to other smtp servers :) .

    These may not have any affect, it really sounds as if it is going to end up being the Outlook setting above.

    IIRC, you have already changed the smtp_psa file to include the -Rt0 option, if not, then you should do this.
     
  9. Swakoo

    Swakoo Guest

    0
     
    I have added the -Rt0 already :)

    I realise the settings are for SMTP, but in this case its the POP that is the question.. is there any similiar settings for POP? Or is the settings applicable to both?

    Many thanks ;)
     
  10. ShadowMan@

    ShadowMan@ Guest

    0
     
    Nothing specific for pop3d that I can recall, just the options in /usr/lib/courier-imap/etc/pop3d , you may want to make sure this file already has:

    TCPDOPTS="-nodnslookup -noidentlookup"

    As to Qmail's pop3d program, there are no config files that I have found. As phoenixisp posted, it does not sound as if it's a problem on the server side, except for possible malformed headers causing Outlook to choke, but if that were the case, then they would have the problem not just in China, but anywhere.

    The 20 min timeout which was mentioned is the qmail-pop3d module's 'idle timeout' default value.
     
  11. Swakoo

    Swakoo Guest

    0
     
    yah precisely... but only in china they have the problem, thats the unnecessary complaication isn't it hehe
     
  12. ShadowMan@

    ShadowMan@ Guest

    0
     
    Yes, China's network infrastructure is still not up to par with the rest of the world (yet).

    Definitely sounds to be a problem from thier end which is why I posted "First, you should change his Outlook - Account - Advanced settings, there is a place to change the Outlook timeout from the default of 1 min. to a higer value. Just change it, don't even tell him or try explaining to him why. It will NOT affect anything when he is at the office. China's networks are prone to very high latency."

    Sometimes it's better to not try to explain things to the boss.... not that the boss would necessarily understand anyways...

    I have had a few clients here in the US where the Outlook timeout had to be increased as well, due to their office DSL having very high latency also. Then I told them to get a 'real' DSL provider...LOL
     
Loading...