1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Postgres 8 and Plesk 7.5

Discussion in 'Plesk for Linux - 8.x and Older' started by JustBen, Apr 18, 2005.

  1. JustBen

    JustBen Guest

    0
     
    I upgraded postgres using the latest RPM's to version 8.02.

    Now when I try to start postgres from the plesk service control panel I get this error "0: /usr/local/psa/admin/htdocs/server/restart_services.php:19 psaerror(string "Unable to make action: Unable to manage service by pg_manage: Not supported PostgreSQL version is installed.")" Will Plesk suport postgres 8 in the near future or do I have to downgrade to an older version?
     
  2. ryanz

    ryanz Basic Pleskian

    24
    73%
    Joined:
    Nov 23, 2002
    Messages:
    91
    Likes Received:
    0
    I have a similar problem but it's with PostgreSQL version 7.3.4 on RH9

    ERROR
    Unable to make action: Unable to manage service by pg_manage: Unable to start PostgreSQL. 1
    0: /usr/local/psa/admin/htdocs/server/restart_services.php:19 psaerror(string "Unable to make action: Unable to manage service by pg_manage: Unable to start PostgreSQL. 1")

    When looking at /var/log/messages I get:

    Apr 22 16:39:15 su(pam_unix)[32084]: session opened for user postgres by (uid=0)
    Apr 22 16:39:15 su(pam_unix)[32084]: session closed for user postgres
    Apr 22 16:39:16 postgresql: Starting postgresql service: failed

    Have you managed to sort yours out?
     
  3. JustBen

    JustBen Guest

    0
     
    no I downgraded to 7.4.7 and everyting works again. I wish they would support 8 but so such luck.
     
  4. ryanz

    ryanz Basic Pleskian

    24
    73%
    Joined:
    Nov 23, 2002
    Messages:
    91
    Likes Received:
    0
    Please tell me what you did to reinstall as I can't seem to get my install working.

    What packages did you install and where did you download from?

    I'm on RH9, Plesk 7.5.2
     
  5. JustBen

    JustBen Guest

    0
     
    RPM uninstall

    I loged in via ssh and did a SU to root and uninstalled all of the postgress rpms after that I downloaded the 7.4 rpms and installed them after that everything was working again
     
  6. ryanz

    ryanz Basic Pleskian

    24
    73%
    Joined:
    Nov 23, 2002
    Messages:
    91
    Likes Received:
    0
    I used yum, and postgresql works fine now.
    Just one problem, 4PSA Total Backup did not save the pgsql database details/data in the dump file.
     
Loading...