1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

%pre(Sitebuilder-2.0.0-fc2.build050606.17) scriptlet failed

Discussion in 'Legacy Sitebuilder Software' started by isplhost.net, Jun 10, 2005.

  1. isplhost.net

    isplhost.net Guest

    0
     
    After finally installing plesk update 7.5.3 on my 7.5 server I also installed the sitebuilder from the plesk GUI at mysite:8443.

    But as I looked i found out that sitebuilder was still 1.1 i decided to upgarde it but while trying to do the same was returned with a error notification.

    Please help... i am releasing my web host at www.isplhost.net and its not going to look very nice to have errors then.

    Also, could any body tell me exactly what dns setting i need to make to make sitebuilder.isplhost.net work. Previously i had to do nothing but now.. even that doesnot work..

    Here is the putty command used,

    [root@isplhost root]# cd /home/medini/sb2
    [root@isplhost sb2]# ls
    Sitebuilder Sitebuilder-2.0.0-fc2.build050606.17.tgz
    [root@isplhost sb2]# cd Sitebuilder
    [root@isplhost Sitebuilder]# ls
    js-1.5rc5a-1.i386.rpm sablotron-1.0.1-2.i386.rpm Sitebuilder-2.0.0-fc2.build
    php-xslt-1.0-0.i386.rpm sb_install
    [root@isplhost Sitebuilder]# rpm -Uhv js-1.5rc5a-1.i386.rpm
    Preparing... ########################################### [100%]
    package js-1.5rc5a-1 is already installed
    [root@isplhost Sitebuilder]# rpm -Uhv php-xslt-1.0-0.i386.rpm
    Preparing... ########################################### [100%]
    package php-xslt-1.0-0 is already installed
    [root@isplhost Sitebuilder]# rpm -Uhv sablotron-1.0.1-2.i386.rpm
    Preparing... ########################################### [100%]
    package sablotron-1.0.1-2 is already installed
    [root@isplhost Sitebuilder]# ./home/medini/sb2/Sitebuilder/sb_install
    -bash: ./home/medini/sb2/Sitebuilder/sb_install: No such file or directory
    [root@isplhost Sitebuilder]# chmod +x sb_install
    [root@isplhost Sitebuilder]# ./sb_install
    Preparing... ########################################### [100%]
    Please, remove the remote_admin folder using the
    rm -rf /usr/local/sitebuilder/remote_admin
    command and restart SiteBuilder installation
    error: %pre(Sitebuilder-2.0.0-fc2.build050606.17) scriptlet failed, exit status
    error: install: %pre scriptlet failed (2), skipping Sitebuilder-2.0.0-fc2.buil
    [root@isplhost Sitebuilder]#
     
  2. rspurlock

    rspurlock Guest

    0
     
    Delete/move remote_admin folder

    isplhost.net

    I had the exact same problem. I simply went to the sitebuilder folder and removed the remote_admin folder completely. Since the remote_admin won't work with the 2.0 version it shouldn't really matter. Once removed, I reran the rpm -ivh for sitebuilder only and it installed no problem. Now I get a licensekey.php error when I try to get into it, but that looks like a gpgext error I'm working through.
     
  3. JamesB

    JamesB Guest

    0
     
    did you get that licensekey.php error figured out....?

    Here's what I'm getting:
    Code:
    Fatal error: General Error in /usr/local/sitebuilder/include/kernel/licensekey.php on line 548
     
  4. isplhost.net

    isplhost.net Guest

    0
     
    Actually I did not see the,

    Please, remove the remote_admin folder using the
    rm -rf /usr/local/sitebuilder/remote_admin
    command and restart SiteBuilder installation

    Instruction while posting the problem. WHen I saw, i did it and again, I had another problem. It showed me a database error... no numbers, just the sitebuilder GUI said it has a databased error when i tried to log in.

    SO i tried to uninstall the rpm, when trying to do that, the rpm command issued was returned with a error message "....rpm not installed"! when i try to rpm -Uhv .rpm the same rpm it says its already was installed.

    Then i used the old method of uninstallation, i deleted, the /..../sitebuilder whole folder and also dropped the whole database (drop database Sitebuilder;)

    Then issued a force install command (rpm -Uhv --force)

    everything installed fine! :)

    I then downloaded all the template rpms and installed them. They installed fine.. and i logged in the admin login.. and they could be seen. I saw that they were activated.

    So i looged out and on the wizrd the templates wern't there.

    I tried switching the templates, template type, but still the template cannot be seen on the wizard.

    How did you make the templates make available to your users? Mine just wont be vailable, it just shows up on the admin login only.

    try my sitebuilder install at, http://sitebuilder.isplhost.net

    Also, does anybody know how to skin horde ? I have the horde webmail with my plesk cp.
     
  5. mhigashi

    mhigashi Guest

    0
     
    I think there's one more step to turn on templates in 2.0. After logging in as admin, you have to go the plan management screen and activate them for that plan.

    Mike
     
  6. isplhost.net

    isplhost.net Guest

    0
     
  7. rspurlock

    rspurlock Guest

    0
     
    same error for me

    This is all I get when I try to log in:


    Fatal error: General Error in /usr/local/sitebuilder/include/kernel/licensekey.php on line 548


    I've reinstalled from scratch and no go. No response from Plesk Support yet though. I get the feeling they have many issues from customers with this sam eproblem.

    If anyone has experienced it and resolved it, please let us know.

    TIA,

    Rob
    LNHosting.com
     
  8. CiViX

    CiViX Guest

    0
     
    Re: same error for me

    I had the same problem, but found the solution. Check the owner of /usr/local/sitebuilder/include/kernel/licensekey.php

    I guess it is plesk:plesk. Change this to apache:apache, and everything will work fine.

    chown apache:apache licensekey.php

    Tada!
     
  9. rspurlock

    rspurlock Guest

    0
     
    Thanks CiViX, but the permissions were correct on mine. I did however hear from support and they sent me a new licensekey.php file to replace my other one. So this must be a real issue. If nothing else works for you, give them a shout for a replacement file.
     
  10. CiViX

    CiViX Guest

    0
     
    Yes, I also was sent a new licensekey.php-file, and PLESK gave me instructions on how to install this. In the instructions they said "after unpacking the new file, change the owner to apache:apache). That was when I noticed that my original file was owned by plesk:plesk. I changed the owner to apache:apache, and then it worked, so I actually never unpacked the new file (hotfix) they sent me...
     
  11. isplhost.net

    isplhost.net Guest

    0
     
    Hello, Everybody,

    I recently realized that my Plesk had problems again.

    Because we are talking about permission denial error.

    While trying to change or self issue a SSL certificate on my plesk 7.5.3 i came acrooss the error that application was denied while trying to set the personal key.

    Help me out its urgent!!
     
Loading...