1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Preview 2 - IIS Hosting plan error

Discussion in 'Plesk Automation' started by GregorL, Jan 13, 2012.

Thread Status:
Not open for further replies.
  1. GregorL

    GregorL Basic Pleskian

    16
    60%
    Joined:
    Oct 24, 2011
    Messages:
    61
    Likes Received:
    0
    On windows 2008R2
    when a user adds IIS hosting to his account, the following error occurs during synchronization:

    Unable to update hosting preferences. Unable to turn on ASP.NET version 2.0 because it is not installed.

    Via Server manager I installed the feature .NET 3.5.1 (which I thought is just an enhanced .NET 2.0)

    But this does not seem to help.
     
  2. Andrey Dobrenko

    Andrey Dobrenko Regular Pleskian

    26
     
    Joined:
    Jun 26, 2007
    Messages:
    256
    Likes Received:
    0
    Hi GregorL,

    Could you please provide some info:

    1. Give the output of execution command "%PLESK_DIR%\admin\bin\defpackagemng.exe" --get on the WIndows node
    2. Give the output of execution command mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa -e "SELECT * from ServiceNodeProperties where name like 'server.packages.%'; " on the management node

    Best Regards,
    Andrey
     
  3. GregorL

    GregorL Basic Pleskian

    16
    60%
    Joined:
    Oct 24, 2011
    Messages:
    61
    Likes Received:
    0
    Attached please find the information requested..
     

    Attached Files:

  4. Andrey Dobrenko

    Andrey Dobrenko Regular Pleskian

    26
     
    Joined:
    Jun 26, 2007
    Messages:
    256
    Likes Received:
    0
    Hi GregorL,

    MSP collects information of installed components/packages like "apache", "php", "miva", "perl", "asp.net". In your case, ASPNET wasn't installed during attaching node. Next, you install additional component "asp.net". But management node still do not know that APS.net is installed. Need to re-read packages which installed on the service node. To fix the problem, need to run the command:

    mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa -e "DELETE from ServiceNodeProperties where name like 'server.packages.%'; "

    P.S. An ability to refresh components to be implemented in the next version.

    Best Regards,
    Andrey
     
  5. GregorL

    GregorL Basic Pleskian

    16
    60%
    Joined:
    Oct 24, 2011
    Messages:
    61
    Likes Received:
    0
    Thank you Andrey,

    That did the trick!
     
Thread Status:
Not open for further replies.
Loading...