1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problem accessing subdomains and performance option in Plesk panel

Discussion in 'Plesk for Windows - 8.x and Older' started by RobertS, Aug 31, 2006.

  1. RobertS

    RobertS Guest

    0
     
    (running Plesk 7.6 on windows2003)

    When I try to acces using the Plesk panel a subdomain (any subdomain) I get an error, this is the error:

    Code:
    Unable to create SubDomainManager object: Unable to create SubDomainPerformance object: WebServerManager::getSubDomainPerformance() failed: Unable to parse current performance.
    ---------------------- Debug Info -------------------------------
    0: D:\SWsoft\Plesk\admin\plib\common_func.php3:153
    	psaerror(string 'Unable to create SubDomainManager object: Unable to create SubDomainPerformance object: WebServerManager::getSubDomainPerformance() failed: Unable to parse current performance.')
    1: D:\SWsoft\Plesk\admin\htdocs\domains\subdomains\subdom_ctrl.php:39
    I cannot access these subdomain in Plesk but they do work normally. The are vissable (online) and the FTP acces works also
    It is also not possible to delete them, if I do that I also got an error like this one:

    on top of the panel:
    Code:
    parse error: parse error, unexpected T_STRING in D:\SWsoft\Plesk\admin\plib\class.WebServerManager.php(470) : eval()'d code on line 1
    then in a red marked box:
    Code:
    Error: Unable to create SubDomainPerformance object: WebServerManager::getSubDomainPerformance() failed: Unable to parse current performance.
    I also cannot use the performance option with normal domains(no sub-domain) anymore, when I try to open this option I get the following error:

    Code:
    Parse error: parse error, unexpected T_STRING in D:\SWsoft\Plesk\admin\plib\class.WebServerManager.php(449) : eval()'d code on line 1
    and
    Code:
    The operation you were performing failed. You can retry the operation with or without changing its parameters. You may also want to report this problem to our support so that we could help you as soon as possible.

    I did not change anything on my server of plesk, in the event log also an error is listed, the error is:
    Code:
    The system cannot find the path specified. (COM Error 80070003) at loadServer(17675)
       at (WebServerMap::reload line 2317)
    Execute file name: D:\SWsoft\Plesk\admin\bin\websrvmng.exe
    An other error which is in the event log is the following one:
    Code:
    Cannot modify or delete an object that was added using the COM+ Admin SDK (COM Error 8004020E, Description: De server heeft het adres van de afzender geweigerd. Reactie van server: 550 Sender is not allowed.
    ) at Unable to execute event
       at (runtask::start line 211)
    Execute file name: D:\SWsoft\Plesk\admin\bin\runtask.exe
    Also I get an error each night of the backup script reporting it cannot access a subdomain, this is the error:

    Code:
    Backup error.
    Error in execute ''websrvmng' --get-subdomain-performance "--vhost-name=domain.com" "--subdomain=xri"':
    The system cannot find the path specified. (COM Error 80070003) at loadServer(17675) Site xri.domain.com doesn't exist
    (changed manually domainname)

    The site does exist and works, in IIS al is OK, the paths are correct.

    I tried the plesk reconfigurator but this tool hangs after a while, I also restarted all plesk services but this had no effect at all.

    Can anyone help me?


    edit:
    A server reboot fixed almost al problems
     
  2. byLiLattah

    byLiLattah Guest

    0
     
    example :deneme.lilattah.com


    "%plesk_bin%\websrvmng.exe" --update-subdomain --vhost-name=lilattah.com --subdomain=deneme

    regards,
     
  3. jrodolfo

    jrodolfo Guest

    0
     
    For ALL Domain

    To reconfigure all domain it uses:


    %Plesk%\admin\bin>websrvmng.exe --reconfigure-all


    ATT: RECONFIGURE ALL DOMAIN ... It prevents error that others of subdomain.


    []'s
     
Loading...