1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problem on Plesk update (Plesk updater is selected but is already installed)

Discussion in 'Plesk for Linux - 8.x and Older' started by druckgott, May 21, 2007.

  1. druckgott

    druckgott Guest

    0
     
    Hallo

    My Problem is, that the base Pack of plesk and the SpamAssassin support is not installed but the Plesk Updater is already installed. If i go on update there comes an error.

    I should select the components I will install.

    In the picture you could see the Plesk autoinstaller.
    I have test it via ssh but there I also can not deselect the Plesk Updater

    What could I do?

    [​IMG]
     
  2. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    Have you tried the commandline autoinstaller?
     
  3. druckgott

    druckgott Guest

    0
     
    Is the comandline autoinstaller via ssh?

    or what ist the comandline autoinstaller?

    I do it this this comandline but in don´t work

    /usr/local/psa/admin/bin/autoinstaller --enable-xml-output --source-type=plesk --target=/root/psa --select-release-id=PLESK_8_1_1 --notify-email=michi@xxxx.xx --install-component=base --install-component=spamassassin
     
  4. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    What happens when you just run /usr/local/psa/admin/bin/autoinstaller and use the autoinstaller interactively?

    Do you have any idea how come you don't have the base packages installed?
     
  5. druckgott

    druckgott Guest

    0
     
    There is the same Problem. Plesk Updater is automaticaly selectet. An I can´t deselect it. The components which I can deslelect have a * and the components which i can´t deselect have a =

    druckgott
     
  6. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    Ok, I'm confused now. I thought you wanted to install something, but you want to uninstall the updater?
     
  7. druckgott

    druckgott Guest

    0
     
    no I don´t want to unistall.

    But the Plesk updater is already installed.

    I think the installation get´s an error because the Plesk updater is selekted but it is already installed.

    But the Plesk basepack is not installed.

    if I will update the basepack I can´t deselect the Plesk updater. So he get´s an error and don´t install the base pack because the plesk updater is already installed (I think)

    sorry for my bad english

    I hopy you have understand me?
     
  8. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    What is the exact error you're getting when you run the autoinstaller and try to install the base packages?

    By the way, the easiest solution might be to download the complete distribution of Plesk packages and just install the base packages that way.

    And I still have no idea how you got into this situation. A failed upgrade?
     
  9. druckgott

    druckgott Guest

    0
     
    Yes I have problems with update

    Code:
    Autoinstaller 3.1.2 (build at 2007-03-21 17:58) started at (timezone CET) Tue May 22 13:47:19 2007
    Command line args: /usr/local/psa/admin/bin/autoinstaller --enable-xml-output --source-type=plesk --target=/root/psa --select-release-id=PLESK_8_1_1 --notify-email=michi@coolpixx.de --install-component=base --install-component=spamassassin 
    
    Try to find rcfile...
    Autoinstaller rcfile not found.
    Check hostname is sucessfull.
    Opsys detected as: os_name=Linux os_vendor=SuSE version=9.3 arch=i686 environment=vz
    Final opsys (with overriding) is: os_name=Linux os_vendor=SuSE version=9.3 arch=i686 environment=vz
    repository: Get brief packages info for all sources
    Checking for installed system packages...readSystemPackagesBrief: execute rpm -qa --queryformat 'F:system_installed_brief_%{NAME}-%{VERSION}-%{RELEASE}.rpm\nN:%{NAME}\nE:%{EPOCH}\nV:%{VERSION}\nL:%{RELEASE}\nA:%{ARCH}\nf:%{INSTALLTIME}\nB:%{BUILDTIME}\nX:\n' 
    done.
    Download file products.inf3: 100% done.
    Download file plesk.inf3: 100% done.
    Download file sitebuilder.inf3: 11%..100% done.
    release PLESK_8_1_1 is actual
    Release SB_3_0_0 contains no any build for this OS
    Release SB_3_0_1 contains no any build for this OS
    release SB_3_0_2 is actual
    Select best build of PLESK_8_1_1 for current OS
    First fit build is current best: PSA_8.1.1/plesk-8.1.1-suse9.3-i386.inf3
    Select best build: finally choised PSA_8.1.1/plesk-8.1.1-suse9.3-i386.inf3
    Download file PSA_8.1.1/plesk-8.1.1-suse9.3-i386.inf3: 100% done.
    You are under Virtuozzo, try to connect to VZAgent...Warning: can't connect to VZAgent: open: No such device or address
    repository: Get brief packages info for all sources
    Check for components installation status
    Component base: mode upgrade,  installed=1177319520,  available=1177319520
    Component psa-autoinstaller: mode up2date,  installed=1174478539,  available=1174478539
    Component asp: mode upgrade,  installed=1164821927,  available=1174564993
    Component mailman: mode upgrade,  installed=1164821930,  available=1174564996
    Component postgresql: mode install,  installed=0,  available=1163583285
    Component java: mode install,  installed=0,  available=1174564674
    Component spamassassin: mode upgrade,  installed=1164821606,  available=1174564681
    Component rblsmtpd: mode upgrade,  installed=1164821603,  available=1174564677
    Component mod_python: mode up2date,  installed=1111533515,  available=1111533515
    Component ruby: mode install,  installed=0,  available=1174565008
    Component fcgi: mode install,  installed=0,  available=1160391403
    Component vault: mode install,  installed=0,  available=1174877970
    Component horde-comps: mode upgrade,  installed=1164821877,  available=1174564938
    Component docs: mode up2date,  installed=1174564918,  available=1174564918
    Component backup-vz: mode up2date,  installed=1175674065,  available=1175674065
    Component drweb: mode install,  installed=0,  available=1174564620
    Component ppwse: mode install,  installed=0,  available=1174564964
    Component api: mode up2date,  installed=1175674080,  available=1175674080
    Component sshterm: mode upgrade,  installed=1164821482,  available=1174564544
    Component pmm: mode up2date,  installed=1175674052,  available=1175674052
    Component psa-firewall: mode up2date,  installed=1174564671,  available=1174564671
    Component cs-gs: mode install,  installed=0,  available=1174564666
    Component psa-vpn: mode up2date,  installed=1174564909,  available=1174564909
    Component battlefield: mode install,  installed=0,  available=1174564943
    Component bf2: mode install,  installed=0,  available=1174565001
    Component psa-fileserver: mode up2date,  installed=1174564655,  available=1174564655
    Component watchdog: mode up2date,  installed=1174564980,  available=1174564980
    Component sitebuilder: mode install,  installed=0,  available=1164691550
    Component sb-publish: mode install,  installed=0,  available=1160553263
    Component cf-support: mode install,  installed=0,  available=1174565003
    Component miva: mode install,  installed=0,  available=1174565012
    Component de-DE-locale: mode install,  installed=0,  available=1174825695
    Component ja-JP-locale: mode install,  installed=0,  available=1174825720
    Component es-ES-locale: mode install,  installed=0,  available=1174825705
    Component ru-RU-locale: mode install,  installed=0,  available=1174825741
    Component fr-FR-locale: mode install,  installed=0,  available=1174825711
    Component it-IT-locale: mode install,  installed=0,  available=1174825717
    Component zh-CN-locale: mode install,  installed=0,  available=1174825750
    Component zh-TW-locale: mode install,  installed=0,  available=1174825752
    Check for components requires keyupdate
    No keyupdate need for component base
    KeyUpdateChecker::doCheck: no components for check key update
    repository: Get full packages info for all sources
    Reading system installed packages...execute command for generate rpm cache in /tmp:
    rpm -qa --queryformat 'F:system_installed_%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}.rpm\nN:%{NAME}\nE:%{EPOCH}\nV:%{VERSION}\nL:%{RELEASE}\nA:%{ARCH}\nf:%{INSTALLTIME}\nB:%{BUILDTIME}\n[R:%{REQUIRENAME} %{REQUIREFLAGS:depflags} %{REQUIREVERSION}\n][P:%{PROVIDENAME} %{PROVIDEFLAGS:depflags} %{PROVIDEVERSION}\n][P:%{FILENAMES}\nm:%{FILEMODES}\n5:%{FILEMD5S}%{FILELINKTOS}\n][C:%{CONFLICTNAME} %{CONFLICTFLAGS:depflags} %{CONFLICTVERSION}\n][O:%{OBSOLETENAME} %{OBSOLETEFLAGS:depflags} %{OBSOLETEVERSION}\n]X:\n'  > /tmp/autoinstaller_system_packages.cache
    catch error with message: Can't execute command for generate system packages cache
    ERROR: Can't execute command for generate system packages cache
    Check SElinux status after error:
    Exit with ERROR status
    
    
    ---
    Plesk autoinstaller.
    
    where can I get this basepackets?
     
  10. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    The core of the error seems to be this:

    Maybe your /tmp doesn't have enough space to generate the system packages cache?

    You can get the complete archive of all Plesk packages on the download page: http://www.swsoft.com/en/download/plesk8/
     
  11. druckgott

    druckgott Guest

    0
     
    oh there are a lot of files can I delete all files in tmp?

    druckgott
     
  12. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    It doesn't matter if there are a lot files there, it matters if there is space left there. Is /tmp its own partition? What doesn df -h say?
     
  13. druckgott

    druckgott Guest

    0
     
    it says

    Code:
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/vzfs              10G  1.6G  8.5G  16% /
    tmpfs                1011M     0 1011M   0% /dev/shm
    
     
  14. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    Seems like disk space is not the problem.
     
  15. druckgott

    druckgott Guest

    0
     
    where can I get if i have a Suse 9.3 or 9.3 64 bit?

    this says plesk

    Betriebssystem Linux 2.6.9-023stab039.1-smp
    Plesk-Version psa v8.1.1_build81070423.15 os_SuSE 9.
     
  16. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    Since you're under Virtuozzo the kernel doesn't tell you much, as it's the hosts kernel. Run lsb_release -d to see what you're running.
     
  17. druckgott

    druckgott Guest

    0
     
    hxxxxxxx:~ # lsb_release -d
    -bash: lsb_release: command not found

    it says command not found

    is a virutal server
     
  18. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    On Red Hat/CentOS/Fedora systems you can run cat /etc/redhat-release to see what you're running. On Debian it's cat /etc/debian_version (maybe works for Ubuntu too?). I don't know what file you'd check on SuSE. Is there a /etc/*release or /etc/*version file?

    Since you apparently aren't hosting this Virtuozzo server yourself, can't you ask your host?
     
  19. druckgott

    druckgott Guest

    0
     
    ah I found a Suse-release file in /etc

    SuSE Linux 9.3 (i586)
    VERSION = 9.3

    druckgott
     
  20. druckgott

    druckgott Guest

    0
     
    Hallo???

    Which files do I have to use to update?

    I tested it again with ssh and I get this error

    Code:
     Unexpected 'St9bad_alloc' catched.
    
    can nobody help me
    druckgott
     
Loading...