1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Problem while installing Plesk on Debian

Discussion in 'Plesk for Linux - 8.x and Older' started by Bluelane, Oct 27, 2005.

  1. Bluelane

    Bluelane Guest

    0
     
    I have this problem when I want to install Plesk on Debian :

    Installation type
    ===============================================================================

    Please select the components you wish to install:

    1. [*] Base packages of Plesk
    2. [ ] Plesk Professional Web Site Editor
    3. [=] Apache mod_python module (already installed)
    4. [ ] Backup utilities
    5. [ ] Plesk Counter-Strike game server module
    6. [ ] Frontpage 2002 support
    7. [ ] Plesk Firewall module
    8. [ ] Dr. Web antivirus
    9. [ ] Plesk migration manager
    10. [ ] Plesk API [former Plesk Agent]
    11. [ ] Plesk VPN module
    12. [ ] SPAM blocker for QMail daemon
    13. [ ] Plesk Battlefield 1942 game server module
    14. [ ] Plesk Fileserver module and SMB file server package
    15. [ ] Additional Horde (webmail) components for Plesk
    16. [ ] Application vault packages
    17. [ ] Watchdog (System monitoring module)
    18. [ ] SSHTerm - SSH Terminal java applet
    19. [ ] Mailman mailing list manager support
    20. [ ] Additional Plesk manuals
    21. [ ] PosgreSQL server support
    22. [ ] ASP support
    23. [ ] SpamAssassin support
    24. [ ] Tomcat Java Servlets support
    25. [ ] ColdFusion support for Plesk
    26. [ ] SiteBuilder and Sitebuilder module for Plesk

    1) Next page; 2) Previous page; 0) Cancel installing
    3) Toggle a component; 4) Select all; 5) Deselect all;
    Type the number corresponding to the desired action and press Enter [1]:
    Hit http://10.94.53.49 stable/main Packages
    Hit http://10.94.53.49 stable/main Release
    Hit http://10.94.53.49 stable/contrib Packages
    Hit http://10.94.53.49 stable/contrib Release
    Hit http://10.94.53.49 stable/non-free Packages
    Hit http://10.94.53.49 stable/non-free Release
    Hit http://10.94.53.49 stable/non-US/main Packages
    Hit http://10.94.53.49 stable/non-US/main Release
    Hit http://10.94.53.49 stable/non-US/contrib Packages
    Hit http://10.94.53.49 stable/non-US/contrib Release
    Get:1 http://autoinstall.plesk.com PSA_7.5.4/ Packages [12.5kB]
    Hit http://10.94.53.49 stable/non-US/non-free Packages
    Hit http://10.94.53.49 stable/non-US/non-free Release
    Hit http://10.94.53.49 stable/updates/main Packages
    Hit http://10.94.53.49 stable/updates/main Release
    Hit http://10.94.53.49 stable/updates/contrib Packages
    Hit http://10.94.53.49 stable/updates/contrib Release
    Hit http://10.94.53.49 stable/updates/non-free Packages
    Ign http://autoinstall.plesk.com PSA_7.5.4/ Release
    Hit http://10.94.53.49 stable/updates/non-free Release
    Fetched 12.5kB in 0s (27.1kB/s)
    Reading Package Lists...
    Reading Package Lists...
    Building Dependency Tree...
    psa is already the newest version.
    psa-api-cli is already the newest version.
    psa-api-common is already the newest version.
    psa-courier-imap is already the newest version.
    psa-courier-imap-add is already the newest version.
    psa-key is already the newest version.
    psa-locale-base-en-us is already the newest version.
    psa-proftpd is already the newest version.
    psa-proftpd-inetd is already the newest version.
    psa-qmail is already the newest version.
    psa-appvault-mambo is already the newest version.
    psa-appvault-oscommerce is already the newest version.
    psa-horde is already the newest version.
    psa-imp is already the newest version.
    psa-hotfix is already the newest version.
    psa-hotfix2 is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    7 not fully installed or removed.
    Need to get 0B of archives.
    After unpacking 0B of additional disk space will be used.
    Setting up psa (7.5.4-debian3.1.build75050824.12) ...
    /var/lib/dpkg/info/psa.postinst: line 7580: : No such file or directory
    Unable to find product configuration file: /etc/psa/psa.conf

    Setting the default locale

    ERROR while trying to setting default locale
    Check the error reason(see log file: /tmp/psa_7.5.4_Debian_3.1_build75050824.12_installing.log), fix and try again

    Aborting...

    dpkg: error processing psa (--configure):
    subprocess post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of psa-appvault-mambo:
    psa-appvault-mambo depends on psa (>= 7.5); however:
    Package psa is not configured yet.
    dpkg: error processing psa-appvault-mambo (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of psa-appvault-oscommerce:
    psa-appvault-oscommerce depends on psa (>= 7.5); however:
    Package psa is not configured yet.
    dpkg: error processing psa-appvault-oscommerce (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of psa-horde:
    psa-horde depends on psa (>= 7.5.4); however:
    Package psa is not configured yet.
    dpkg: error processing psa-horde (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of psa-hotfix:
    psa-hotfix depends on psa-7.5.4; however:
    Package psa-7.5.4 is not installed.
    Package psa which provides psa-7.5.4 is not configured yet.
    dpkg: error processing psa-hotfix (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of psa-hotfix2:
    psa-hotfix2 depends on psa-7.5.4; however:
    Package psa-7.5.4 is not installed.
    Package psa which provides psa-7.5.4 is not configured yet.
    dpkg: error processing psa-hotfix2 (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of psa-imp:
    psa-imp depends on psa-horde; however:
    Package psa-horde is not configured yet.
    dpkg: error processing psa-imp (--configure):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    psa
    psa-appvault-mambo
    psa-appvault-oscommerce
    psa-horde
    psa-hotfix
    psa-hotfix2
    psa-imp
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Hit http://10.94.53.49 stable/main Packages
    Hit http://10.94.53.49 stable/main Release
    Hit http://10.94.53.49 stable/contrib Packages
    Hit http://10.94.53.49 stable/contrib Release
    Hit http://10.94.53.49 stable/non-free Packages
    Hit http://10.94.53.49 stable/non-free Release
    Hit http://10.94.53.49 stable/non-US/main Packages
    Hit http://10.94.53.49 stable/non-US/main Release
    Hit http://10.94.53.49 stable/non-US/contrib Packages
    Hit http://10.94.53.49 stable/non-US/contrib Release
    Hit http://10.94.53.49 stable/non-US/non-free Packages
    Hit http://10.94.53.49 stable/non-US/non-free Release
    Hit http://10.94.53.49 stable/updates/main Packages
    Hit http://10.94.53.49 stable/updates/main Release
    Hit http://10.94.53.49 stable/updates/contrib Packages
    Hit http://10.94.53.49 stable/updates/contrib Release
    Hit http://10.94.53.49 stable/updates/non-free Packages
    Hit http://10.94.53.49 stable/updates/non-free Release
    Reading Package Lists...
    Press <ENTER> to continue...
     
  2. _tek

    _tek Basic Pleskian

    23
    40%
    Joined:
    Feb 7, 2005
    Messages:
    46
    Likes Received:
    0
    Had similar issues

    While i did it a long time ago, (literally first day they released plesk for debian) i do recall having massive issues getting it up and running. i had installed it just one week before on redhat ES and had no issues at all.

    Still glad i went through the headaches of getting it setup on debian though. If i recall i went and downloaded all of the packages and did a manual installation of each package by hand using dpkg -i <package_name>.

    There were a few i had to string together to resolve dependancies and i also recall there were quite a few i had to resort to doing it with dpkg -i --force-all on a few packages. THIS CAN BE DANGEROUS. but then again so can be beating your head on the same problem for a few days.
    If you do something like that, which i admit i did. backup your stuff. give yourself an exit route.

    Also recommend reading up on dpkg --force-help
    It will explain all of the various permutations that --force has and what is different with each ones.

    Long story is it can be installed but you have to find out what the first dependancy is and string them together when installing them.

    Hope that is of some help.
     
Loading...