1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problem with the upgrade key

Discussion in 'Plesk for Linux - 8.x and Older' started by coccia.stefano, Jan 4, 2005.

  1. coccia.stefano

    coccia.stefano Guest

    0
     
    I have Plesk 7.0.3 and I have do the upgrade to 7.5 but I have when I do the RPM -Uvh for the psa-key I receive this error
    [root@server base]# rpm -Uvh psa-key-7.5-fc1.build75041216.14.noarch.rpm
    Preparing... ########################################### [100%]
    file /usr/local/psa/tmp/psa.key from install of psa-key-7.5-fc1.build75041216.14 conflicts with file from package psa-7.0.3-fc1.build040611.14

    What I must to do?
     
  2. Cranky

    Cranky Guest

    0
     
    You need to ...

    rpm -Uvh base/*.rpm

    Rather than just installing psa-key alone you need to install the entire contents of the base directory simultaneously as above.
     
  3. coccia.stefano

    coccia.stefano Guest

    0
     
    [root@server rpm_FedoraCore_1]# rpm -Uvh base/*.rpm
    Preparing... ########################################### [100%]
    package psa-pre-keyupdate-7.5.1-fc1.build75041216.14 is already installed
    package psa-proftpd-1.2.10-fc1.build75041216.14 is already installed
    package psa-proftpd-xinetd-1.2.10-fc1.build75041216.14 is already installed
    package psa-logrotate-3.7-fc1.build75041216.14 is already installed
    package libidn-0.4.2-fc1.build75041216.14 is already installed
    package psa-qmail-1.03-fc1.build75041216.14 is already installed
    package courier-imap-3.0.8-fc1.build75041216.14 is already installed
    package psa-courier-imap-add-7.5.1-fc1.build75041216.14 is already installed
    package Mambo-4.5.1-1 is already installed


    ok but the other file? Don't see psa-key psa-api and psa-75
     
  4. Cranky

    Cranky Guest

    0
     
    What does...

    rpm -qa | grep psa

    ... say? It looks like your upgrade failed. You may need to revert to 7.0.x then upgrade to 7.1.6, then to 7.5.1 instead. Does Plesk actually load, and what version does it think it is when it loads?
     
  5. coccia.stefano

    coccia.stefano Guest

    0
     
    ok now I try to install 7.1.6 and after 7.5.1
     
  6. coccia.stefano

    coccia.stefano Guest

    0
     
    nothing I have download 7.1.6 and I have tryed to upgrade fro 7.0.3 but when i try to installa psa-key I received the same problem
    [root@server base]# rpm -Uvh psa-key-7.1-fc1.build71041118.17.noarch.rpm
    Preparing... ########################################### [100%]
    file /usr/local/psa/tmp/psa.key from install of psa-key-7.1-fc1.build71041118.17 conflicts with file from package psa-7.0.3-fc1.build040611.14
     
Loading...