1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Problem with zlib version when updating

Discussion in 'Plesk for Linux - 8.x and Older' started by mousemat1974, Apr 26, 2005.

  1. mousemat1974

    mousemat1974 Guest

    0
     
    When I perform the standard built-in update for plesk I get the following error:

    ----- begin of output -----
    Installing zlib-1.2.1.2-0.fc2.i386.rpm
    warning: /root/psa/PSA_7.5.2/FC2_std.updates/zlib-1.2.1.2-0.fc2.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
    error: Failed dependencies:
    zlib = 1.2.1.1 is needed by (installed) zlib-devel-1.2.1.1-2.1
    ----- end of output -----

    Which to my untrained eye looks a little odd as the zlib version installed is greater than the version it requires to update to an even greater version (!)

    querying rpm confirms the installed zlib version as zlib-1.2.1.1-2.1

    I can't find a plain zlib-1.2.1.1 version anywhere.

    So my question is - am I safe to force the installation of zlib-1.2.1.2-0 to overwrite the current install?

    or is there another fix?

    This problem is preventing me from performing any of the other updates (antivirus etc.)
     
  2. Stucco

    Stucco Guest

    0
     
    Same problem

    I get the exact same problem when updating to 7.5.2 files. Have a solution yet?

    Code:
    Preparing for packages installation...
    ----- begin of output -----
    Installing postgresql-libs-7.4.6-1.FC2.2.i386.rpm
    warning: /root/psa/PSA_7.5.2/FC2_std.updates/postgresql-libs-7.4.6-1.FC2.2.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2 Installing tzdata-2005c-1.fc2.noarch.rpm
    warning: /root/psa/PSA_7.5.2/FC2_std.updates/tzdata-2005c-1.fc2.noarch.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2 Installing info-4.7-4.i386.rpm
    warning: /root/psa/PSA_7.5.2/FC2_std.updates/info-4.7-4.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2 Installing zlib-1.2.1.2-0.fc2.i386.rpm
    warning: /root/psa/PSA_7.5.2/FC2_std.updates/zlib-1.2.1.2-0.fc2.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
    error: Failed dependencies:
    	zlib = 1.2.1.1 is needed by (installed) zlib-devel-1.2.1.1-2.1
     
Loading...