1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

psa-backup-manager wont install freebsd

Discussion in 'Plesk for Linux - 8.x and Older' started by tetra, Jan 8, 2007.

  1. tetra

    tetra Guest

    0
     
    i goto /usr/ports/swsoft

    do make config
    then make install

    to get the backup manager selected and i get these errors.





    BIG ERROR


    ---> Fetching mod_fcgid-1.09
    fetch: http://autoinstall.plesk.com/PSA_8.1.0/dist-pkg-FreeBSD-5.5-i386/packages/All/mod_fcgid-1.09.tbz: Not Found
    ** The command returned a non-zero exit status: 1
    ** Failed to fetch http://autoinstall.plesk.com/PSA_8.1.0/dist-pkg-FreeBSD-5.5-i386/packages/All/mod_fcgid-1.09.tbz
    fetch: http://autoinstall.plesk.com/PSA_8.1.0/dist-pkg-FreeBSD-5.5-i386/packages/All/mod_fcgid-1.09.tgz: Not Found
    ** The command returned a non-zero exit status: 1
    ** Failed to fetch http://autoinstall.plesk.com/PSA_8.1.0/dist-pkg-FreeBSD-5.5-i386/packages/All/mod_fcgid-1.09.tgz
    fetch: http://autoinstall.plesk.com/PSA_8..../packages/RELEASE_5_5/All/mod_fcgid-1.09.tbz: Not Found
    ** The command returned a non-zero exit status: 1
    ** Failed to fetch http://autoinstall.plesk.com/PSA_8....6/packages/RELEASE_5_5/All/mod_fcgid-1.09.tbz
    fetch: http://autoinstall.plesk.com/PSA_8..../packages/RELEASE_5_5/All/mod_fcgid-1.09.tgz: Not Found
    ** The command returned a non-zero exit status: 1
    ** Failed to fetch http://autoinstall.plesk.com/PSA_8....6/packages/RELEASE_5_5/All/mod_fcgid-1.09.tgz
    ** Failed to fetch mod_fcgid-1.09
    ** Listing the failed packages (*:skipped / !:failed)
    ! mod_fcgid-1.09 (fetch error)
    ---> Packages processed: 0 done, 0 ignored, 0 skipped and 1 failed
    ** Could not find the latest version (1.09)
    ---> Using the port instead of a package
    ---> Installing 'mod_fcgid-1.09' from a port (www/mod_fcgid)
    ---> Building '/usr/ports/www/mod_fcgid'
    ===> Vulnerability check disabled, database not found
    => mod_fcgid.1.09.tar.gz doesn't seem to exist in /usr/ports/distfiles/.
    => Attempting to fetch from http://fastcgi.coremail.cn/.
    fetch: http://fastcgi.coremail.cn/mod_fcgid.1.09.tar.gz: No address record
    => Attempting to fetch from ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/vanilla/.
    fetch: ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/vanilla/mod_fcgid.1.09.tar.gz: File unavailable (e.g., file not found, no access)
    => Attempting to fetch from ftp://ftp.se.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/vanilla/.
    fetch: ftp://ftp.se.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/vanilla/mod_fcgid.1.09.tar.gz: File unavailable (e.g., file not found, no access)
    => Attempting to fetch from ftp://ftp.uk.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/vanilla/.
    fetch: ftp://ftp.uk.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/vanilla/mod_fcgid.1.09.tar.gz: File unavailable (e.g., file not found, no access)
    => Attempting to fetch from ftp://ftp.ru.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/vanilla/.
    fetch: ftp://ftp.ru.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/vanilla/mod_fcgid.1.09.tar.gz: File unavailable (e.g., file not found, no access)
    => Attempting to fetch from ftp://ftp.jp.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/vanilla/.
    fetch: ftp://ftp.jp.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/vanilla/mod_fcgid.1.09.tar.gz: File unavailable (e.g., file not found, no access)
    => Attempting to fetch from ftp://ftp.tw.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/vanilla/.
    fetch: ftp://ftp.tw.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/vanilla/mod_fcgid.1.09.tar.gz: File unavailable (e.g., file not found, no access)
    => Attempting to fetch from ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/.
    fetch: ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/mod_fcgid.1.09.tar.gz: File unavailable (e.g., file not found, no access)
    => Couldn't fetch it - please try to retrieve this
    => port manually into /usr/ports/distfiles/ and try again.
    *** Error code 1

    Stop in /usr/ports/www/mod_fcgid.
    ** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade.38059.0 env make
    ** Fix the problem and try again.
    ** Listing the failed packages (*:skipped / !:failed)
    ! www/mod_fcgid (fetch error)
    ---> Packages processed: 0 done, 0 ignored, 0 skipped and 1 failed
    Unable to install some components
    *** Error code 1

    Stop in /usr/ports/swsoft/psa-rubyrails-configurator.
    *** Error code 1

    Stop in /usr/ports/swsoft/psa-rubyrails-configurator.
    *** Error code 1

    Stop in /usr/ports/swsoft/psa-rubyrails-configurator.
    *** Error code 1

    Stop in /usr/ports/swsoft/psa-rubyrails-configurator.
    ** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade.11601.0 env make ARCH=i386 OPSYS=FreeBSD OSREL=5.5 OSVERSION=505000 PORTOBJFORMAT=elf SYSTEMVERSION=
    ** Fix the problem and try again.
    ** Listing the failed packages (*:skipped / !:failed)
    ! swsoft/psa-rubyrails-configurator (fetch error)
    ---> Packages processed: 0 done, 0 ignored, 0 skipped and 1 failed
    *** Error code 1
     
  2. ItMan

    ItMan Guest

    0
     
    Update ports with cvsup and it will be work.
     
  3. Whistler

    Whistler Guest

    0
     
    Your error has nothing to do with installation of the backup manager. Its the installation of mod_fcgid (used by Ruby on Rails) that fails.

    And it fails due to the fact that the ports package can't be fetched.

    I has the problem here also - and the easiest way is to manually fetch the package from the homepage http://fastcgi.coremail.cn/download.htm and put the file in /usr/ports/distfiles

    I haven't tested if the newer versions can be used without problems - but if you fetch the 1.09 version it will work.

    I suspect the autoinstaller having problems with resolving the correct IP for that fastcgi.coremail.cn domain causing the file to not be downloaded. But diden't dig in further on the problem.
     
  4. hansel

    hansel Guest

    0
     
    The easiest way I guess is:

    cd /usr/ports/www/mod_fcgid
    make deinstall
    make reinstall

    And do a 'make reinstall' in /usr/ports/swsoft.

    It's possible you'll get some more md5 mismatched, but simply find the port, go to it, do a make deinstall; make NO_CHECKSUM; make reinstall and continu.

    It's **** with the hotfix4 around, the very first 8.1.0 installed without a glitch.
     
Loading...