1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

psa-spamassassin fails after Perl update

Discussion in 'Plesk for Linux - 8.x and Older' started by capaho, Aug 7, 2008.

  1. capaho

    capaho Guest

    0
     
    After the last Perl update from Red Hat, psa-spamassassin fails with the follwing error message:

    no loaded plugin implements 'check_main': cannot scan! at /usr/lib/perl5/site_perl
    /5.8.5/Mail/SpamAssassin/PerMsgStatus.pm line 164.

    The plugin is loaded by the v320.pre config file in /etc/mail/spamassassin and spamassassin itself is working, but psa-spamassassin fails to start.

    Any ideas on this one?
     
  2. Jllynch

    Jllynch Regular Pleskian

    28
     
    Joined:
    Nov 11, 2003
    Messages:
    242
    Likes Received:
    0
    I think I have a simmilar problem. Did you ever get a solution?
     
  3. capaho

    capaho Guest

    0
     
    No, I couldn't find any helpful information on this problem anywhere. SpamAssassin itself is working, but the functions provided by psa-spamassassin are disabled. I may try to force a re-install of the CPAN Mail::SpamAssassin modules and see if that fixes it, but I haven't done it yet.
     
  4. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    I believe this is resolved in the 3.2.5 release of spamassassin, I have it available in the atomic yum repo if rhel5 doesnt have it.
     
  5. capaho

    capaho Guest

    0
     
    I am having the problem with SpamAssassin 3.2.5, and the problem started with Perl 5.8.5. I suspect this is a problem between psa-spamassassin and Perl that probably needs an update from Plesk, but it appears that Plesk 7.5 Reoladed is no longer supported, considering that it's been at least a couple of years since the last time any updates were released for it.
     
Loading...