1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Qmail errors : "handlers permanentfail"

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by regisg, Feb 10, 2010.

  1. regisg

    regisg Regular Pleskian

    24
    90%
    Joined:
    Jan 19, 2010
    Messages:
    112
    Likes Received:
    1
    Hello,

    My VPS : Plesk 9.3, CentOS 5.2, Postfix 2.3.3

    Well, i must say that i am a bit irritated with all these persistent smtp errors...

    First, i used Postfix and was confronted to this bug : Mail Redirect (still) doesn't work right with Postfix & CentOS
    As the issue was not fixed, i switched postfix to qmail, and this bug disappeared.

    But now... i am confronted to ANOTHER BUG with qmail : some mails are not delivered !!
    Only certain types of mails, like autoresponders mails (but only when mails are sent from external email adresses/clients, see bellow) and also certain mails sent from php scripts...

    In my Server-wide mail preferences, i have :
    Enable message submission : ON
    Relay options : authorization is required: SMTP
    DomainKeys spam protection :
    Allow signing outgoing mail : ON
    Verify incoming mail : ON


    Is there a fix for that ?

    THX...
     
    Last edited: Feb 10, 2010
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    Any related errors from /usr/local/psa/var/log/maillog ?
     
  3. regisg

    regisg Regular Pleskian

    24
    90%
    Joined:
    Jan 19, 2010
    Messages:
    112
    Likes Received:
    1
    Resolved

    Problem resolved after :
    /usr/local/psa/admin/sbin/mchk --with-spam
    (it seems that this operation is necessary after switching postfix <->qmail from the plesk autoinstaller...)
     
Loading...