1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Qmail + Greylisting + Blacklists + AV-Filtering

Discussion in 'Plesk for Linux - 8.x and Older' started by sjuerges, Apr 19, 2006.

  1. sjuerges

    sjuerges Guest

    0
     
    Hey.

    This whole qmail setup thing with plesk patched qmail is frustrating to the max.

    One my no-plesk server i run a clean mail system, that is doing its job nicely:

    MTA:
    PostFix, SASL Auth, SSL-only

    Content-Filter:
    amavisd

    SpamFilter:
    SpamAssassin
    Vipul's Razor
    DCC

    AV-Filter
    F-Prot AV
    ClamAV
    Sophos AV

    Blacklists:
    combined.njabl.org
    opm.blitzed.org
    relays.ordb.org
    cbl.abuseat.org
    opm.blitzed.org
    sbl-xbl.spamhaus.org

    Policys:
    reverse PTR must exist
    SPF-Policy
    Greylisting for 300s

    Now, I've been trying to get a similar setup using qmail, but its being a MAJOR pain in the **** (four letters :D)

    Can anyone provide help on the following:
    blacklists under plesk (WITHOUT TIMEOUT PROBLEMS) , reverse ptr checking, greylisting, AV filtering with something other than drweb, vipul & dcc

    Regards,
    Sebastian M Juerges
     
  2. Lars@

    Lars@ Guest

    0
     
  3. sjuerges

    sjuerges Guest

    0
     
    Well, I've been preaching for updating towards postfix anyways. modular, fast, secure and EASY TO CONFIGURE ... damnit .
     
  4. Lars@

    Lars@ Guest

    0
     
    Write it in
    - bold,
    - mega huge,
    - red
    - blinking!

    (and tell it my webhoster 1&1!)

    Lars
     
  5. sjuerges

    sjuerges Guest

    0
     
    sif webhost :d sifnt run own server ... the only reason i run a plesk server is because some of my more lazy customers were bitching about a missing interface .. bleh bleh ... the other box is running a massively tuned gentoo, the good stuff.

    I tell you, with the regular stuff (abuse mail checking and so on) i barely touch the gentoo server. i do an update every 3 months or so, and for a week after that i plug the errors that that comes up iwht. the debian plesk box is more broken thatn working. it is giving me the ****ing ****s ... :D
     
  6. sjuerges

    sjuerges Guest

    0
     
    oh, and lets not forget, 1 & 1 is !"§%)!"$ ...

    Seb -
    Kiel, Germany
     
  7. Lars@

    Lars@ Guest

    0
     
    Mit Confixx war das alles kein Problem

    With Confixx there were no problems at all

    Plesk is Hell©

    Lars
     
  8. sjuerges

    sjuerges Guest

    0
     
    Yeh, but the web1 web2 stuff annoyed me to death :D

    now at least i know who is who :D

    Oh, and btw, found a workaround for the SA plesk 8 problem.
     
  9. Lars@

    Lars@ Guest

    0
     
    please tell me/us more ;)

    Lars
     
  10. sjuerges

    sjuerges Guest

    0
     
  11. buddaaa

    buddaaa Guest

    0
     
    i've installed postfix with all antispam-features and let qmail only sort mails into mailboxes:

    http://rupp.de/howto_install_postfix_before_qmail.html

    since i hope that swsoft finally adds support for postfix on the 10th anivesary of the last official qmail release it seems resonable to get more involved with crappy qmail ;)
     
  12. k.satirli

    k.satirli Guest

    0
     
    if you dislike the way plesk utilizes outdated technology, why dont you switch back to confixx or even another hosting panel?

    there are plenty out there, some let you choose on the fly which ftp or mail server you want to use...

    or even better - write your own or base it on visas / webmin and customize it heavily - that way you only get what YOU need :)
     
  13. sjuerges

    sjuerges Guest

    0
     
    Point is ... plesk is nice, i like the technology, and most parts of how its handled.

    There are just a few things, that need to be dont differently. for example, replacing outdated and not up to security standards software like qmail, and replacing it with fast, yet modular software like postfix.

    Everything, even RBL support is easier in postfix.

    I can setup a fully working, secured, spam and av filtering postfix server on gentoo in LESS than 15 minutes, with it pulling mail account from a mysql database included.

    Technolgy like regular expression mailadresses (let me just say postmaster@* or abuse@*) make postfix clearly the better choice for a production mail system, not to mention the speed test results.

    All in all, plesk is a good product, if you want easy configurability, but for stability, that is something swsoft needs to work on. Oh, and another example: SA 3.0.3 is what is being used with PSA. That is ridiculously outdated (27-04-2005) ...

    Meh, enough rambling. I'm done with qmail ... i wrote myself some scripts that analyse the .qmail files and create postfxi virtuals from it. Dont ask me for it, i wont give it out, as workarounds only stop swsoft from taking this serious. Enough to say that it works, and that postfix/amavisd-new/clamav/rbl's/spamassasin/ works at least 5 times fast than qmail / sa ... and that is just ridiculous. (25 seconds until one mail is processed for qmail, 5 seconds (including all filtering) in postfix) ...

    a very disappointed
    Seb
     
  14. Lars@

    Lars@ Guest

    0
     
    The version of phpMyAdmin shipped with Plesk 8.0 is from 2005-10-22. The current version for the release of Plesk 8.0 (2006-03-31) was from 2006-03-16 (phpMyAdmin 2.8.0.2). Now the current version is phpMyAdmin 2.8.0.3 from 2006-03-16.http://forum.swsoft.com/showthread.php?s=&threadid=32826

    I will cancel my server contract. If my hosting provider asks for the reason they get only one word => "Plesk 8.0"
    Lars
     
  15. k.satirli

    k.satirli Guest

    0
     
    you do realize that

    using the latest
    and greatest
    isnt always the smartest
    (thing to do... dont you?)

    still, keep us posted about your problems - swsoft might fix them if they see enough reports :)
     
  16. sjuerges

    sjuerges Guest

    0
     
    hehe, i fully agree ... i aint for bleeding edge php 5 / mysql 5 either ... stabel php 4 and mysql 4 does just fine, and doesnt crash anywhere NEAR as often :D ..

    but there are some areas (in particular mailserver and anti-spam and anti-virus systems) that NEED to be "bleeding edge" to actually be any good.

    I wouldnt ***** because some php script doesnt run on plesk, coz it needs php 5 ... so waht, ill just use one of the bazillion other scripts. But im touchy when it comes to my mailservers. (especially because that is my main source of income ... :D)

    (and besides that, postfix aint the newest / greatest ... its just stable, fast and secure)

    Meh, i'm preaching again. I'l shut up now. but i'd sure like to hear opinions ...

    Seb
     
  17. Lars@

    Lars@ Guest

    0
     
    I am feeling locked out

    With Plesk I have the feeling that I am locked out of my system. I don't control the system anymore, the system controls me! I need to find workarounds for bugs and annoyances.

    Lars
     
Loading...