1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

qmail local delivery to root failures

Discussion in 'Plesk for Linux - 8.x and Older' started by Anton Akola, May 2, 2007.

  1. Anton Akola

    Anton Akola Guest

    0
     
    Seems that Swsoft has entered a new business model:

    Cripple its updates with as much bugs as possible and cash on the paying support customers. All and all, spam and bugs, Plesk is more and more a piece of ****.

    As for this forum: try a search, find nothing, compose your post, be logged out before you can post. A fine showcase of the SWSoft expertise.

    There are people using server virtualization software from the same experts I am told! They can't even do some PHP right!

    Other than that, I've checked all the following:

    . User alias exist, has its home directory in /var/qmail/alias and UID 2021

    . /var/qmail/alias contains:
    -rw-r--r-- 1 root qmail 16 May 2 01:07 .qmail-abuse
    -rw-r--r-- 1 root qmail 16 May 2 01:07 .qmail-hostmaster
    -rw-r--r-- 1 root qmail 16 Jul 26 2006 .qmail-mailer-daemon
    -rw-r--r-- 1 root qmail 16 Jul 26 2006 .qmail-postmaster
    -rw-r--r-- 1 root qmail 16 Jul 26 2006 .qmail-root

    . All these files contain the same &name@host.tld that was perfectly working up to Plesk 8.1

    . /usr/local/psa/var/log/maillog messages:
    May 2 11:46:47 host qmail: 1178099207.936604 new msg 251709518
    May 2 11:46:47 host qmail: 1178099207.937026 info msg 251709518: bytes 229 from <root@host.tld> qp 21298 uid 0
    May 2 11:46:47 host qmail: 1178099207.937153 starting delivery 26: msg 251709518 to local root@host.tld
    May 2 11:46:47 host qmail: 1178099207.937213 status: local 1/10 remote 0/20
    May 2 11:46:47 host qmail: 1178099207.940882 delivery 26: failure:
    May 2 11:46:47 host qmail: 1178099207.941015 status: local 0/10 remote 0/20
    May 2 11:46:47 host qmail: 1178099207.945726 bounce msg 251709518 qp 21301
    May 2 11:46:47 host qmail: 1178099207.945934 end msg 251709518
    May 2 11:46:47 host qmail: 1178099207.946184 new msg 251709519
    May 2 11:46:47 host qmail: 1178099207.946243 info msg 251709519: bytes 726 from <> qp 21302 uid 2522
    May 2 11:46:47 host qmail: 1178099207.952114 starting delivery 27: msg 251709519 to local root@host.tld
    May 2 11:46:47 host qmail: 1178099207.952522 status: local 1/10 remote 0/20
    May 2 11:46:47 host qmail: 1178099207.955938 delivery 27: failure:
    May 2 11:46:47 host qmail: 1178099207.956345 status: local 0/10 remote 0/20
    May 2 11:46:47 host qmail: 1178099207.961360 bounce msg 251709519 qp 21305
    May 2 11:46:47 host qmail: 1178099207.961684 end msg 251709519
    May 2 11:46:47 host qmail: 1178099207.961749 new msg 251709523
    May 2 11:46:47 host qmail: 1178099207.961807 info msg 251709523: bytes 1139 from <#@[]> qp 21306 uid 2522
    May 2 11:46:47 host qmail: 1178099207.967929 starting delivery 28: msg 251709523 to local postmaster@host.net
    May 2 11:46:47 host qmail: 1178099207.968245 status: local 1/10 remote 0/20
    May 2 11:46:47 host qmail: 1178099207.969754 delivery 28: failure:
    May 2 11:46:47 host qmail: 1178099207.969826 status: local 0/10 remote 0/20
    May 2 11:46:47 host qmail: 1178099207.969883 triple bounce: discarding bounce/251709523
    May 2 11:46:47 host qmail: 1178099207.969937 end msg 251709523

    qmail is otherwise working fine. Users can send and receive mails with other hosts and use the horde Webmail.

    Trouble is limited to sending local mails to root (which implies mandatory use of aliases with qmail, vanilla qmail at least).
     
  2. dirty@

    dirty@ Guest

    0
     
    > delivery 26: failure:

    such failure report w/o any details is very similar to the situation when your hostname is in qmail/control/locals file.. the file must contain 'localhost' only, remove all entries except 'localhost' from there and restart qmail..
     
  3. Anton Akola

    Anton Akola Guest

    0
     
    It is.
    Can't see why it should:
    http://www.qmail.org/man/man8/qmail-send.html
    Tried that anyway... And the local host name should definitely stay in locals as the new error message in maillog is:
    Code:
    May  2 16:19:38 host qmail: 1178115578.238255 delivery 3: failure: Sorry._Although_I'm_listed_as_a_best-preference_MX_or_A_for_that_host,/it_isn't_in_my_control/locals_file,_so_I_don't_treat_it_as
    _local._(#5.4.6)/
    Thanks for your suggestion anyway. :)
     
  4. argon@

    argon@ Guest

    0
     
    I've got the same problem.
    (There's another with the same: http://forum.swsoft.com/showthread.php?threadid=43374)

    I am running SUSE 10.0 32bit and Plesk 8.1.1 with both updated to the latest state.

    This problem occured right after the update to Plesk 8.1 (from 8).

    Is there a way to get qmail more verbose on errosr? I really would like to get the local messages.

    Is there anyone running that configuration where it actually works to deliver local mail? Does it work on Debian etc.?

    If so, could you plese post your config, say, as tgz (with file perms etc)?

    Thanks in advance,
    Andreas.
     
  5. Anton Akola

    Anton Akola Guest

    0
     
    And there seem to be similar problems involving apparently DrWeb or Spam Assassin which could be in fact related as well.
    FC4 32 bits "fully" updated in my case (FC4 is a bit old though).
    Agreed.
    It seems to me that precisely the fact that no message appears after "failure:" is very odd in itself and might come from a clumsy SWSoft patching of QMail.
     
  6. cfairchild

    cfairchild Guest

    0
     
    Has anyone found a solution to this problem. I have also run into this problem after installing 8.1.1 on a fresh build of Fedora Core 6. However I noticed that Plesk has their own executable for qmail-local and when I replaced it with the default the mailing to the root alias started working.

    Code:
    [root@localhost bin]# ls -l /var/qmail/bin/qmail-local*
    -r-xr-xr-x 1 root qmail 25576 Mar 22 07:42 /var/qmail/bin/qmail-local*
    -r-xr-xr-x 1 root qmail 54480 May  4 07:09 /var/qmail/bin/qmail-local.moved*
    -r-xr-xr-x 1 root qmail 25576 Mar 22 07:42 /var/qmail/bin/qmail-local.plesk*
    
    However I do not know what other problems will be introduced if I leave the other binary in place.
     
  7. Anton Akola

    Anton Akola Guest

    0
     
    Havn't found any solution yet. (Other than change manually e-mail addresses in crontabs, etc.)

    I don't expect any solution from SWSoft either. Not anytime soon if past experience serve (let say for instance that AWStats many bugs are still there, probably for long).

    I've restrained from doing what you did as it is bound to break many things in Plesk, judging by the importance of the patch applied (didn't find the specific patch for 8.1): SWSoft Knowledge Base.

    In the meantime, all administrative mails sent to root are lost. This is just great to keep an eye on the kettle...

    Just hope that this struck only a small part of all Plesk for Linux users.
     
  8. cfairchild

    cfairchild Guest

    0
     
    I have logged a support case on this issue and they confirm that it is an issue and that their developers are working on fixing this "feature" of qmail. However there really seemed to be no urgency in their reply as they said that it will be fixed in one of the future releases of Plesk. I think I will try procmail forwarding as I had managed that on one of my other Plesk boxes a few years ago, and perhaps it may pass the message to another local mail program without running into problems.
     
  9. hesham55

    hesham55 Guest

    0
     
    i have the same problem

    41: failure: Sorry._Although_I'm_listed_as_a_best-preference_MX_or_A_for_that_host,/it_isn't_in_my_control/locals_file,_so_I_don't_treat_it_as_local._(#5.4.6)/
     
  10. Anton Akola

    Anton Akola Guest

    0
     
    Most probably it isn't the same problem.

    Check the content of (could be in another place):
    /var/qmail/control/locals

    This file should contain all the host names for which you want e-mails to be delivered locally.

    See man qmail-control and man qmail-send for more information.

    HTH
     
  11. chanam

    chanam Guest

    0
     
    any news? i have the same problem, no local mail to root after upgrading to 8.1.1 :(
     
  12. Anton Akola

    Anton Akola Guest

    0
     
    Still broken in 8.1.1

    Absolutely no news, and no fix in 8.1.1, as you note.

    Can't say I'm surprised. Most bugs stays for months, and several releases, before they are fixed, if they ever are. (Just look at the awstats troubles, for instance.)

    SWSoft sure doesn't care about bugs. It's only interested in costumers paying for support (but not in solving their troubles, mind you).
     
  13. Anton Akola

    Anton Akola Guest

    0
     
    Solved with Plesk 8.2

    Although not mentioned anywhere, it seems that this problem is solved in Plesk 8.2.

    At least, it is for me (on fedora 4, hosted by 1&1). And for the moment, I have no new problem with 8.2.

    Could be a mightily good idea to check what others say about upgrading before jumping though.

    HTH.
     
Loading...