1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

QMail Performance Tuning

Discussion in 'Plesk for Linux - 8.x and Older' started by d-woo, Aug 3, 2006.

  1. d-woo

    d-woo Guest

    0
     
    On the official Mailman FAQ site it is stated:

    I didn't have a concurrencyremote file in /var/qmail/control (I have the RPM build)

    Adding that file did not help.

    I sent an announcement email to 100K email addresses (validated and bona fide).

    I used both EZMLM and Mailman.

    Both programs filled up the mail queue and delivery was quite slower than on a Plesk 5 box that I moved from.

    I now have Plesk 8 and 2 GB more RAM than on my Plesk 5 box....

    Is it possible that Qmail is doing DNS resolution on recipients for messages delivered locally?

    Is there a fix for this?

    Is there a way to use qmail-inject?
     
  2. d-woo

    d-woo Guest

    0
     
    Okay,

    I modified /etc/xinetd.d/smtp_psa by adding the -Rt0 to prevent reverse lookup.

    Code:
    service smtp
    {
    	socket_type     = stream
    	protocol        = tcp
    	wait            = no
    	disable		= no
    	user            = root
    	instances       = UNLIMITED
    	server          = /var/qmail/bin/tcp-env
    	server_args     = -Rt0 /var/qmail/bin/relaylock /var/qmail/bin/qmail-smtpd 
    /var/qmail/bin/smtp_auth /var/qmail/bin/true /var/qmail/bin/cmd5checkpw
     /var/qmail/bin/true
    }
    Hopefully this was my issue.


    Man..these new boxes are something!
     
  3. cmurphy@

    cmurphy@ Guest

    0
     
    SMTP Timeout

    Plesk 8
    Fedora Core 4

    all our customers on Dial Up internet access time out attempting to connect to SMTP. Those on braodband take WAY to long to send mail.

    i have made the following fix:

    Code:
    service smtp
    {
            socket_type     = stream
            protocol        = tcp
            wait            = no
            disable         = no
            user            = root
            instances       = UNLIMITED
            server          = /var/qmail/bin/tcp-env
            server_args     = -Rt0 /var/qmail/bin/relaylock /var/qmail/bin/qmail-smtpd /var/qmail/bin/smtp_auth /var/qmail/bin/true /var/qmail/bin/cmd5checkpw /var/qmail/bin/true
    }
    
    But the problem still exists. Is it not reading this file? how do we tell if reverse DNS has stopped accurring? This problem is terrible, please help.
     
  4. d-woo

    d-woo Guest

    0
     
    CMurphy,

    Are your users using "My Server Requires Authentication"?

    We had to make sure that in Outlook they put their full email address (not just username) and password under More Settings>>Outgoing Server.

    Check the top box My Outgoing Server Requires Authenticationthen select Log On Using vs Use Same Settings As My Incoming Server

    Additionally, I think I remember someone stating that they had to restart their entire server. Restarting Qmail and Xinet.d was not enough....I think I read that....but cannot find the post.
     
  5. cmurphy@

    cmurphy@ Guest

    0
     
    Well its not just outlook customers, its those using Thunderbird as well.

    It just takes forever for those using dial up to connect. Those on DSL have a better time but its still not very fast.
     
  6. Sean Dempsey

    Sean Dempsey Guest

    0
     
    I have this same problem and have not been able to find any solution in either thunderbird or outlook express.
     
  7. LogicalOutput

    LogicalOutput Guest

    0
     
    Same SMTP Problem

    I'm having the same problem. Sending emails in Outlook takes about 30 seconds to authenticate and send.
    telnet on port 25 takes about 30 seconds to authenticate. I have -Rt0 on the server_args line in the smtp_psa file and still no luck.

    Even if i run a script FROM within the same server to send out emails and the script authenticates via SMTP it still takes 30 seconds to send out.

    Has anyone figured this one out yet?
     
  8. joda

    joda Guest

    0
     
    If the server is: Debian 3.x

    Hi all,

    The mentioned ways is also posible on Debian server.

    Do as following:

    Code:
    vi /etc/inetd.conf
    Edit the smtp and smtps lines to look like the following:

    Code:
    smtp stream tcp nowait.1000 root /var/qmail/bin/tcp-env tcp-env -Rt0 /var/qmail/bin/relaylock /var/qmail/bin/qmail-smtpd /var/qmail/bin/smtp_auth /var/qmail/bin/true /var/qmail/bin/cmd5checkpw /var/qmail/bin/true
    smtps stream tcp nowait.1000 root /var/qmail/bin/tcp-env tcp-env -Rt0 /var/qmail/bin/relaylock /var/qmail/bin/qmail-smtpd /var/qmail/bin/smtp_auth /var/qmail/bin/true /var/qmail/bin/cmd5checkpw /var/qmail/bin/true
    
    Save the file, and restart the inetd daemon.
     
Loading...