1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

QMail Problem after upgrade to 8.1.1

Discussion in 'Plesk for Linux - 8.x and Older' started by helmi, Mar 28, 2007.

  1. helmi

    helmi Guest

    0
     
    anyone else not able to send out mails after the actual update?

    qmail fills up the queue (800 mails and counting) but doesn't send anything out.

    any ideas yet how to get it fixed? I removed dr. web and spamassassing. dr. web seems to have licencing issues after the update.

    best,
    helmi
     
  2. helmi

    helmi Guest

    0
     
    anyone else with this problem? any solutions yet?
     
  3. crnunez

    crnunez Regular Pleskian

    25
    90%
    Joined:
    May 24, 2006
    Messages:
    124
    Likes Received:
    0
    I have the same problem. Qmail doesnt star!!1
     
  4. fizz

    fizz Guest

    0
     
    I too have this problem. I cant even add domains to customer accounts either.. it specifies a qmail problem and quits with a plesk fatal exception.
     
  5. Hal9000

    Hal9000 Guest

    0
     
    what operating system are you guys using?
     
  6. fizz

    fizz Guest

    0
     
    **** *** fedora.. Old version... Were waiting for the new server to get here in which Ill be loading Ubuntu Server on... Then just have to figure out how to move all the data..
     
  7. fizz

    fizz Guest

    0
     
    Ok guys.. this is what was done on my server to fix the issue.

    First, make sure you have the psa-qmail update in /root/psa/PSA_8.1.1/{dist}/base


    next, rpm-q psa-qmail
    {should out put one, but in my case, there were 5}
    rpm -el --nodeps nameinlist

    I removed all 5

    The rpm -ivh psa-qmail-1.03-fc1.build80170322.17.i586.rpm

    Now everything is working again! your milage may vary but this is what got me up and running.
     
  8. SpidermonBob

    SpidermonBob Guest

    0
     
    this Qmail problem sounds farmiliar

    Yes, this Qmail problem sounds familiar, Maybe my past upgrade experience will help...




    This is my current configuration…

    Hostname www.mydomain.com
    Plesk version psa v8.1.0_build81061226.14 os_Debian 3.1
    Operating system Linux 2.6.8-3-686
    License key number PLSK.00000000.0002

    Plesk currently indicates there 2 updates available...
    New updates are available for Plesk 8.1.0, Plesk 8.1.1

    ...However after the grief I experienced trying to upgrade from v8.0.1 to v8.1.0 I am extremely reluctant to perform the new upgrades. I can not afford to have my server and all my clients’ domains go down again for 4 to 5 days. It is apparent from all the recent post that upgrading Plesk to v8.1.1 is plagued with similar problems. And very few solutions to problems seem to be posted here.

    Perhaps, what I experienced when I upgraded to v8.0.1 will be of assistance to those having Qmail problems following the v8.1.1 upgrade. If this works please let me know…

    ---------------Email from Plesk FrontLine Support --------->

    Hello,
    >
    > You have 'inetutils-inetd' package installed. Plesk does not support it
    > natively and thus normally it should not start at all.
    > But it is functional due to stale '/etc/init.d/inetd' file; because Plesk
    > supports only 'netkit-inetd' and 'xinetd' packages on Debian it suppose that
    > you have 'netkit-inetd' package installed:
    >
    > # ls -l /etc/init.d/inetd
    > -rwxr-xr-x 1 root root 1764 2004-10-24 12:28 /etc/init.d/inetd
    > # dpkg -S /etc/init.d/inetd
    > netkit-inetd: /etc/init.d/inetd
    >
    > And thus Plesk tries to do '/etc/init.d/inetd restart' to manage inetd. But
    > this has no sense for inetutils-inetd.
    >
    > So there are two ways to resolve your issue:
    > 1) deinstall 'inetutils-inetd' package and install 'netkit-inetd' package
    > back (since 'netkit-inetd' is a 'functionality' either, you may need to do it
    > via 'aptitude' program);
    > 2) remove stale '/etc/init.d/inetd' file and make a symbolic link to allow
    > Plesk manage inetutils-inetd:
    >
    > # rm -f /etc/init.d/inetd
    > # ln -s inetutils-inetd /etc/init.d/inetd
    >
    >
    > This should help. Please decide which way you can do it and let us know if
    > there is something unclear left.
    >
    > ---
    <--------------- end of Email from Plesk FrontLine Support ---------


    ... after a few days SWsoft Tech Support logged into my server & fixed the problem, I am not exactly sure what they did but it had to do with the problem they indicated...

    I hope this helps, but I am not sure if this has anything to do with the current Qmail problem, but the symthom sounds very similat. Qmail would start but would immediately stop...

    If this works or if there is something different that needs to be done on this new upgrade, please let me and everyone else know...

    thanks
     
  9. crnunez

    crnunez Regular Pleskian

    25
    90%
    Joined:
    May 24, 2006
    Messages:
    124
    Likes Received:
    0
    REL4

    Solution: Remove all Maps zones, and restart qmail. After this you can add 1 zone.
     
  10. HMnet

    HMnet Basic Pleskian

    24
    73%
    Joined:
    Mar 30, 2004
    Messages:
    32
    Likes Received:
    0
    Sorry, but this doens'nt solve my problem.

    My OS is Suse 9.3 (1&1 Server).

    Qmail service is running. I can start or stop it, but no Mails were dilivered.

    The problem is really urgent.

    My customers are gettign angry.

    Any other ideas?

    Hopefully, HMnet
     
  11. HMnet

    HMnet Basic Pleskian

    24
    73%
    Joined:
    Mar 30, 2004
    Messages:
    32
    Likes Received:
    0
    @ crnunez:

    I want to remove the maps zone via the control panel, this doesn't function. Plesk quits with a fatal error:

    Unable to update superserver configuration file: MailMng->setMapsProtection() failed: mailmng failed: mailmng: popen_exec: command failed code: 1 , Unable to determine the domain name of your computer.
    Please, run the 'domainname' or 'hostname -f' command
    from the console and make sure that the command returns your domain name.
    
    ERROR while trying to get domain name
    Check the error reason(see log file: /tmp/psa-rblmng-script___reconfiguration.log), fix and try again

    So I removed the maps manually via /etc/xinetd.d/smtp_psa and /etc/xinetd.d/smtps_psa

    xinet.d restarted - but no mails were deliverd
     
  12. HMnet

    HMnet Basic Pleskian

    24
    73%
    Joined:
    Mar 30, 2004
    Messages:
    32
    Likes Received:
    0
    If I send an email to the plesk-server, I got this mailer-deamon-error:

    Hi. This is the qmail-send program at xxx.rootmaster.info.
    I'm afraid I wasn't able to deliver your message to the following addresses.
    This is a permanent error; I've given up. Sorry it didn't work out.
    ...
    Received-SPF: none (www.xxx.info: domain at xxx.de does not designate permitted sender hosts)
    ...

    I hope anyone can help me soon...

    HMnet
     
  13. HMnet

    HMnet Basic Pleskian

    24
    73%
    Joined:
    Mar 30, 2004
    Messages:
    32
    Likes Received:
    0
    OK, I think problem is solved...

    I post the solution in a few minutes... ;)
     
  14. HMnet

    HMnet Basic Pleskian

    24
    73%
    Joined:
    Mar 30, 2004
    Messages:
    32
    Likes Received:
    0
    Sorry, for the delay...

    Here is my solution:
    In my case the file /etc/hosts had wrong entries, so the plesk-autoinstaller started the installation and aborts after a few moments. So the installation wasn't finished correctly and some parts of the 8.1.1 were already installed but the files were still version 8.1.0.
    So I corrected the hosts-file, and started the installation manually again. The control-panel installation doesn't worked:
    I located the files in the folder: /srv/psa/PSA_8.1.1/<dist>/base
    an ran the rpm -U command with the psa-8.1.1-suse9.3.build81070322.16.x86_64.rpm

    After this update-installation the mails were delivered again and I was able to do the rest of the update over the cp.

    HMnet
     
  15. eugenevdm

    eugenevdm Silver Pleskian

    30
    68%
    Joined:
    Nov 11, 2003
    Messages:
    611
    Likes Received:
    0
    Re: REL4

    I had the same problem as crnunez, and also noticed that the -Rt0 switched stopped working.

    Then when I removed all MAPS zones Qmail started working and so also the -Rt0 switch. Looks like /var/qmail/bin/relaylock is broken?
     
  16. nulleffect

    nulleffect Guest

    0
     
    How do you remove qmail MAPS zones?
     
  17. eugenevdm

    eugenevdm Silver Pleskian

    30
    68%
    Joined:
    Nov 11, 2003
    Messages:
    611
    Likes Received:
    0
    Log in to server as Admin, click on Server, Click on Mail, Untick "DNS zones for RBL+ Service" or remove the entries there.
     
  18. nulleffect

    nulleffect Guest

    0
     
    Oh. I dont have that selected anyway. I have a clean installed of Plesk 8.1.1 on Fedora 6, and i CAN send emails using a normal mail client, but i cant receive any email from apache/php scripts.

    Any ideas anyone!??!
     
  19. eugenevdm

    eugenevdm Silver Pleskian

    30
    68%
    Joined:
    Nov 11, 2003
    Messages:
    611
    Likes Received:
    0
    start a new thread with your problem or contact SWSoft support.
     
  20. MajorWinters

    MajorWinters Guest

    0
     
    Try disabling selinux if activated.
     
Loading...