1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

qmail problem or what?

Discussion in 'Plesk for Linux - 8.x and Older' started by Mr.Yes, Jul 22, 2005.

  1. Mr.Yes

    Mr.Yes Guest

    0
     
    Hi,

    one of my client wrote me that he cannot receive mail from a specific address only.

    Here is what the sender receive when send an e.mail to my client:


    The attached message had transient non-fatal delivery errors

    THIS IS A WARNING MESSAGE ONLY - YOU DO NOT NEED TO RESEND YOUR MESSAGE!

    This server is configured to automatically retry delivery at configured intervals. Subsequent attempts to deliver this message are pending.

    Failed address: mail@clientdomain.com

    --- Session Transcript ---
    Fri 2005-07-22 17:41:56: Parsing Message <xxxxxxxxxxxxxxxxxx\pd50000467248.msg>
    Fri 2005-07-22 17:41:56: From: lorenzo@hisdomain.com Fri 2005-07-22 17:41:56: To: mail@clientdomain.com.com Fri 2005-07-22 17:41:56: Subject:
    Fri 2005-07-22 17:41:56: Message-ID: <!~!UENERkVCMDkAAQACAAAAAAAAAAAAAAAAABgAAAAAAAAAX04EVmCX1U+N3mVE/MnLK8KAAAAQAAAAvXPzQP8HGUa2hhuKO6Lw9wEAAAAA@hisdomain.com>
    Fri 2005-07-22 17:41:56: MX-record resolution of [clientdomain.com] in progress (DNS Server: 10.32.200.17)...
    Fri 2005-07-22 17:41:56: * P=010 D=clientdomain.com TTL=(556) MX=[mail.clientdomain.com] {85.500.87.203} Fri 2005-07-22 17:41:56: Attempting MX: P=010 D=clientdomain.com TTL=(556) MX=[mail.clientdomain.com] {85.500.87.203} Fri 2005-07-22 17:41:56: Attempting SMTP connection to [85.500.87.203 : 25] Fri 2005-07-22 17:41:56: Waiting for socket connection...
    Fri 2005-07-22 17:41:56: Socket connection established (10.32.200.6 : 3457 -> 85.500.87.203 : 25) Fri 2005-07-22 17:41:56: Waiting for protocol initiation...
    Fri 2005-07-22 17:42:25: * Error: 30 second wait for protocol timeout exceeded.
    Fri 2005-07-22 17:42:25: This message is 60 minutes old; it has 0 minutes left in this queue Fri 2005-07-22 17:42:25: Primary queue lifetime exceeded; message placed in retry queue
    --- End Transcript ---
    : Message contains [1] file attachments




    Please help, i'm going crazy :(
     
  2. serial-thrilla

    serial-thrilla Guest

    0
     
    well of course this is the problem:

    Fri 2005-07-22 17:41:56: Socket connection established (10.32.200.6 : 3457 -> 85.500.87.203 : 25) Fri 2005-07-22 17:41:56: Waiting for protocol initiation...
    Fri 2005-07-22 17:42:25: * Error: 30 second wait for protocol timeout exceeded.

    i suppose the question is to ask them (the person sending the message) is if they have this problem sending email to other people as well.

    otherwise, i don't see why it would only affect one client on your end...
     
  3. Mr.Yes

    Mr.Yes Guest

    0
     
    Hi,

    the strange thing is that
    my client says he can receive mails from the same sender to his yahoo mail account.
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Check the values in the following files:

    /var/qmail/control/timeoutconnect
    /var/qmail/control/timeoutremote
    /var/qmail/control/timeoutsmtpd

    To see a list of all control files and their defaults:

    http://www.qmail.org/man/man5/qmail-control.html

    If your server's settings are not too low, then it may be the sender's end has too short of a timeout value, in which case not much you can do about it. :)

    Just had another look, it is the sender's server timing out after 30 secs, not yours. So you should check to see if there is a reason that your server would be taking more than 30 seconds to respond to their server. It may be due to a DNS foul up on the sender's server end, again nothing you can do about that.... ;)
     
  5. Mr.Yes

    Mr.Yes Guest

    0
     
    Hi james,

    here are the only files i have in control dir:

    badmailfrom
    clientcert.pem
    databytes
    dh1024.pem
    dh512.pem
    locals
    me
    rcpthosts
    rejectnonexist
    rsa512.pem
    servercert.pem
    smtpplugins
    virtualdomains

    thanx
     
  6. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Right, those are the default files. The other ones if they don't exist, Qmail uses the default values internally. That's fine.

    One other thing to check would be:

    /etc/xinetd.d/smtp_psa

    Should have a line 'server_args = ...'

    Make sure that after the = is -Rt0, such as this:

    server_args = -Rt0 ....

    This can also cause SMTP connect delays. (old issue)
     
  7. Mr.Yes

    Mr.Yes Guest

    0
     
    Hi,

    here is my smtp_psa:


    service smtp
    {
    socket_type = stream
    protocol = tcp
    wait = no
    disable = no
    user = root
    instances = UNLIMITED
    server = /var/qmail/bin/tcp-env
    server_args = /usr/sbin/rblsmtpd -r relays.ordb.org -r bl.spamcop.net -r list.dsbl.org /var/qmail/bin/relaylock /var/qmail/bin/qmail-smtpd /var/qmail/bin/smtp_auth /var/qmail/bin/true /var/qmail/bin/cmd5checkpw /var/qmail/bin/true
    }


    can i have other kind of problems changing to:


    service smtp
    {
    socket_type = stream
    protocol = tcp
    wait = no
    disable = no
    user = root
    instances = UNLIMITED
    server = /var/qmail/bin/tcp-env
    server_args = /usr/sbin/rblsmtpd -r relays.ordb.org -r bl.spamcop.net -r list.dsbl.org /var/qmail/bin/relaylock -Rt0/var/qmail/bin/qmail-smtpd /var/qmail/bin/smtp_auth /var/qmail/bin/true /var/qmail/bin/cmd5checkpw /var/qmail/bin/true
    }


    ... of course have i to restart qmail?

    thanx
     
  8. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Be careful, look closely at the placement of the -Rt0
    And there is a space before and after the -Rt0

    Another thing which can cause delays in SMTP is the use of RBL lists. If one or more of the RBL's in your list are offline or not answering, then your SMTP server has to wait to timeout trying to query each of the RBL's. Even one not responding can add an unacceptable delay. Thus causing the sender's server to timeout connecting to your server!
     
  9. Mr.Yes

    Mr.Yes Guest

    0
     
    Thanx james,

    do you have this hack on your production server?

    i don't want to compromise my qmail for a single client's problem ..
     
  10. jamesyeeoc

    jamesyeeoc Guest

    0
     
    It's not a hack, but an oversight. I have it on all my servers, this has been a known issue (not really Plesk's fault) since version 5 (or earlier). It has to do with the SMTP, this is not Plesk specific. I have seen this same on other control panel forums as well.

    It does no harm. Too many RBLs do 'harm' in that it slows things down even if they are all responding.

    But even just 1 RBL down can cause too much time delay... Had this happen on a number of Plesk 6 servers way back... I don't use RBLs anymore because of this, well, maybe one RBL....

    It's really not 'our' problem, but when other server admins shorten their timeout values, it then becomes our problem since our clients are affected :D
     
  11. zboyblue

    zboyblue Guest

    0
     
    I tried this and it seemed to work!

    I guess the -Rt0 just tells it not to time out??

    Craig
     
  12. omid

    omid Guest

    0
     
    miss files

    =====
    Check the values in the following files:

    /var/qmail/control/timeoutconnect
    /var/qmail/control/timeoutremote
    /var/qmail/control/timeoutsmtpd
    ===============
    hi
    i dont have any of above file in my server. what i have to do?
    i want to change the timeout setting.
    some email remain in queue witout warn about 7 day and never delete or back to sender.
    it is possible this is for above file missing?
    help me pls
     
  13. jamesyeeoc

    jamesyeeoc Guest

    0
     
    If they are not there, then Qmail will use it's "default" values for each item.

    To specify particular values for those options, you will have to use a plain linux text editor to create each one and put the values in them.

    However, those files are not controlling how long messages stay in the mail queue. The file (or option) you want to check or set is:

    queuelifetime 604800 (default number of seconds, which is 7 days)
     
  14. omid

    omid Guest

    0
     
    Thanks for your help
    I have another question.
    I don't know what I have to write in editor for creating control file for qmail. May you or else paste the line in the qmail control files?
    Files that control timeout setting.
    Thanks a lot
     
  15. jamesyeeoc

    jamesyeeoc Guest

    0
     
    The content of the file will be a single number only. For example, if you wanted the queuelifetime to be 1 day, you would put:

    86400


    and that would be the entire content of the file.
     
  16. omid

    omid Guest

    0
     
    thank u
     
Loading...