1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Quota problem: Invalid cross-device link

Discussion in 'Plesk for Linux - 8.x and Older' started by Gorka, Oct 20, 2007.

  1. Gorka

    Gorka Guest

    0
     
    I'm trying to enable hard disk quota, but I keep getting the "hard disk quota not supported" message.

    Far as I can tell disk quotas are enabled on fstab and running ok, but:

    --------------------------------------------------------
    #/usr/local/psa/admin/sbin/usermng --isquotable
    usermng: Unable to turn on user quota. User quota not supported on device '/dev/md4'

    System error 18: Invalid cross-device link
    usermng: Unable to turn on user quota. User quota not supported on device '/dev/md4'

    System error 18: Invalid cross-device link
    1
    --------------------------------------------------------

    The fstab entries:
    --------------------------------------------------------
    # cat /etc/fstab
    /dev/md0 /boot ext3 errors=remount-ro 0 1
    /dev/md2 / reiserfs defaults,usrquota,grpquota 0 0
    /dev/md1 none swap sw 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs defaults 0 0
    /dev/md4 /usr reiserfs auto,defaults,noatime,nodiratime,usrquota 0 0
    --------------------------------------------------------

    I already followed some other threads on the forum and did the remount+quotaoff+quotacheck+quotaon procedure to no success.

    Could anybody help with this?
     
  2. anb_t

    anb_t Guest

    0
     
    Here is an SWsoft knowledge base article concerning your problem:

    http://kb.swsoft.com/article_16_768_en.html
    =================================================
    First of all make sure that quota is supported by kernel. It should be compiled into the kernel or loaded as module.

    You can check if quota is configured properly with this command line:
    /usr/local/psa/admin/sbin/usermng --isquotable

    Normally, it should return "0".

    If the utility returns the following error message:

    usermng: Unable to turn on user quota. User quota not supported on device '/dev/sda3'
    System error 3: No such process


    then, please, make sure that quota is enabled in /etc/fstab for the partitions Plesk stores data on.
    You should add 'usrquota' as it is done in the example below:

    /dev/hda1 / ext3 defaults,usrquota 1 1

    Note: the partition must be remounted after you added usrquota option into /etc/fstab.

    Please update users quota with this command line:
    quotaon /dev/hda1

    Make sure that 'aquota' format is used. It should be an aquota.user file
    in the root of every partition where quota is enabled. If you see
    a 'quota.user' file, please remove it and create the right one:


    rm -f quota.user
    touch aquota.user
    /sbin/quotacheck -fmv /dev/hda1

    Note: you have to use your own device instead of '/dev/hda1'.


    How to configure Quota on FreeBSD can be found at http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/quotas.html
    =================================================

    ./anb
     
  3. Gorka

    Gorka Guest

    0
     
    Thanks anb_t, but I had already read that article and the problem is not the same described in it.

    Disk quotas are enabled, quota files exist and they are in aquota format. Still, I can't get rid of the "hard disk quota not supported" message. I'm only guessing, but the "invalid cross-device link" error makes me think of a broken soft link somewhere in plesk.
     
Loading...