1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

RedHat up2date

Discussion in 'Plesk for Linux - 8.x and Older' started by gilmoure, Apr 12, 2005.

  1. gilmoure

    gilmoure Guest

    0
     
    Hy,
    is it a good idea to use the redhat up2date function to update my system or will this determine conflicts with my Plesk 7.5.2?
     
  2. justyxxxx

    justyxxxx Guest

    0
     
    It's never interfered with mine. I talked with a SWSoft support representative as well and they said that there were some issues before, but that they should be fixed now. This was several months ago. I've had Plesk though for years and it's always worked fine for me.
     
  3. alex042

    alex042 Guest

    0
     
    Unless this has recently been resolved, we've had issues with rebuilding the RPM database when up2date is used in conjuction with plesk updates.
     
  4. rthrash@

    rthrash@ Guest

    0
     
    We've repeatedly run into up2date RPM db conflicts with Plesk updates. What's the "official" line on how to keep your system updated?
     
  5. justyxxxx

    justyxxxx Guest

    0
     
    I was told that this is quite common with RedHat when different processes are trying to open the rpm database in read/write access at the same time.

    I rarely experience the problem now, however, after 7.5.2

    But, it's rather easy to correct by running:

    rm -f /var/lib/rpm/__db.00*

    The above has always worked for me.

    SWSoft has been working toward optimizing the RPM database queries so that corruption is lowered.
     
  6. rthrash@

    rthrash@ Guest

    0
     
    So how do you rectify RedHat's RPM database being version 4 and Plesk expecting version 3, which causes problems in upgrading to newer versions of Plesk?
     
  7. justyxxxx

    justyxxxx Guest

    0
     
    I honestly haven't ever had any problems upgrading except the one time when I ran into an autoinstaller problem and had to run that command line that I gave you. After that, it upgraded fine. I believe that's the only issue I've had with the upgrades and the RPM database.
     
Loading...