1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

root email forward / qmail

Discussion in 'Plesk for Linux - 8.x and Older' started by jagsinc, Jan 8, 2005.

  1. jagsinc

    jagsinc Guest

    0
     
    Does anyone know how to create a email forward for root email?
     
  2. jagsinc

    jagsinc Guest

    0
     
    Cranky @Transnexis.com or Scott @atomicrocketturtle.com can u help me here? Thx.
     
  3. whitecurve

    whitecurve Guest

    0
     
    I got reading roots's mail working yesterday by

    look in /etc/hosts for the domain name alongside the IP address of your machine.

    For example mine is p123456789.pureserver.info
    then add this line to /var/qmail/control/locals on the line beneath localhost. The /var/qmail/control/locals file controls which hosts qmail will treat as "local" and therefor accept mail from.

    So after editing my /var/qmail/control/locals file will look like this:
    Code:
    localhost
    p123456789.pureserver.info
    
    Next in the plesk Admin interface go to
    Server Administration -> Administrator information -> E-mail. this is the mail that will then get all roots mail.

    It worked for me anyway. Please post back how it turns out.
     
  4. jagsinc

    jagsinc Guest

    0
     
    I just want a forward email address for root emails...

    Anyone have any suggestions?
     
  5. whitecurve

    whitecurve Guest

    0
     
    see the above entry for a how to.

    This works for me. Though I'd apprciate others letting me know if it works for them (or a better alternative).
     
  6. jagsinc

    jagsinc Guest

    0
     
    hi whitecurve

    hi whitecurve

    are you saying put your server name below the line with localhost in /var/qmail/control/locals

    this will then send root emails to another email you specify in Server Admin >> Email

    Thx.
     
  7. networkthinking

    networkthinking Guest

    0
     
    hello,
    I tried this above and it did not work for me. I've been searching for this answer for some time to no avail.

    Love to hear some other suggestions.

    Wally
     
  8. jagsinc

    jagsinc Guest

    0
     
    It worked great.

    This must be needed if server name is not in DNS.

    Thanks for the FYI whitecurve.
     
  9. jagsinc

    jagsinc Guest

    0
     
    Did you edit the file /var/qmail/control/locals?

    contents should be on 2 seperate lines:

    # more /var/qmail/control/locals
    localhost
    your.server.name
    #
     
  10. whitecurve

    whitecurve Guest

    0
     
    thats exactly right jagsinc.

    if your machines hostname is not in /var/qmail/control/locals, qmail will treat mail addressed to either the machines IP address or the machines hostname as unknown mail that should not have been delivered to that machine and bounce it. This bouncing will probably be back to itself causeing the dreaded Triple-bounce problem.
     
  11. electronicfur

    electronicfur Guest

    0
     
    Thanks guys. I had this same problem after changing my server hostname via the plesk interface.

    Editing the /var/qmail/control/locals as described fixed the problem for me.

    Cheers,
    EF
     
  12. Whistler

    Whistler Guest

    0
     
    Another way is to create a virtual host for the servername and just setup a forward in the mail preferences settings ( Domain -> Mail -> Preferences -> Forward to adress: - input your mail adress here) - this works great on our systems.
     
Loading...