1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

RPM dependancies

Discussion in 'Plesk for Linux - 8.x and Older' started by sakshale@, Dec 28, 2004.

  1. sakshale@

    sakshale@ Guest

    0
     
    Me again.

    I installed synaptic: http://www.nongnu.org/synaptic/
    and started upgrading items. I immediately ran into a problem. There is a long list of items tagged "Installed (obsolete)".

    For example; psa-7.5.1-rh9.build75041216.14

    When I go to upgrade some key items, such as perl, mysql, etc... all of the "obsolete" files are listed for removal.

    What flags them as "obsolete"?

    # rpm -q --requires psa-7.5.1
    /bin/bash
    /bin/sh
    /bin/sh
    /bin/sh
    /bin/sh
    /bin/sh
    /usr/bin/awk
    /usr/bin/perl
    /usr/bin/scp
    /usr/local/psa/admin/htdocs/locales/default
    /usr/local/psa/tmp/psa.key
    bind >= 9.2.1
    config(psa) = 7.5.1-rh9.build75041216.14
    httpd
    libbz2.so.1
    libc.so.6
    libc.so.6(GLIBC_2.0)
    libc.so.6(GLIBC_2.1)
    libc.so.6(GLIBC_2.1.2)
    libc.so.6(GLIBC_2.1.3)
    libc.so.6(GLIBC_2.2)
    libc.so.6(GLIBC_2.2.3)
    libc.so.6(GLIBC_2.2.4)
    libc.so.6(GLIBC_2.3)
    libcom_err.so.3
    libcrypt.so.1
    libcrypt.so.1(GLIBC_2.0)
    libcrypto.so.4
    libdl.so.2
    libdl.so.2(GLIBC_2.0)
    libdl.so.2(GLIBC_2.1)
    libexpat.so.0
    libgcc_s.so.1
    libgcc_s.so.1(GCC_3.0)
    libgcc_s.so.1(GLIBC_2.0)
    libgdbm.so.2
    libgssapi_krb5.so.2
    libidn.so.11
    libk5crypto.so.3
    libkrb5.so.3
    libm.so.6
    libm.so.6(GLIBC_2.0)
    libnsl.so.1
    libpam.so.0
    libpthread.so.0
    libpthread.so.0(GLIBC_2.0)
    libpthread.so.0(GLIBC_2.1)
    libpthread.so.0(GLIBC_2.2)
    libpthread.so.0(GLIBC_2.3.2)
    libresolv.so.2
    libresolv.so.2(GLIBC_2.0)
    libresolv.so.2(GLIBC_2.2)
    libssl.so.4
    libstdc++-libc6.1-1.so.2
    libstdc++.so.5
    libstdc++.so.5(CXXABI_1.2)
    libstdc++.so.5(GLIBCPP_3.2)
    libxml2.so.2
    libz.so.1
    mod_perl
    mod_ssl
    mysql
    mysql-server
    ntp
    openssh-clients
    perl >= 0:5.003
    perl(AnyDBM_File)
    perl(Fcntl)
    perl(strict)
    php >= 4.0
    php-imap
    php-mysql
    psa-api-cli >= 7.5.1
    psa-api-common >= 7.5.1
    psa-courier-imap-add
    psa-key = 7.5
    psa-locale-base = 7.5.1
    psa-logrotate
    psa-pre >= 7.5.1
    psa-proftpd-start
    psa-qmail
    rpmlib(CompressedFileNames) <= 3.0.4-1
    rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    rpmlib(VersionedDependencies) <= 3.0.3-1
    shadow-utils
    sharutils
    unzip
    webalizer
     
Loading...