1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Security BUG fix not work

Discussion in 'Plesk for Windows - 8.x and Older' started by onuy, Apr 16, 2007.

  1. onuy

    onuy Guest

    0
     
    ../../../boot.ini securty vulnerability fix common_func.php3 is not working correctly. After put common_func plib folder control panel give this error.(Fix page)


    Code:
    Warning: main(common_func.php3) [function.main]: failed to open stream: No such file or directory in C:\pleskserver\admin\auto_prepend\auth.php3 on line 30
    
    Fatal error: main() [function.require]: Failed opening required 'common_func.php3' (include_path='C:\pleskserver\admin\plib;C:\pleskserver\admin\plib\api-rpc;C:\pleskserver\admin\javascripts;C:\pleskserver\admin\plib\locale;C:\pleskserver\admin\auto_prepend;C:\pleskserver\admin\htdocs\domains\databases\phpMyAdmin;C:\pleskserver\admin\htdocs\domains\databases\phpPgAdmin') in C:\pleskserver\admin\auto_prepend\auth.php3 on line 30
     
  2. CryoGenID

    CryoGenID Regular Pleskian

    25
    90%
    Joined:
    Apr 14, 2004
    Messages:
    150
    Likes Received:
    0
    The same here :(

    Great fix... switching back to the backup...
     
  3. kami@

    kami@ Guest

    0
     
    Same error here.

    By the way what is the difference between:
    Plesk 8.1.0
    and
    Plesk 8.1.0 + plesk_8.1.0_update070216.19

    How do I tell which one I need to use?

    Thanks
     
  4. CryoGenID

    CryoGenID Regular Pleskian

    25
    90%
    Joined:
    Apr 14, 2004
    Messages:
    150
    Likes Received:
    0
    Just go to Updater -> Installed Updates
    and look if the update "update070216.19" is installed.
    But you can save your time the "patch" isn't working anyway...

    It patches your plesk to be unusable and so the bug is also fixed :D :D :D

    We've switched back to the original version of the file again...
     
  5. onuy

    onuy Guest

    0
     
    me too... :confused:
     
  6. Data@

    Data@ Guest

    0
     
    Can SWSOFT at least acknowledge that their working on it? This is not the only unanswered bug report... I hope they will respond very soon, or i'm going to ask my money back. Or at least format my system again, as the Plesk uninstaller doesn't work either.
     
  7. tkwebtools

    tkwebtools Guest

    0
     
    Like a idiot I didn't backup the original. And the reason why the "fix" only breaks the control panel is because the files are encoded by Zend Optimizer in binary format. So when you download them the way they link it, it corrupts the file because its not downloading in binary.

    If someone can please zip the original file for me (8.1.1 version) and send it so I can get the control panel working again I would greatly appreciate it. I need it zipped up so it will preserve the binary format.

    Thanks in advance.
     
  8. OlegB

    OlegB Guest

    0
     
  9. kami@

    kami@ Guest

    0
     
    It might be a dumb question to ask, but how do you download the file in binary format???

    Thanks
     
  10. CryoGenID

    CryoGenID Regular Pleskian

    25
    90%
    Joined:
    Apr 14, 2004
    Messages:
    150
    Likes Received:
    0
    Oleg,

    thanks for the information!

    Saving it to the final destination directly solved the issue...
    The Update is now working fine here ;)

    Btw: "binary" transfer only applies for FTP-Transfers, so if you use your browser to download the file you don't have to take care of that...
    Just save it to the final destination right away ;-)
     
Loading...