1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Service httpd failed to gracefully restart

Discussion in 'Plesk for Linux - 8.x and Older' started by ricflomag, Jan 22, 2007.

  1. ricflomag

    ricflomag Guest

    0
     
    Trying to configure a subdomain to add some open_basedir paths to the default
    one. I found this post to be useful to me:
    http://www.gadberry.com/aaron/2006/02/09/plesk_vhost/

    So I wrote a vhost.conf:

    <Directory /var/www/vhosts/<mydomain>/subdomains/egroupware/httpsdocs>
    php_admin_value open_basedir
    "/var/www/vhosts/<mydomain>/subdomains/egroupware/httpsdocs:/var/www/vhosts/<mydomain>/subdomains/egroupware/files:/var/www/vhosts/<mydomain>/subdomains/egroupware/backup:/tmp"
    </Directory>

    and saved it in
    /var/www/vhosts/<mydomain>/subdomains/egroupware/conf/

    But when I ran:
    /usr/local/psa/admin/sbin/websrvmng -v -a

    the answer was:
    websrvmng: Service /etc/init.d/httpd failed to gracefully restart
    websrvmng: Service /etc/init.d/httpd failed to gracefully restart
    (yes, twice)

    So I tried to restart apache from Plesk, and it eventually stopped, but did not
    restart (i didn't copy the error message). So i removed my vhost.conf file,
    tried again to restart apache from plesk, without success.

    So i followed this advice:
    http://forum.swsoft.com/showthread.php?threadid=23865

    and rebooted the server. Hopefully it worked (It's a production server, I would
    try not to interrupt the service). But i still can't get my vhost.conf to work,
    i still get the "failed to gracefully restart" error.

    The server runs Fedora Core 4, with Plesk 8.1.

    Thanks to anyone who could help !

    -----
    processes:
    # ps aux | grep http
    root 2228 0.0 1.0 36016 5572 ? Ss 13:04 0:00 /usr/local/psa/admin/bin/httpsd
    psaadm 2232 0.0 4.1 42228 21436 ? S 13:04 0:08 /usr/local/psa/admin/bin/httpsd
    psaadm 2249 0.0 5.1 42476 26384 ? S 13:05 0:08 /usr/local/psa/admin/bin/httpsd
    root 2939 0.0 3.1 32716 16224 ? Ss 13:09 0:00 /usr/sbin/httpd -k graceful
    root 2940 0.0 1.6 20964 8656 ? S 13:09 0:00 /usr/sbin/httpd -k graceful
    apache 2941 0.1 5.4 43540 28000 ? S 13:09 0:11 /usr/sbin/httpd -k graceful
    apache 2942 0.0 5.3 43296 27628 ? S 13:09 0:09 /usr/sbin/httpd -k graceful
    apache 2943 0.1 5.3 42972 27520 ? S 13:09 0:11 /usr/sbin/httpd -k graceful
    apache 2944 0.0 5.3 42656 27228 ? S 13:09 0:06 /usr/sbin/httpd -k graceful
    apache 2945 0.0 5.4 43632 28004 ? S 13:09 0:07 /usr/sbin/httpd -k graceful
    apache 2946 0.0 5.5 43956 28544 ? S 13:09 0:07 /usr/sbin/httpd -k graceful
    apache 2947 0.1 5.5 43788 28376 ? S 13:09 0:12 /usr/sbin/httpd -k graceful
    apache 2948 0.0 4.9 41036 25464 ? S 13:09 0:08 /usr/sbin/httpd -k graceful
    apache 2988 0.0 5.3 43000 27468 ? S 13:09 0:07 /usr/sbin/httpd -k graceful
    apache 3293 0.0 5.3 43100 27544 ? S 13:18 0:09 /usr/sbin/httpd -k graceful
    apache 4047 0.0 5.3 43040 27364 ? S 13:38 0:07 /usr/sbin/httpd -k graceful
    apache 4049 0.0 5.3 43184 27516 ? S 13:38 0:06 /usr/sbin/httpd -k graceful
    apache 4050 0.0 4.8 40692 25020 ? S 13:38 0:04 /usr/sbin/httpd -k graceful
    root 8765 0.0 0.1 3784 760 pts/0 S+ 16:11 0:00 grep http
    -----------------------------
    log files attached, generated after reboot and last attempt to gracefully
    restart apache:
    -----------------------------
    #cat /usr/local/psa/admin/logs/httpsd_error_log

    [Mon Jan 22 13:03:44 2007] [notice] caught SIGTERM, shutting down
    Processing config directory: /usr/local/psa/admin/conf/httpsd.*.include
    [Mon Jan 22 13:04:55 2007] [notice] Apache/1.3.33 (Unix) mod_ssl/2.8.22 OpenSSL/0.9.7f PHP/5.0.5 configured -- resuming normal operations
    [Mon Jan 22 13:04:55 2007] [notice] Accept mutex: sysvsem (Default: sysvsem)
    Checking for installed system packages...done.
    Download file products.inf3: Error while parse products info: Curl download failed: Couldn't resolve host 'autoinstall.plesk.com' Can't download http://autoinstall.plesk.com/products.inf3
    Fallback to old products info config
    Download file versions.inf3: websrvmng: Service /etc/init.d/httpd failed to start
    ERROR: Curl download failed: Couldn't resolve host 'autoinstall.plesk.com' Can't download http://autoinstall.plesk.com/versions.inf3
    websrvmng: Service /etc/init.d/httpd failed to start
    Checking for installed system packages...done.
    Download file products.inf3: [Mon Jan 22 13:28:18 2007] [error] mod_ssl: SSL handshake interrupted by system [Hint: Stop button pressed in browser?!] (System error follows)
    [Mon Jan 22 13:28:18 2007] [error] System: Connection reset by peer (errno: 104)
    [Mon Jan 22 13:28:18 2007] [error] mod_ssl: SSL handshake interrupted by system [Hint: Stop button pressed in browser?!] (System error follows)
    [Mon Jan 22 13:28:18 2007] [error] System: Connection reset by peer (errno: 104)
    [Mon Jan 22 13:28:18 2007] [error] mod_ssl: SSL handshake interrupted by system [Hint: Stop button pressed in browser?!] (System error follows)
    [Mon Jan 22 13:28:18 2007] [error] System: Connection reset by peer (errno: 104)
    [Mon Jan 22 13:28:18 2007] [error] mod_ssl: SSL handshake interrupted by system [Hint: Stop button pressed in browser?!] (System error follows)
    [Mon Jan 22 13:28:18 2007] [error] System: Connection reset by peer (errno: 104)
    [Mon Jan 22 13:28:27 2007] [error] mod_ssl: SSL handshake interrupted by system [Hint: Stop button pressed in browser?!] (System error follows)
    [Mon Jan 22 13:28:27 2007] [error] System: Connection reset by peer (errno: 104)
    Error while parse products info: Curl download failed: Couldn't resolve host 'autoinstall.plesk.com' Can't download http://autoinstall.plesk.com/products.inf3
    Fallback to old products info config
    Download file versions.inf3: ERROR: Curl download failed: Couldn't resolve host 'autoinstall.plesk.com' Can't download http://autoinstall.plesk.com/versions.inf3
    [Mon Jan 22 13:30:02 2007] [error] mod_ssl: SSL handshake interrupted by system [Hint: Stop button pressed in browser?!] (System error follows)
    [Mon Jan 22 13:30:02 2007] [error] System: Connection reset by peer (errno: 104)

    ----------------------------------
    # cat /var/log/httpd/error_log

    [Mon Jan 22 13:00:59 2007] [notice] caught SIGTERM, shutting down
    [Mon Jan 22 13:09:20 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    No worker file and no worker options in httpd.conf \nuse JkWorkerFile to set workers\n
    [Mon Jan 22 13:09:21 2007] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
    [Mon Jan 22 13:09:21 2007] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
    [Mon Jan 22 13:09:21 2007] [notice] Digest: generating secret for digest authentication ...
    [Mon Jan 22 13:09:21 2007] [notice] Digest: done
    [Mon Jan 22 13:09:21 2007] [notice] LDAP: Built with OpenLDAP LDAP SDK
    [Mon Jan 22 13:09:21 2007] [notice] LDAP: SSL support unavailable
    No worker file and no worker options in httpd.conf \nuse JkWorkerFile to set workers\n
    [Mon Jan 22 13:09:22 2007] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
    [Mon Jan 22 13:09:22 2007] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
    [Mon Jan 22 13:09:22 2007] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
    [Mon Jan 22 13:09:22 2007] [notice] Apache/2.0.54 (Fedora) configured -- resuming normal operations
     
  2. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    First of all review this article http://faq.swsoft.com/article_41_432_en.html
    and try to change your rule according to it.
    Also, I can see that in the rule you are using httpsdocs directory, so this it should be placed not into vhost.conf file but into vhost_ssl.conf.
    Hope this information will be helpful.
     
  3. ricflomag

    ricflomag Guest

    0
     
    Thank you for your reply. I finally managed to fix the problem. my "php_admin_value open_basedir" line in vhost.conf was pretty long, and the editor i use (nano), wrapped the line. But it eventually inserted a line-break! This made the file erroneous to apache, it could not parse it and threw the "failed to gracefully restart" error.

    I can confirm also that to configure an https *subdomain*, the right file is indeed <domainname>/subdomains/<subdomainname>/conf/vhost.conf and not vhost_ssl.conf, which is ignored.

    Regards.
     
Loading...