1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Site preview uses internal server address

Discussion in 'Plesk for Windows - 8.x and Older' started by EuroMaverick, Jun 3, 2006.

  1. EuroMaverick

    EuroMaverick Guest

    0
     
    Hello people,

    When I do a site preview (using the preview button in the Plesk panel), I get a screen that opens up to show the preview and that has the following address: http://192.168.135.8/$sitepreview/<name of the site>/.

    This does not work, since the 192.168.135.8 is the internal address of the server. When I manually replace that address with the external fix IP of the server, the preview works fine.

    So, how do I change this so that not the internal, but rather the external IP-address is used as a default in these preview screen ?

    Many thanks in advance !

    Regards,

    Mav.
     
  2. Pavluha

    Pavluha Guest

    0
     
    Sometime Plesk preview does not work behind NAT.
     
  3. EuroMaverick

    EuroMaverick Guest

    0
     
    Okay, let me be more specific: the server I am working on, is located in a datacentrum, far away from where I am. I am not in the same network as the Plesk server and I contact Plesk via the fix IP-address of the server.

    The only thing Plesk does wrong, is using the internal IP-adres of the server to generate the URL to the site preview. Apart from that, everything works fine and as far as I can see, NAT should have no influence here.

    I am pretty sure I should be able to change that somewhere, but I don't see where...

    Regards,

    Mav.
     
Loading...