1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

SiteBuilder 3.0 and SQLite Error when publishing

Discussion in 'Legacy Sitebuilder Software' started by mcminc, Sep 27, 2006.

  1. mcminc

    mcminc Guest

    0
     
    I recently upgrade my Plesk 8 server running fedora core 2 to Sitebuilder 3.0.0.

    When my users try to publish I see the following error in the logs and the site is not pubished.

    SQLite version 2.x is not installed at the target server

    I have verified that php51-SQLite is install on the server.

    Does anyone have any ideas?
     
  2. noimad1

    noimad1 Guest

    0
     
    I'm having the same problem....Let me know if you find a solution.
     
  3. noimad1

    noimad1 Guest

    0
     
    Digging into it I noticed that I do have sqlite installed, but it is not compiled into apache. That may be the problem. You might want to do a php info on your server and see if it truley is compiled with php.

    I'm afraid to touch my php5 though because it was a complete nightmare to get installed...
     
  4. zero@

    zero@ Guest

    0
     
    Problem solved for me

    Thanks mcminc. That solved the problem for me! On a Debian system I opened up /etc/php4/apache2/php.ini, and added this line:

    extension=sqlite.so

    Restarted apache using apache2ctl graceful and everything cleared up!
     
  5. noimad1

    noimad1 Guest

    0
     
    Man, I wish that would have worked for me....no luck with that though...
     
  6. zero@

    zero@ Guest

    0
     
    Do you have sqlite compiled in php?
     
  7. noimad1

    noimad1 Guest

    0
     
    Ah, that would be the problem. I had to pay someone to compile php5 for me because I could not get it figured out on this version of Rhel4...

    He did not compile sqlite though. And I'm very gun-shy to try to re-compile php because I had so many problems with it.....I guess I wouldn't even know where to start...

    I've been trying to get ahold of the guy for like 3 days now, but we keep missing each other....
     
Loading...