1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Sitebuilder said on Prewiev: Cannot prepare placeholders

Discussion in 'Sitebuilder 4.0 for Linux' started by McBeeR, Nov 15, 2007.

  1. McBeeR

    McBeeR Guest

    0
     
    On some sites, when I click on Prewiev button, Sitebuilder said:
    ---
    Internal SiteBuilder error.
    File: /usr/local/sitebuilder/include/SB/Site/Compiler/Modules.php; Line: 775
    Message: Cannot prepare placeholders.; Code: 0

    (on http://bob.robi.to/Preview?siteId=ef7cb0bff8f9da1e04cc8da347b1653e)
    ---

    And I have not preview ;(
    This do when I clik on "Insert Image" icon (in edit sites) and I create new folder: "Images" name. Folder created but after not preview.

    In other time I copy feedback from any Sitebuilder site and I insert this to new site. After not preview, too. Next I delete this feedback but preview not return.

    Can I repair this?
    Have I preview yet?
    Help me, please
    thx
     
  2. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    I have sent you patch files. Check your e-mail and let me know if it helped or not.
     
  3. McBeeR

    McBeeR Guest

    0
     
    Wow! Thanks! Patches repair my sites :)
    Now it's look fine.
     
  4. McBeeR

    McBeeR Guest

    0
     
    Hello Dmitry,
    This problem return :(
    What We do it now ?
    We have still Sitebuilder 4.0 version. You know We can't upgrade it to 4.1 yet.
     
  5. lfreitas

    lfreitas Guest

    0
     
    Same problem

    Hello my name is Leandro, I'm from Brazil.

    The same problem happens to my site, you could help me solve this problem Dimitry?

    Thanks.
     
  6. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    If you have version 4.0 I can suggest you to accomplish upgrade to latest 4.2 version. If upgrade is not possible in this case you can try to apply patch from the attachment which was prepared for 4.0 version. All fixes from the patch are included into next 4.1 and 4.2 version. Patch should be applied in this way:

    # tar -xzvf sitebuilder_patch_4.0.0_3.tgz -C <sb_root>/

    <sb_root> - Sitebuilder installation directory /usr/local/sitebuilder or /opt/sitebuilder depending on OS installation.
     

    Attached Files:

  7. lfreitas

    lfreitas Guest

    0
     
    Problem resolved

    The problem was resolved deleting all the contents of the directory /tmp and doesn't happens anymore.
     
  8. david_3rdday

    david_3rdday Guest

    0
     
    I have the same issue

    I have the same issue that you guys talk about here just that I get it when I publish a site. It gets to about 90% and then I get the following error.

    Internal SiteBuilder error.
    File: /usr/local/sitebuilder/include/SB/Site/Compiler/Modules.php; Line: 827
    Message: Cannot prepare placeholders.; Code: 0

    I am not sure how to fix it. Any ideas? I am running sitebuilder 4.2 on Fedora Core 7.
     
  9. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    Do you have any pages which are hidden from navigation?
     
Loading...