1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Sitebuilder slow

Discussion in 'Sitebuilder 4.0 for Linux' started by Jllynch, Aug 14, 2007.

  1. Jllynch

    Jllynch Regular Pleskian

    28
     
    Joined:
    Nov 11, 2003
    Messages:
    242
    Likes Received:
    0
    Our clients are having concerns with how slow the site builder has been to load pages. After having complaints from clients with the speed I went in to use our Sitebuilder to make changes to one website and it was literally taking 15min+ to load pages. I restarted my computer, refreshed pages and it even got to the point it froze. This is an ongoing problem and really does need to be addressed as it seems to be getting worse.


    This really is frustrating as little changes can take up to an hour to make, and that’s only if the page loads.

    And this is on a very lightly loaded server that has an average load of less than .5

    Could this be a java issue? Do clients need to update their java? Is it a browser issue? Are some browsers quicker than others?
     
  2. Jllynch

    Jllynch Regular Pleskian

    28
     
    Joined:
    Nov 11, 2003
    Messages:
    242
    Likes Received:
    0
    Sitebuilder very slow?

    We have clients complaining that sitebuilder is sometimes very slow. Are other people experiencing this? Is sitebuilder 4 better at this? Is it a browser issue?
     
  3. SibProgrammer

    SibProgrammer Regular Pleskian Staff Member

    29
     
    Joined:
    Nov 21, 2004
    Messages:
    342
    Likes Received:
    15
    You need to look at the server's load average at this time. What are the processes on the 'top'? What are they doing?

    I can only say that WYSIWYG is loading faster under IE, rather than under Firefox.
     
  4. Jllynch

    Jllynch Regular Pleskian

    28
     
    Joined:
    Nov 11, 2003
    Messages:
    242
    Likes Received:
    0
    We are very sure it is not the server load. The server is a new one with few sites on it. It is as if some times the client either gets into sitebuilder3 immediately or it times out.
     
  5. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    Let customer check Internet connection to the Sitebuilder server. Probably that is the case. Do you experience similar situation on your server when you connecting to Sitebuilder?
     
  6. Jllynch

    Jllynch Regular Pleskian

    28
     
    Joined:
    Nov 11, 2003
    Messages:
    242
    Likes Received:
    0
    I haven't had any issue with speed when connecting to the server. I doubt that it is network speed as the client says sometimes they wait 15 minutes and still don't get the next page. Sometimes it takes a few seconds. They are on broadband and not dial up.
     
  7. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    Justin, I have checked this forum, old customers request for similar issues with slowness in Sitebuilder v.3, v.4 but could not find anything. Also I do not remember if Sitebuilder customers experienced such issue in the past. Some slowness can be caused by huge number of sites on the server. How many sites do you have? But in this case I guess this issue should be usual but not periodical.
    I can also suggest to check if there are any scheduled tasks on the server which could cause server load from time to time. I appreciate if you could get some additional information from the customers concerning this situation.
     
  8. Jllynch

    Jllynch Regular Pleskian

    28
     
    Joined:
    Nov 11, 2003
    Messages:
    242
    Likes Received:
    0
    There are only about 30 sites on the server and no load issues. It is a very low load server. We have reports today of the application now crashing after users make changes to their site, so all their changes are lost.
     
  9. SibProgrammer

    SibProgrammer Regular Pleskian Staff Member

    29
     
    Joined:
    Nov 21, 2004
    Messages:
    342
    Likes Received:
    15
    Try to check all your sites. Are only some of them working slow? Maybe the problem only with exact site or sites. What is the slow step of Wizard? Is it a edit step with WYSIWYG? Are other steps running normal (fast)?
     
  10. Jllynch

    Jllynch Regular Pleskian

    28
     
    Joined:
    Nov 11, 2003
    Messages:
    242
    Likes Received:
    0
    I have reports now from resellers that SB3 is crashing their machines, as well as taking about 15 minutes to load the next page...

    It appears that IE is much worse than Firefox. IE gives errors that the script is taking too long to respond and do you want to kill it.
     
  11. Jllynch

    Jllynch Regular Pleskian

    28
     
    Joined:
    Nov 11, 2003
    Messages:
    242
    Likes Received:
    0
    Ok so we upgraded to version 4 and things are still very slow for a client.

    Is there some kind of maximum amount of content that Sitebuilder can handle on one page?

    We have a client with 75 products on one page this very very slow. Taking many minutes to save in Ie and Firefox.

    I recall the old version of SB would stop with an error if a maximum number of chatracters was reached.
     
Loading...