1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Slow and sometimes failing Qmail

Discussion in 'Plesk for Linux - 8.x and Older' started by erhnam, Sep 27, 2005.

  1. erhnam

    erhnam Basic Pleskian

    23
    57%
    Joined:
    Oct 26, 2003
    Messages:
    37
    Likes Received:
    0
    My Qmail is slow and sometimes doesn't work. When I try to send a mail using my smtp server this always takes around 10 second. Sometimes the server rejects the request.

    What have I tried:

    - Added -Rt0 option
    - Changed resolv.conf (only 127.0.0.1 and the dns from my ISP).
    - Checked the Firewall

    Anyone else with this problem? Or knows how to fix this?
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Do you have Plesk set for SMTP authentication?

    You did mean 127.0.0.1 (not 127.0.01)?

    Resolv.conf - you put the ISP's nameserver first, then the 127.0.0.1, right?

    See if changing the MAXPERIP in your other post changes the delay or not.

    What *nix distro and Plesk version are you running?

    Are you on a VPS/Virtuozzo server or standalone/dedicated?

    There are many other questions which could be asked... CPU, RAM, server load, # hosted domains, many many things.
     
  3. erhnam

    erhnam Basic Pleskian

    23
    57%
    Joined:
    Oct 26, 2003
    Messages:
    37
    Likes Received:
    0
    The plesk version I use is 7.5.2. The box contains RedHat9 and uses 1 GB mem and is installed with a Pentium 4 3 Ghz.

    In the resolve.conf I put the localhost entry at the end.

    I also changed back the MAXIP settings. But it seems it has nothing to do with this issue.
     
  4. erhnam

    erhnam Basic Pleskian

    23
    57%
    Joined:
    Oct 26, 2003
    Messages:
    37
    Likes Received:
    0
    I checked the /usr/local/psa/var/log/maillog and found this interesting:

    Sep 27 11:33:23 server07 qmail-queue: dwlib[11699]: scan: the message(drweb.tmp.UeldeH) sent by piethein@xxxxxx.xxx to damien@xxxxxx.xxx should be passed without checks, because contains uncheckable addresses.

    I checked plesk and noticed that the service drweb is not running. Anyone?
     
  5. jamesyeeoc

    jamesyeeoc Guest

    0
     
    After you made the -Rt0 change, did you restart the service for it to take effect?

    If you telnet to your server on port 25 and 110, do you still get a 10 second delay before seeing the 220 response?

    I have seen the DrWeb errors, can be from either not having DrWeb running, not licensed properly (the 'free' version only covers the first 15 mail users or something like that), or not installed/configured properly. (there may be more possible causes, I disabled it on my servers because it is too costly and just not quite right IMO)
     
  6. jamesyeeoc

    jamesyeeoc Guest

    0
     
  7. erhnam

    erhnam Basic Pleskian

    23
    57%
    Joined:
    Oct 26, 2003
    Messages:
    37
    Likes Received:
    0


    Yes, my /etc/xinetd.d/smtp_psa file looks now like this:

    service smtp
    {
    socket_type = stream
    protocol = tcp
    wait = no
    disable = no
    user = root
    instances = UNLIMITED
    server = /var/qmail/bin/tcp-env
    server_args = -Rt0 /var/qmail/bin/relaylock /var/qmail/bin/qmail-smtpd /var/qmail/bin/smtp_auth /var/qmail/bin/true /var/qmail/bin/cmd5checkpw /var/qmail/bin/true


    No, I do not get a 10 seconds delay when I try to reach it with telnet. Not from this machine. Not from other machines and also not from the webserver itself..

    I checked the MX record 1-1 thread but I do not see any problems here.. Anyone else?
     
  8. erhnam

    erhnam Basic Pleskian

    23
    57%
    Joined:
    Oct 26, 2003
    Messages:
    37
    Likes Received:
    0
    I found this:

    try increase que number of concurrente conections and disable reverse-lookups in DNS.

    /usr/local/psa/qmail or /usr/local/psa/qmail/conf
    and look for dot-qmail.files (.qmail files)

    adjust the qmail files to work like you want.....

    "G.10. DNS or IDENT lookups can make SMTP slow
    If qmail-smtpd is slow to respond to connections, the problem is probably due to DNS reverse lookups or IDENT lookups. If you're starting qmail-smtpd with tcpserver, remove the "-h", "-p", and "-r" options and add "-H", "-P", "-R", and "-l hostname".


    Any can tell me where to change this?
     
  9. jamesyeeoc

    jamesyeeoc Guest

    0
     
    The file you edited to add the -Rt0 option is where they are referring to (on a Plesk server). Not sure about using the -H, -P, and "-l hostname", never had to do that ever.
     
  10. erhnam

    erhnam Basic Pleskian

    23
    57%
    Joined:
    Oct 26, 2003
    Messages:
    37
    Likes Received:
    0
    This had something to do when you use tcpserver.. I'm not quite sure about this...
     
  11. jamesyeeoc

    jamesyeeoc Guest

    0
     
    If you're server is running a RH flavor, then smtp should be running as part of xinetd (which it is), and unless you have re-installed Qmail per the Qmail Rocks instructions or the generic Qmail instructions, then it will not be running under tcpserver. There are many ways to get Qmail running, the instructions you found do not totally apply to Plesk servers.
     
  12. erhnam

    erhnam Basic Pleskian

    23
    57%
    Joined:
    Oct 26, 2003
    Messages:
    37
    Likes Received:
    0
    Okee thanks for the info. What about:

    DNS or IDENT lookups can make SMTP slow

    Is there any way to disable this for qmail? And can you tell me what the impact would be when I disable this? I disabled it also for proftpd and the speed is very good now!
     
  13. jamesyeeoc

    jamesyeeoc Guest

    0
     
    First I would run a dnsreport.com on your domain and make sure there are no DNS issues which may be contributing. Since you had posted that telnet to the server has no delay, I'm wondering if there is a resolving issue with the domain.
     
  14. erhnam

    erhnam Basic Pleskian

    23
    57%
    Joined:
    Oct 26, 2003
    Messages:
    37
    Likes Received:
    0
    Okee I fixed the reverse DNS issue. There are no issues on dnsreport.com, only a few warnings. The smtp is still very slow.. Any clue?
     
  15. jamesyeeoc

    jamesyeeoc Guest

    0
     
    You never answered my question from way back, about resolv.conf and if you put the 127.0.0.1 AFTER the ISP nameserver IP. What other lines do you have in the file other than the 2 nameserver & IP lines?
     
  16. erhnam

    erhnam Basic Pleskian

    23
    57%
    Joined:
    Oct 26, 2003
    Messages:
    37
    Likes Received:
    0
    [root@ns1 root]# cat /etc/resolv.conf
    nameserver 206.13.30.12
    nameserver 206.13.29.12
    nameserver 127.0.0.1
    [root@ns1 root]#
     
  17. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Hi fellow SBC user...

    Ok that looks fine, you have the SBC-SD, then SBC-LA, then the localhost. So that is now ruled out as a source of the problem.

    Since you are not getting the delay from telnetting to port 25, it's only when the email client actually tries to send a message, right?

    Have you tried multiple email clients (OE, Outlook, Thunderbird, etc) and also from different ISP's?

    I was going to suggest a traceroute, but since there is no 'connection' delay, that probably wouldn't show anything.

    It is sounding more like an authentication delay.
     
  18. erhnam

    erhnam Basic Pleskian

    23
    57%
    Joined:
    Oct 26, 2003
    Messages:
    37
    Likes Received:
    0
    I tried almost everything. Multiple clients, Different ISP's but no good results. I only have this when I sent e-mails. IMAP, POP3, FTP is very fast! Maybe Qmail does some resolving or reverse dns lookups. Is there any way to check that and maybe disable this? I had the same problem for FTP but I disabled it by putting

    IdentLookups off
    UseReverseDNS off

    in the proftpd.conf. This fixed the problem. I wonder if something like this also exists for qmail?
     
  19. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Yes, I saw that in your earlier post. Other than the -Rt0 fix, I have never seen or heard of any other options related to DNS/Lookups/Ident with a Plesk version qmail installation.

    If you have modified the standard qmail install which Plesk does, like having done "Life with Qmail" or a standard Qmail install, then you would probably be running it with tcpserver which has those additional options you posted earlier.

    Are you running the Plesk version of Spamassassin, and what AntiVirus are you running on the server?
     
  20. erhnam

    erhnam Basic Pleskian

    23
    57%
    Joined:
    Oct 26, 2003
    Messages:
    37
    Likes Received:
    0
    I run a default plesk installation and didn't modify anything. I disabled Spamassasin and DrWeb to make sure this is not the issue.
     
Loading...