1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

smtp / horde / qmail problem

Discussion in 'Plesk for Linux - 8.x and Older' started by k.satirli, Sep 3, 2005.

  1. k.satirli

    k.satirli Guest

    0
     
    Since I dont know which one of the above is directly responsible, I just listed all.

    Here's the problem. I updated from .3 to .4 without any problems at all. It worked fine for a week now; I was happy with it until today, when suddenly mails wouldnt be received anymore.

    when I try to send a mail from horde I get:

    "There was an error sending your message: unable to send data"

    When I send a mail from remote to local, I get

    "PERM_FAILURE: SMTP Error (state 10): 553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)"

    how'd I go about solving the problem? I installed webmin today, but was pretty sure it wouldnt break anything, since it didnt break anything the first time...

    I also checked out the following threads:

    http://forum.plesk.com/showthread.php?s=&threadid=24186
    http://forum.plesk.com/showthread.php?s=&threadid=24186

    but couldnt find information that helped me solve my problem.
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Have you checked the contents of /var/qmail/control/rcpthosts to make sure the domain is still listed in the file?

    Try restarting qmail from the control panel or commandline (/etc/init.d/qmail restart)

    And do you use the Plesk backup utils? Check your backup log to see if it bombed out last night....
     
  3. k.satirli

    k.satirli Guest

    0
     
    I should have mentioned that I did try some restarts incl a full reboot (the privilege of your own server, where customers dont get irritated...)

    I checked the rcpthosts file, but it seems tat all my domains are listed in there.

    I happened to do a manual backup today on that domain but im unsure if the mail service stopped working for it before or after the backup.

    what I know is that apache didnt properly restart in order for the domain to be reactivated, so I did it manually.

    I just checked another mailbox on the server and it appears that this one isnt receiving mails either.

    other suggestions are certainly welcome :)
     
  4. k.satirli

    k.satirli Guest

    0
     
    would it help if I'd remove qmail and reinstall it?

    if so, how'd I go about this?
     
  5. reybie

    reybie Guest

    0
     
    The last time this happened to me, it was because of adding Rt0 in one of the files to speed up checking mail but in doing so I must have missed a white space where I inserted the text. Check it out it might be that simple.

    Edit: The file was /etc/xinetd.d/smtp_psa
     
  6. k.satirli

    k.satirli Guest

    0
     
    this is all I've got in said file:

    Code:
    service smtp
    {
    	socket_type     = stream
    	protocol        = tcp
    	wait            = no
    	disable		= no
    	user            = root
    	instances       = UNLIMITED
    	server          = /var/qmail/bin/tcp-env
    	server_args     = /var/qmail/bin/relaylock /var/qmail/bin/qmail-smtpd /var/qmail/bin/smtp_auth /var/qmail/bin/true /var/qmail/bin/cmd5checkpw /var/qmail/bin/true
    }
    
    
     
  7. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Not having the -Rt0 in the file would only cause the 30 second SMTP connection/sending delay, so you're fine on that for now.

    Always do full backups before modifying, updating, upgrading things.

    Before trying to uninstall/reinstall qmail, try doing the following from SSH:

    /usr/local/psa/admin/bin/mchk -v

    It may take a few seconds to complete. Then restart Qmail from the control panel.

    If that does not work, then we can try forcing a re-install of qmail. Note: I don't normally like recommending this measure unless all other options are exhausted, but since I don't have access to your server, it may be more expedient to try this.

    MAKE A FULL BACKUP OF YOUR SERVER BEFORE DOING ANY OF THE FOLLOWING

    If you want to try and re-install the qmail RPMs, first locate where they were downloaded to, usually in:

    /root/psa/PSA_7.5.4/rpm_OSVersion/base
    (I don't know what OS version you use)

    Change directory into that directory.

    Do you use DrWeb?? If not, then skip the last command below:

    Did I mention to do a full backup of the server before any of this??

    rpm -Uvh --force psa-qmail psa-qmail-rblsmtpd

    (skip this next one if you do NOT use DrWeb)
    rpm -Uvh --force drweb-qmail


    You should not need to put the --nodeps option since all the other dependency packages should already be installed.

    Check the output of the RPM command carefully to see if any warnings or errors of any kind appear. Post results here.
     
  8. k.satirli

    k.satirli Guest

    0
     
    roger that, backed up, downloaded and uploaded to another server.

    didnt help. I also restarted via shell but no difference.

    understood.

    good idea :)

    done. worked without problems (so far), but I didnt find the rblsmtpd

    skipped.

    seems to have worked fine. I sent an email and it appeared in the other inbox and I received one :D

    Thank you James, you truly are my saviour, protecting me from the email that is known as empty inbox.

    Thanks again
     
  9. jamesyeeoc

    jamesyeeoc Guest

    0
     
    You are welcome. There are worse things than an empty mailbox... I often wish mine were empty....
     
  10. k.satirli

    k.satirli Guest

    0
     
    heh :)

    thanks again.
     
  11. reybie

    reybie Guest

    0
     
    I should just search for posts by james before I ask a question LOL :)
    This is really informative.
     
  12. jamesyeeoc

    jamesyeeoc Guest

    0
     
    I must have been having a 'lucid' night when I posted that :D LOL Seriously, I do not know much of anything, and I'll deny knowing anything until I am buried.... (change my handle to Sgt. Schultz from Hogan's Heroes)
     
  13. koof

    koof Guest

    0
     
    Hi, i have the same problems. Mail stopped working.
    i can send, but i can't recieve.
    no errors are given when using a program like outlook or apple mail.
    in webmail it gives the error as described.

    so, i followed intructions posted here.
    i started the RPM twice, first time it seem to did not have enough memory or something ?

    ** my problems have not been solved, they got worse, i get more errors in webmail now**

    output:

    [root@ns1 base]# rpm -Uvh --force psa-qmail-1.03-rhel3.build75050824.12.i586.rpm
    Preparing... ########################################### [100%]
    Checking for the system groups and users necessary for Qmail...
    Checking for the group 'nofiles'...
    Group 'nofiles' already exists

    Checking for the user 'alias'...
    User 'alias' already exists

    Checking for the user 'qmaild'...
    User 'qmaild' already exists

    Checking for the user 'qmaill'...
    User 'qmaill' already exists

    Checking for the user 'qmailp'...
    User 'qmailp' already exists

    Checking for the group 'qmail'...
    Group 'qmail' already exists

    Checking for the user 'qmailq'...
    User 'qmailq' already exists

    Checking for the user 'qmailr'...
    User 'qmailr' already exists

    Checking for the user 'qmails'...
    User 'qmails' already exists

    Checking for the group 'popuser'...
    Group 'popuser' already exists

    Checking for the user 'popuser'...
    User 'popuser' already exists

    1:psa-qmail ########################################### [100%]
    error: unpacking of archive failed on file /var/qmail/bin/tcp-env;43347593: cpio: write failed - No space left on device
    [root@ns1 base]# rpm -Uvh --force psa-qmail-1.03-rhel3.build75050824.12.i586.rpm
    Preparing... ########################################### [100%]
    Checking for the system groups and users necessary for Qmail...
    Checking for the group 'nofiles'...
    Group 'nofiles' already exists

    Checking for the user 'alias'...
    User 'alias' already exists

    Checking for the user 'qmaild'...
    User 'qmaild' already exists

    Checking for the user 'qmaill'...
    User 'qmaill' already exists

    Checking for the user 'qmailp'...
    User 'qmailp' already exists

    Checking for the group 'qmail'...
    Group 'qmail' already exists

    Checking for the user 'qmailq'...
    User 'qmailq' already exists

    Checking for the user 'qmailr'...
    User 'qmailr' already exists

    Checking for the user 'qmails'...
    User 'qmails' already exists

    Checking for the group 'popuser'...
    Group 'popuser' already exists

    Checking for the user 'popuser'...
    User 'popuser' already exists

    1:psa-qmail ########################################### [100%]
    ===> Updating /etc/psa/psa.conf...
    Trying to set up default qmail permissions... done

    ===> Installing Qmail server
    Configuring Qmail...
    Trying to generate SSL certificates for TLS sessions... done
    Trying to register service qmail... using /sbin/chkconfig
    done
    Trying to start Qmail services... done
    Trying to register service qmail... using /sbin/chkconfig
    done
    Shutting down kernel logger: [ OK ]
    Shutting down system logger: [ OK ]
    Starting system logger: [ OK ]
    Starting kernel logger: [ OK ]
    [root@ns1 base]#
     
  14. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Looks like you have run out of drive space on at least one of your partitions... You need to resolve that issue before trying the rpm re-install again.
     
Loading...