1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

SpamAssassin 3.0.3 installation trouble with make. Permission denied?

Discussion in 'Plesk for Linux - 8.x and Older' started by Mateo1041, Jun 5, 2005.

  1. Mateo1041

    Mateo1041 Guest

    0
     
    Hi everyone,

    I recently downloaded the 3.0.3 installation for Perl users and receive the following error when using the "make" command:

    Code:
    ...
    ...
    ...
    cd spamc
    /usr/bin/perl version.h.pl
    version.h.pl: creating version.h
    ./configure --prefix=/usr --sysconfdir=/etc/mail/spamassassin --datadir=/usr/share/spamassassin --enable-ssl=no
    [b]Can't exec "./configure": Permission denied at spamc/configure.pl line 82.
    make: *** [spamc/Makefile] Error 127[/b]
    Line 82 is a Perl "exec" command. Has anyone experienced this before and what might I do to fix it? I am running as root. Plesk version is the latest 7.5.2. I did try stopping "xinetd". Is there something I need to do to stop qmail too? Any help would be much appreciated.

    Thanks,
    - Matt.
     
  2. hardweb

    hardweb Guest

    0
     
    1. You should update Spamassassin from RPM.
    2. If you use Plesk spamssassin extension it is not compatible with Spamassassin 3.x, so you should not upgrade.
     
  3. Mateo1041

    Mateo1041 Guest

    0
     
    It would be a new install and I would not be running a Plesk version.

    I'll try installing via RPM when I get home this evening. Will update with the results. Strange how installing via Perl doesn't work.

    Thanks,
    - Matt.
     
  4. Mateo1041

    Mateo1041 Guest

    0
     
    I've tried running the RPM install and everything seemed to install fine without problems. However, when I go looking for SpamAssassin, I can't find it!

    I can't find any of the configuration files and the "/etc/mail/spamassassin" directory doesn't even exist. If I type "spamassassin --lint -D", I get the following:

    Code:
    [root@server /]# spamassassin --lint -D
    -bash: spamassassin: command not found
    
    Everything looked fine during the install. Is there a reason it wouldn't even show up now? I did try restarting my VPS and the xinetd service.
     
  5. sieb@

    sieb@ Guest

    0
     
    Can you do:

    # service spamassassin status
     
  6. Mateo1041

    Mateo1041 Guest

    0
     
    I unfortunately get the following:

    Code:
    [root@server /]# service spamassassin status
    spamassassin: unrecognized service
    
    Would it be worth trying the install again and posting the install log here? I hadn't seen any problems while installing the first time.
     
  7. Mateo1041

    Mateo1041 Guest

    0
     
    Just tried another install by typing the following after uploading the tar.gz file via FTP in binary mode:

    Code:
    rpmbuild -tb Mail-SpamAssassin-3.0.4.tar.gz
    I've attached the install log as a txt file due to space limitations in this post.
     
  8. Mateo1041

    Mateo1041 Guest

    0
     
  9. hardweb

    hardweb Guest

    0
     
    Ok, but you did not installed the RPMS after you built them.
     
  10. Mateo1041

    Mateo1041 Guest

    0
     
    Oh, I had thought that was done automatically during the rpmbuild process. I'll try installing the following RPM's when I get home:

    /usr/src/redhat/RPMS/i386/spamassassin-3.0.4-1.i386.rpm

    /usr/src/redhat/RPMS/i386/spamassassin-tools-3.0.4-1.i386.rpm

    /usr/src/redhat/RPMS/i386/perl-Mail-SpamAssassin-3.0.4-1.i386.rpm

    I'm assuming I want to run a command similar to the following for each of the RPM's above?

    Code:
    rpm --install -ivh <filename>
    Thanks for your help.
     
  11. Mateo1041

    Mateo1041 Guest

    0
     
    I've now installed the RPM's and everything went fine. The following page seemed to have some good pointers:

    http://www.whoopis.com/howtos/spamassassin-install.html

    I did try the following command:

    Code:
    spamassassin --lint -D 2>&1 | grep -i dns
    But get the following instead:

    Code:
    debug: is Net::DNS::Resolver available? yes
    debug: Net::DNS version: 0.50
    debug: All NS queries failed => DNS unavailable (set dns_available to override)
    debug: is DNS available? 0
    Not sure if this breaks anything. But now that SpamAssassin is running (I've made sure by doing a service spamassassin start), I find it isn't tagging any email or even modifying the headers.

    I have modified the /etc/mail/spamassassin/local.cf file to say the following:

    Code:
    rewrite_header Subject ***SPAM***
    report_safe 1
    report_header 1
    use_bays 1
    auto_learn 1
    required_hits 8
    rewrite_subject 1
    use_terse_report 1
    defang_mime 0
    ok_locales en
    Do I somehow have to modifty a qmail setting so that it sends email through SpamAssassin? I've looked and looked and looked and am ready to pull my hair out.

    Thanks for your help so far.
     
  12. sieb@

    sieb@ Guest

    0
     
    Check the email headers of known spam. Are there any X entries from SA? There should be a Score in there. PSA defaults to a score of 7, though I set both my server and user settings to a score of 4. SA won't tag anything less than the set score.

    If you don't see any entries, then the Qmail isn't passing email through SA.
     
  13. Mateo1041

    Mateo1041 Guest

    0
     
    So SpamAssassin won't add X headers for things that don't score high enough? I sent myself test emails, but did not see any X headers at all.

    How would I make qmail pass email through SpamAssassin? I think that might be my problem right now. Which configuration file would I modify for it to do that?

    Thanks.
     
  14. Mateo1041

    Mateo1041 Guest

    0
     
    Does anyone know how to make qmail pass email through SpamAssassin for filtering? SpamAssassin appears to be installed, but is not filtering email.

    Thanks so much for all your help so far.
     
  15. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    You need to install qmail-scanner (yum install qmail-scanner if you use my archive), or have it called from a .qmail file.
     
Loading...