1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

SpamAssassin doesn't work on Plesk 7.5.3. Help?

Discussion in 'Plesk for Linux - 8.x and Older' started by Mateo1041, Sep 22, 2005.

  1. Mateo1041

    Mateo1041 Guest

    0
     
    Hi everyone,

    I have SpamAssassin installed on my VPS via the Plesk Updater tool. I'm hosted on a Fedora Core 2 system. It is set to be global and the threshold is 1 (for testing as it should flag a lot of valid emails). It is also running as a service ("spamd" I believe).

    Yet it won't flag any emails in either the subject line or header. I don't even see any scores when emails come in.

    Does anyone have any ideas of what might be wrong? Anything special I should check? Everything looks fine to me. Is this a known bug?

    Thanks much,
    - Matt.
     
  2. Mateo1041

    Mateo1041 Guest

    0
     
    Anyone have any ideas on this?
     
  3. cmaxwell

    cmaxwell Regular Pleskian

    25
    73%
    Joined:
    Aug 1, 2001
    Messages:
    150
    Likes Received:
    1
    Have you tried restarting SpamAssassin from the control panel? Sometimes after an upgrade SpamAssassin doesn't work properly and you need to restart it.

    - Chris
     
  4. Whistler

    Whistler Guest

    0
     
    Check that the SpamAssassin service is running - but also check the .qmail files as almost every upgrade in the 7.x.x series of Plesk seems to cause problems with the SA settings.

    Often the .qmail files are not written correct at the upgrade causing the controlpanel to say that SA is enabled on a mail account, but it's actually never written in the configuration file.

    One way to check it - is to uncheck/check the "Use server wide settings" and save in the Spam filter configuration of a mailbox. Recheck the option again - causing Plesk to write the correct .qmail configuration.
     
  5. slydahunter

    slydahunter Guest

    0
     
    Yes,

    so i uncheck and check spamassassin on my user and then the .qmail file got written corrrectly,....

    the problem is that i'm not going to do that on my 1200 mailboxes of my customers...

    and if i globally unactive and reactive the spamassassin fuction it doesn't change like it does when i'm doing it individually,...

    anyone can help me?

    i really do have problems with all anti-spams functions on plesk... qmail anti-spam and spam assassin are not working correctly and i could'nt find any post that solve my problems on this forum...

    Is there anyone who can save my life...

    Thanks a lot

    Sylvain
     
  6. jamesyeeoc

    jamesyeeoc Guest

    0
     
    You have 1200 mailboxes, but you did not mention how many domains.

    You can do "Group Operations" on a per domain basis, In each domains' MAIL area, you can select ALL mail users and then click on Group Operations and set the SA option and it will change all of that domain's users at once.

    You would only have to do this for each domain. Better than doing it 1200 separately!

    Otherwise, you would end up writing a script.
     
  7. slydahunter

    slydahunter Guest

    0
     
    HI,

    thank you for your answer, but that's why i already tried.

    To select all mailboxes and to desactivate spamassassin and then reactivate it...

    but it doesn't work....

    but i am the only one to have with spamassassin and also with zone maps with qmail block spam stuff?

    'cause i got mad for days with that problems...

    i'm running plesk on debian, is there a special problem with this distribution?
     
  8. twrs

    twrs Guest

    0
     
    I had this same problem recently with one domain. SA enabled there but never working.

    I fixed it by disabling the "Use server wide settings" in the mailbox Spam Filter configuration.
     
  9. cmaxwell

    cmaxwell Regular Pleskian

    25
    73%
    Joined:
    Aug 1, 2001
    Messages:
    150
    Likes Received:
    1
    Did you try reactivating the "Use server-wide settings" option?

    Sometimes if SpamAssassin doesn't work, if you disable then re-enable this setting, it makes things work again.

    I haven't seen this happening recently but it did happen in the earlier 7.5.x releases if I remember correctly.

    As the topic of this thread mentions 7.5.3, you may want to upgrade to 7.5.4 if you have not already done so.

    Best Regards,

    - Chris
     
  10. ShadowMan@

    ShadowMan@ Guest

    0
     
    See this other thread (recent) about MAPS RBLs and Debian

    http://forum.sw-soft.com/showthread.php?s=&postid=124153#post124153
    "working solution for rbl on debian" by _tek on 28 Oct 2005
     
  11. bluestarsystem

    bluestarsystem Guest

    0
     
    Hi,
    I have Plesk 7.5.4 on Fedora Core 2 and I installed RulesDuJour to update SpamAssassin rules. Everytime I check my mail after a RulesDuJour update it seems spamassassin not working, but the spamd daemon is running. So I have to uncheck and check the "Use server wide settings" server config of Spamassassin and it start to work again. How can we repair this ? What's wrong ?

    Bye

    Juri
     
Loading...