1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Spamassassin not flagging email

Discussion in 'Plesk for Linux - 8.x and Older' started by jas8522, Jan 9, 2006.

  1. jas8522

    jas8522 Basic Pleskian

    24
    23%
    Joined:
    Feb 3, 2005
    Messages:
    80
    Likes Received:
    0
    Location:
    Halifax, Nova Scotia Canada
    Hello,

    I know there's plenty of these, but none seem to have a solution that will work.

    I've reinstalled spamassassin (from Plesk Updater alone, as well as from ART). Qmail has been reinstalled, and Dr Web has been removed.

    I did exactly as a few different threads had directed to solve this kind of SA problem, and it did not fix it. Currently I have Dr Web removed and SA 3.1 installed with the "yum install qmail-scanner" command and ran the /usr/bin/qmail-scanner-reconfigure command with no issues.

    I've run usr/local/psa/admin/sbin/mchk --with-spam to verify the settings are good for each mailbox, as well as "spamassassin -d --lint" to verify that my config is accurate. I've changed all the settings in the CP at least once to verify that it's writing to the config file (even though it's obviously correct due to the -d --lint command).

    My headers show nothing at all (like they used to) about scoring the message. I've sent the Gtube, and it gets through no problem - not stopped by SA at all.

    I've run "service stop spamassassin" and "service stop psa-spamassassin" then loaded it from the CP, as well as stopped them again and run "service start psa-spamassassin" alone.

    Nothing is allowing spam assassin to read through the queue and flag messages!

    My config file is as follows:

    required_score 5
    rewrite_header subject *****SPAM*****
    report_safe 1
    use_bayes 1
    skip_rbl_checks 1
    use_pyzor 1
    score CUM_SHOT 10
    score LIVE_PORN 10
    score HARDCORE_PORN 10
    score HOT_NASTY 10
    score BEST_PORN 10
    score NASTY_GIRLS 10
    score AMATEUR_PORN 10
    score PORN_15 10
    score PORN_16 10
    score LOTS_OF_STUFF 10
    score DISGUISE_PORN 10
    score GET_PAID 10
    score GUARANTEED_STUFF 10
    score WHY_WAIT 10
    score NO_MEDICAL 10
    score BAD_CREDIT 10
    score BILLION_DOLLARS 10
    score GUARANTEED_100_PERCENT 10
    score HTTP_EXCESSIVE_ESCAPES 3
    score MIME_HTML_ONLY 3
    score RCVD_IN_BL_SPAMCOP_NET 5
    score HTML_TAG_BALANCE_BODY 3


    I've also tried it with only

    required_score 5
    rewrite_header subject *****SPAM*****

    options to no avail.

    Any ideas?

    Jordan


    EDIT: I'm an idiot, apparently the upgrade disables spamassassin on all mailboxes. To fix it, just re-enable spamassassin on the mailboxes you wish to have spam protection on, and away you go...
     
Loading...