1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

SpamAssassin not working after upgrade

Discussion in 'Plesk for Windows - 8.x and Older' started by varian, Dec 19, 2004.

  1. varian

    varian Guest

    0
     
    I just did an upgrade from Plesk 7.0.1 to 7.0.3, and then restored the backup I made. Ever since I did that SA has not been running. I checked the MTA debug log in MailEnable and I found this everytime an email came into the system:

    12/19/04 01:05:40 Pickup Event CreateProcess failed Error:2 (C:\Program Files\SWsoft\Plesk\admin\bin\mailfilter.exe 8E910B4314D4F6BA656C2D08A026.MAI SMTP)
    12/19/04 01:05:40 [8E910B4314D4F6BA656C2D08A026.MAI] from [SMTP] Connector queued to [SF] Connector as [436C3B6D9359417B82C2467778658B.MAI]
    12/19/04 01:06:05 Sucessfully created new thread for message delivery.
    12/19/04 01:06:05 Pickup Event CreateProcess failed Error:2 (C:\Program Files\SWsoft\Plesk\admin\bin\mailfilter.exe D513DEBE292A4FE687B96E4E349BD.MAI SMTP)
    12/19/04 01:06:05 [D513DEBE292A4FE687B96E4E349BD.MAI] from [SMTP] Connector queued to [SF] Connector as [961429728D7C4CB5ABA2548032AFC9.MAI]
    12/19/04 01:06:46 Sucessfully created new thread for message delivery.
    12/19/04 01:06:46 Pickup Event CreateProcess failed Error:2 (C:\Program Files\SWsoft\Plesk\admin\bin\mailfilter.exe 71C0DEF1F2384293817BF94B7FCC3.MAI SMTP)
    12/19/04 01:06:46 [71C0DEF1F2384293817BF94B7FCC3.MAI] from [SMTP] Connector queued to [SF] Connector as [D5EEC2A6BD9B48608A93EDB03B2BF9.MAI]
    12/19/04 01:06:54 Sucessfully created new thread for message delivery.

    I searched the system for "mailfilter.exe" and it does not exsist anywhere.
     
  2. Leighm0

    Leighm0 Guest

    0
     
    I believe it's now:

    C:\Program Files\SWsoft\Plesk\admin\bin\memailfilter.exe

    Check your MailEnable MTA Filter settings and change if necessary.
     
  3. varian

    varian Guest

    0
     
    I did change it over to memailfilter.exe, but email is not running through SA. There are no headers added by SA in any of the email. The errors in the logs are gone. Is there a way to check if memailfilter.exe is calling SA?
     
  4. Leighm0

    Leighm0 Guest

    0
     
    hmm.. im not getting any SA logs either :(
     
  5. dominic2

    dominic2 Guest

    0
     
    same problem

    i have the same problem !!!


    event log :

    Detection of product '{2B8742CB-CEEB-4955-BE12-8FE5E89EE8AC}', feature 'PleskUtils', component '{A4540254-432E-416D-95F1-AD6023484719}' failed. The resource 'C:\Program Files\SWsoft\Plesk\admin\bin\mailfilter.exe' does not exist.

    and

    Detection of product '{2B8742CB-CEEB-4955-BE12-8FE5E89EE8AC}', feature 'PleskUtils' failed during request for component '{FC3E0B6E-F62B-11D1-B144-00C04F990B2B}'
     
  6. Leighm0

    Leighm0 Guest

    0
     
    Re: same problem

    read my above posts about changing it to memailfilter.exe
     
  7. dominic2

    dominic2 Guest

    0
     
    In MTA , i have already memailfilter.exe

    If i rename memailfilter.exe by mailfilter.exe i have no error message but SA don't work!!!!


    tank'S
     
  8. cviviani

    cviviani Guest

    0
     
    set mssql password "sa" in the plesk panel datebase again (press change password button)

    you can check the actual password for mssql with the mssql-query-analyzer

    that is actually the only error which we with the update found with 7.03 sp 2
    spammassassin ok, delete and create mailaccount ,domain,user is ok.
    we have those test with a server made where 18 domain and 76 mail acounts are.
    up to now we have also none call received from customers the errors announced.
     
  9. dominic2

    dominic2 Guest

    0
     
    i can't change the password in plesk control panel

    Microsoft SQL server (not supported by your license key)


    tank's
     
  10. Deltafox

    Deltafox Guest

    0
     
    does anybody know how to fix this allready?
     
  11. varian

    varian Guest

    0
     
    Guess not. Its a big problem for my users.
     
  12. zartrix

    zartrix Guest

    0
     
    Anybody have a fix for this???

    I have the same problem... i try to install Plesk Control Panel 7.5 but doesn´t work.

    When i reinstall the 7.0.3 version all works fine. But i have the same problem with spamassassin. The mailfilter.exe doesn´t exist.

    Anyone have a fix fot his problem?

    Thanks in advance.

    Zartrix
     
  13. Deltafox

    Deltafox Guest

    0
     
    i upgraded yesterday succesfully to plesk 7.5 and spamassassin works so maybe you should upgrade too.

    good luck
     
Loading...