1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

spamassassin not working plesk 8.2?

Discussion in 'Plesk for Windows - 8.x and Older' started by arisd, Aug 2, 2007.

  1. arisd

    arisd Basic Pleskian

    23
    90%
    Joined:
    Jan 31, 2007
    Messages:
    60
    Likes Received:
    0
    I just installed (upgraded) plesk v8.1 -> v8.2 and I noticed I am getting a lot of spam emails and noone is marker spam.

    Its strange since before upgrade only 3 spam mails got in a day on one e-mail not in 10 minutes i got 20 of them got thrue.

    Is there any way to check if spam filter works?

    Thanks for all the answers

    Aris, www.slohost.net
     
  2. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
  3. arisd

    arisd Basic Pleskian

    23
    90%
    Joined:
    Jan 31, 2007
    Messages:
    60
    Likes Received:
    0
    I tried it right now but no success... Spam is still getting thrue.

    But I found a solution - I wrote MTA pickup event for ESET NOD32 (http://www.nod32.com) antivirus and Spamassassin 3.2.1.0 for windows (http://sawin32.sourceforge.net/) than integrate program in MailEnable standard and works like a charm...

    It produces more CPU load on server but works better and marks more accurate mails as spam.

    It also checks other server lists: Razor, dcc,... that plesk spam does not (I think)

    Example of Content analysis details of one email:
    1.5 RAZOR2_CF_RANGE_E8_51_100 Razor2 gives engine 8 confidence level
    above 50%
    [cf: 100]
    2.5 RAZOR2_CHECK Listed in Razor2 (http://razor.sf.net/)
    1.5 RAZOR2_CF_RANGE_E4_51_100 Razor2 gives engine 4 confidence level
    above 50%
    [cf: 100]
    0.5 RAZOR2_CF_RANGE_51_100 Razor2 gives confidence level above 50%
    [cf: 100]
    3.6 DCC_CHECK Listed in DCC (http://rhyolite.com/anti-spam/dcc/)
    2.0 URIBL_BLACK Contains an URL listed in the URIBL blacklist
    [URIs: sportmedrx.com]
    2.9 URIBL_JP_SURBL Contains an URL listed in the JP SURBL blocklist
    [URIs: sportmedrx.com]
    2.1 URIBL_OB_SURBL Contains an URL listed in the OB SURBL blocklist
    [URIs: sportmedrx.com]
    2.5 URIBL_SBL Contains an URL listed in the SBL blocklist
    [URIs: sportmedrx.com]


    If anyone interested I can post program and info of installing on the net...

    Aris, http://www.slohost.net
     
  4. dellis203

    dellis203 Guest

    0
     
    Hi arisd,
    I would love to get a copy and instructions of that mta pickup.
    Thanks
    Dave
     
  5. pierregr

    pierregr Guest

    0
     
    Hi,

    I am also having this problem.
    We paid for the Spamassassin software to be included and working in Plesk and since version 8.2, it is no longer working.

    I tried requesting a patch but I got a non-useful answer.

    Anyone has a solution to get spamassassin working again?
    Using the patches recommended in this thread by swsoft did not help.
     
  6. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Hello,

    Why did you decide "it is no longer working"?
    Whom did you try requesting and "got a non-useful answer"?

    Could you please send me credentials for your problem server?
     
  7. pierregr

    pierregr Guest

    0
     
    Hi Sergius,

    It was on the phone with swsoft the day after I attempted the upgrade (or perhaps that night). I don't remember the person's name but I do remember being frustrated.

    Anyways, here's the situation:

    1) I tried initially to upgrade from 7.6.1 to 8.2 and it failed in the process. (Maybe because I had updated the MsSQL 2005 root password manually and that breaks future upgrades? Anyways, I eventually just gave up and decided to build a brand new server

    2) On a fresh new install of Windows server 2003 web + MsSQL server 2005 workgroup edition, I installed plesk 8.2. I called swsoft for a temporary license.

    Then I installed clamav and got it to to be enabled in plesk.

    Then i used the plesk backup and restore tool to create a backup of the 7.6.1 accounts and transfer all the accounts to this new server. Accounts appeared to copy successfully.

    Once that was completed, I tested the mail/spamassassin and anti virus.

    Mail was working, but nothing was being scanned.

    3) Then I looked at Start-->Programs-->MailEnable-->MailEnable Administrator
    I right click on "Servers-->localhost-->Agents-->MTA and I select properties.
    Then I noticed that "Enable pickup event" was selected, but there was nothing in the text box indicating the "program to execute on mail file". So I figured that might be a problem so I entered the following in the text box:

    C:\Program Files\SWsoft\Plesk\admin\bin\memailfilter.exe
    This file does exist.

    Then I also selected "Process pickup after filters instead of before".

    I then restarted the services.

    4) Since I did the above, anti virus is working (I get notifications when an email is caught and deleted), but spamassassin is not working.

    Blacklist filters are working (I have tested it), but spamassassin rules don't appear to be doing anything. I have not modified any of the spamassassin files so I don't see why it wouldn't be working.
    There is a green (enabled) next to spamassassin in the plesk control panel indicating that it is working.

    5) I also tried appying the patches listed above, restarted the services, but that did not fix it.

    Hopefully this will provide the level of details you need to tell me how to fix the issue.
    I would prefer if you could tell me how to fix it (if you can) instead of me providing you access to our production machine hosting customers.

    Thank you,

    Pierre
     
  8. webavant

    webavant Guest

    0
     
    Wow, no reply? I'm wondering if I should purchase Plesk after all...
     
  9. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Please check options for Spam Filtering and Antivirus on page Plesk > Server > Mail

    http://kb.swsoft.com/en/2072
     
  10. shultis

    shultis Guest

    0
     
    Check User Prefs

    Not sure if this will help or not, but we spent a couple of weeks thinking SA was broken. It loaded correctly, and the processes were running, but there was not filtering after the upgrade to 8.2

    We finally found that somewhere in the upgrade process, spam filtering had been disabled for all users. So while it was running, none of the mail accounts were actually enabled to use it.

    There's a way to enable spam filtering for all users on a plesk server, (and some other great posts) here:

    Add Spam FIltering for All Users in Plesk


    -- shultis
     
  11. jpboyce

    jpboyce Guest

    0
     
    I've been having the same problem. However, I checked the table that shultis' link refers to and there is no field called spamfilter on that table for me (Fresh 8.2 install using MS SQL Server).
     
  12. jpboyce

    jpboyce Guest

    0
     
    Just a followup on this. I decided to check what was going on with the rules files. I found that there were two folders with rule files - C:\Program Files\SWsoft\Plesk\Additional\SpamAssassin\rules and C:\Program Files\SWsoft\Plesk\Additional\Perl\site\share\spamassassin One of the folders only seemed to have a few files in there. So I ran an update batch file I have and ensured that both folders had the same set of rule files. A lot more spam is being tagged correctly now by Spamassassin.
     
  13. arisd

    arisd Basic Pleskian

    23
    90%
    Joined:
    Jan 31, 2007
    Messages:
    60
    Likes Received:
    0
  14. funky123

    funky123 Guest

    0
     
    Sergius

    I do have same issue with one of plesk 8.2 box

    I did try http://kb.swsoft.com/en/2072
    where eventually , where php file errored out and spamfilter tab stopped working at plesk panel.

    whats the right way to find out
    if spamassasin is actively workinga nd ingetrated wth default install of Mailenable standard edition.
    please guide

    this is urgent.
     
  15. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0

    Please install update 8.2.0.1 or new 8.3.0.
     
  16. christophorus

    christophorus Guest

    0
     
    Hello,

    I am experiencing a similar issue with plesk 8.6

    SpamAssassin is enabled server wide and for all domains, stil no emails are scanned by SpamAssassin.

    Any advise please.

    Thanks,
    Chris
     
Loading...