1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

SpamAssassin not working

Discussion in 'Plesk for Windows - 8.x and Older' started by logan@jatol, Nov 30, 2005.

  1. logan@jatol

    logan@jatol Guest

    0
     
    On our server of Windows 2003 SP1 I am running Plesk 7.5.5 and even though SpamAssassin is install it's greyed out on the clients list of access, and I can't access it ether. The service is running and using the correct file and I find the following error in my Event Log:

    System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host
    at System.Net.Sockets.Socket.Send(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags)
    at System.Net.Sockets.Socket.Send(Byte[] buffer)
    at SpamC.SpamAssassinFilter.FilterMessage(Byte[] bytesMsg, FilterOperations filterOperation, FilterResult& result)
    at SpamAssassinService.FilterThread.filterMessage(String fileName, String mailName, Boolean checkOnly, Boolean userOnly, SpamResult& spam)
    at SpamAssassinService.FilterThread.threadProc()
     
  2. matija

    matija Guest

    0
     
    After the last update (which cause more problems than any good), I also get errors regarding SpamAssassin service:

    SpamC.FilterException: Invalid CHECK result.
    at SpamAssassinService.FilterThread.filterMessage(String fileName, String mailName, Boolean checkOnly, Boolean userOnly, SpamResult& spam)
    at SpamAssassinService.FilterThread.threadProc()

    (taken from Event Manager log)

    Any ideas?
     
  3. matija

    matija Guest

    0
     
  4. JackL

    JackL Guest

    0
     
    logan@jatol

    It seems, you use SmarterMail, if so, turn off SpamAssassin, SmarterMAil uses its own integrated spam filter

    matija

    Not enough information in your post, please describe configuration (mail server, event ID)

    John S.G.
     
  5. matija

    matija Guest

    0
     
    Mail server installed is MailEnable Standard Edition 1.9. There are no errors in MailEnable System Diagnose, only few warnings (Resident AV Agent warning and Host IP Reverse Lookup Tests for nameservers - ns1 and ns2 which don't use post offices).

    Copy/paste from Event Viewer - > Application Log:

    Type: Error
    Source: SpamAssassinService.exe
    Category: None
    Event ID: 0
    Description:
    SpamC.FilterException: Invalid CHECK result.
    at SpamAssassinService.FilterThread.filterMessage(String fileName, String mailName, Boolean checkOnly, Boolean userOnly, SpamResult& spam)
    at SpamAssassinService.FilterThread.threadProc()

    Note: it was working fine untill v7.5.5, it still works for some mailboxes, I tried restarting service/server but no result
     
  6. JackL

    JackL Guest

    0
     
    As I can see from practice, it is due to failed upgrade, or SmarterMail, or Third party spam filter (stop it if you use any):

    1. Control Panel->Add/Remove program->Plesk 7.5.5 for Windows ->change->repair
    2. If it won't help -> try remove SpamAssassin and install again
    Control Panel->Add/Remove program->Plesk 7.5.5 for Windows ->change->modify

    (Don't forget make backup before trying these steps both Plesk and MailEnable (just copy folder - while services stoped - for MailEnable))

    John S.G
     
  7. matija

    matija Guest

    0
     
    Uh uh uh... I'll rather wait for next Plesk update instead of uninstalling/repairing... Dr.Web issue was enough...

    Update:
    Reinstalled SpamAssassin and it's working now... Thanks JackL
     
Loading...