1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

SSL cert problem

Discussion in 'Plesk for Linux - 8.x and Older' started by a2tech, Feb 14, 2006.

  1. a2tech

    a2tech Guest

    0
     
    I installed an SSL cert for one of my domains. The site runs Mambo, which was originally installed in the httpdocs folder. I would like to run https with some parts of it.

    Do I have to reinstall it in the httpsdocs folder or is there some way to use Plesk to serve the SSL linked docs from the same httpdocs folder?
     
  2. jwdick

    jwdick Guest

    0
     
    In the Plesk control panel, goto <DOMAINS><DOMAINNAME><SETUP> Check the box for SSL in same folder as httpdocs
     
  3. a2tech

    a2tech Guest

    0
     
    Hi,

    When I go to Domains, then choose the Domain name, the only Setup icon is for the physical hosting. If I choose that, the only SSL options I see is "SSL Support". It does not mention which folders will be covered by SSL.

    In the list of Domain icons for my domain, which area am I supposed to go into?
     
  4. jwdick

    jwdick Guest

    0
     
    the difference must be the version of Plesk that you are running. I have Plesk 7.5.4. My options in the physical hosting setup say:

    SSL support

    &

    Use a single directory for housing SSL and non-SSL content

    I don't know if that option is available in older versions.
     
  5. a2tech

    a2tech Guest

    0
     
    Ah, ic.

    I was going to upgrade, but I am running a different verison of Mambo than the one that comes w Plesk. When I tried to upgrade Plesk, it wanted to upgrade Mambo, so I canceled it.

    Hmmm, will have to figure out how to upgrade I think.

    Thank you.
     
  6. jwdick

    jwdick Guest

    0
     
    I'm sure there has to be an "alias" command in one of the conf files. Before you try upgrading ( unless you really want to upgrade ), let's see if I can find the answer or maybe someone else will chip in with the answer for us.
     
  7. jwdick

    jwdick Guest

    0
     
    a2tech,

    From what I could find out, the settings are in the httpd.include file in the /home/httpd/vhosts/domainname/conf directory. The problem is that Plesk over writes this file whenever an upgrade is done. If you do not want to upgrade to 7.5.4 now but are planning to in the future, you could edit this include file to change the ssl directory, but this is not a perament fix as this file may get updated by Plesk.
     
  8. a2tech

    a2tech Guest

    0
     
    Thanks

    I will look there. I can always add this note to my "playbook" for Plesk in case I upgrade.
     
Loading...