1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

SSL error

Discussion in 'Plesk Expand 2.2 Troubleshooting Issues' started by webcie, Aug 9, 2007.

  1. webcie

    webcie Guest

    0
     
    Hello

    My expand server generates an error message like the example below almost every hour:


    Plesk server win1.xxxx.net changed its network status to "offline"

    Details
    --
    Plesk server is unreachable now: SSL read: error:00000000:lib(0):func(0):reason(0), errno 104.

    or

    Plesk server is unreachable now: Unknown SSL protocol error in connection to xx.xx.xx.xx:8443

    any suggestions?


    Jef
     
  2. resellertr

    resellertr Regular Pleskian

    25
    57%
    Joined:
    Jul 14, 2004
    Messages:
    133
    Likes Received:
    0
    I have same problem, I downgraded Expand to 2.1, I works without a problem.
     
  3. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    Could you try running

    /usr/local/expand/sbin/pamon server -id <# of your Plesk server> -v -c

    and post an output here (but REMOVE password in output!) or in private message?

    That looks like problem of cURL library used in internals.
     
  4. mscinar

    mscinar Guest

    0
     
    I have same problem

    I tried this command and got this result;

    /usr/local/expand/sbin/pamon server -id 2 -v -c

    * About to connect() to *.*.*.* port 8443
    * Trying *.*.*.*... * connected
    * Connected to *.9*.*.* (ip) port 8443
    * error setting certificate verify locations, continuing anyway:
    * CAfile: /usr/share/curl/curl-ca-bundle.crt
    CApath: none
    * SSL connection using RC4-MD5
    * Server certificate:
    * subject: /C=US/ST=Virginia/L=Herndon/O=SWsoft, Inc./OU=Plesk/CN=plesk/emailAddress=info@plesk.com
    * start date: 2007-06-29 14:24:51 GMT
    * expire date: 2008-06-28 14:24:51 GMT
    * issuer: /C=US/ST=Virginia/L=Herndon/O=SWsoft, Inc./OU=Plesk/CN=plesk/emailAddress=info@plesk.com
    * SSL certificate verify result: error number 1 (18), continuing anyway.
    > POST /enterprise/control/agent.php HTTP/1.1
    Host: *.*.*.*:8443
    Pragma: no-cache
    Accept: */*
    HTTP_AUTH_PASSWD: ************
    Content-Type: text/xml
    Content-Length: 129

    <?xml version="1.0" encoding="UTF-8" standalone="no" ?><packet version="1.4.2.0"><server><get><gen_info/></get></server></packet>< HTTP/1.1 200 OK
    < Connection: close
    < Date: Fri, 24 Aug 2007 09:41:44 GMT
    < Server: Microsoft-IIS/6.0
    < X-Powered-By: ASP.NET
    < X-Powered-By: PHP/5.0.5
    < P3P: CP="NON COR CURa ADMa OUR NOR UNI COM NAV STA"
    < Last-Modified: Fri, 24 Aug 2007 09:41:44 GMT
    < content-type: text/xml
    < Set-Cookie: PHPSESSID=35246cf51d7628c857e7b4639b303a25; path=/
    < Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    < Set-Cookie: PHPSESSID=53b8cceed5fcdd5245cf8359a8885d8e; path=/
    < Expires: Thu, 19 Nov 1981 08:52:00 GMT
    < Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    < Pragma: no-cache
    < Set-Cookie: PLESKSESSID=53b8cceed5fcdd5245cf8359a8885d8e; path=/
    < Set-Cookie: locale=en-US; expires=Sat, 23 Aug 2008 09:41:44 GMT; path=/
    * Closing connection #0
    <?xml version="1.0"?>
    <packet version="1.4.2.0"><server><get><result><status>ok</status><gen_info><server_name>servername</server_name></gen_info></result></get></server></packet>

    The PleskAgent checked successfully.
     
  5. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    How often do you receive the error from 1st posting? Each time? Once a hour? Once a day?
     
  6. resellertr

    resellertr Regular Pleskian

    25
    57%
    Joined:
    Jul 14, 2004
    Messages:
    133
    Likes Received:
    0
    I couldn't get list of domains because of this error when I first added a server.
     
  7. AndreasK

    AndreasK Regular Pleskian

    26
    23%
    Joined:
    Sep 6, 2006
    Messages:
    173
    Likes Received:
    0
    Yes... Thats the best way to solve tons of problems...
     
  8. mscinar

    mscinar Guest

    0
     
    When I tried to assign the Plesk Server that includes lots of domains,I had got connecting timeout problem.

    I increased the connect_timeout and operation timeout value in expand.conf file. So I started to get this SSL error.
     
  9. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    cURL guys said this error occurs if connection is interrupted on other side.

    Probably your Plesk server interrupts connection on its own timeouts. There are few parameters affecting script lifetime on Plesk side:
    - "Timeout" parameter in Apache configuration file (
    /usr/local/psa/admin/conf/httpsd.conf), that is 300 seconds by default
    - "max_execution_time" in PHP configutation file (/usr/local/psa/admin/conf/php.ini), that is 600 seconds by default
    - "memory_limit" in PHP configutation file (/usr/local/psa/admin/conf/php.ini), that is 32 Mb by default

    Memory limit can interrupt processing request on Plesk server if there are very many domains on Plesk server. Building XML answer for all of domains consumes a lot of RAM. Probably there is 600+ domains on your Plesk server.
     
  10. resellertr

    resellertr Regular Pleskian

    25
    57%
    Joined:
    Jul 14, 2004
    Messages:
    133
    Likes Received:
    0
    Plesk server is a Windows Server. I tried to switch Plesk Web Engine from apache to iis. I got same error. There are 300 domains on Windows plesk server.
     
  11. mscinar

    mscinar Guest

    0
     
    My Plesk Server is running on Windows too.
     
  12. mscinar

    mscinar Guest

    0
     
    The problem was solved.

    I increased the SSLSessionCacheTimeout value in ssl.conf file and timeout values in php.ini file. I repeadly started to assigning process. And then problem was solved.
     
  13. resellertr

    resellertr Regular Pleskian

    25
    57%
    Joined:
    Jul 14, 2004
    Messages:
    133
    Likes Received:
    0
    Re: The problem was solved.

    Which ssl.conf? On web server or on expand server?
     
  14. mscinar

    mscinar Guest

    0
     
    Ssl.conf file on web Server(Plesk for windows)

    "C:\Program Files\SWsoft\Plesk\admin\conf\ssl.conf"
     
  15. resellertr

    resellertr Regular Pleskian

    25
    57%
    Joined:
    Jul 14, 2004
    Messages:
    133
    Likes Received:
    0
    I tried it but still same error

    Plesk server is unreachable now: SSL read: error:00000000:lib(0):func(0):reason(0), errno 104.
     
  16. Netjunky

    Netjunky Guest

    0
     
    Hello,

    We have the same error.
    Plesk is on Windows and we have 1000 domains there.
    We have successfully transfered 300 domains but then connection failed with the following error:

    Plesk server is unreachable now: SSL read: error:00000000:lib(0):func(0):reason(0), errno 104.

    We increased the SSLSessionCacheTimeout value in ssl.conf(C:\Program Files\SWsoft\Plesk\admin\conf\ssl.conf) file and timeout values in php.ini(C:\Windows) file and still geting the same error.

    Any suggestions?

    Igor
     
  17. gold

    gold Regular Pleskian

    25
    57%
    Joined:
    Jan 8, 2008
    Messages:
    307
    Likes Received:
    0
    Error number 104 means 'Connection reset by peer'. This error appears probably over big load of Plesk servers during processing of Expand requests. To reduce load decrease max_get_per_request/max_set_per_request parameters in '/usr/local/expand/conf/expand.conf' file.
     
  18. gold

    gold Regular Pleskian

    25
    57%
    Joined:
    Jan 8, 2008
    Messages:
    307
    Likes Received:
    0
    Error number 104 is appeared more often in configuration Plesk CP over IIS in comparison with Plesk CP over Apache. It is caused low ConnectionTimeout property default value in IIS (120 seconds). To increase property value I use follow command:

    cscript c:\Inetpub\AdminScripts\adsutil.vbs set w3svc/ConnectionTimeout 1200
     
Loading...