1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Strange prob with stats

Discussion in 'Plesk for Linux - 8.x and Older' started by MaRiOs, Sep 9, 2005.

  1. MaRiOs

    MaRiOs Guest

    0
     
    I have this domain on the server www.grserver.gr

    I have enabled the statistics and even the protected folder..

    the problem is when I get in the cp and

    get in the grserver.gr domain ->Report->Web Stats or FTP stats I get this output :

    403 Forbidden
    Forbidden
    You do not have permission to access this document.

    Web Server at grserver.gr

    I go in the folder

    /home/httpd/vhosts/grserver.gr/statistics/webstat
    and
    /home/httpd/vhosts/grserver.gr/statistics/ftpstat

    and i see the index.html and all the files...

    So i think to put manually the url :

    https://grserver.gr/webstat/index.html ( i added the index.html )
    and https://grserver.gr/ftpstat/index.html (added index.html here too)
    and the stats open fine..

    But why it doesnt work throught the panel ?
    any ideas?
     
  2. madsere

    madsere Regular Pleskian

    26
    57%
    Joined:
    May 8, 2005
    Messages:
    200
    Likes Received:
    0
    I can confirm this problem. Plesk 7.5.4.

    /home/httpd/vhosts/*.*/conf/httpd.include now all have aliases for webstat. I imagine that's the problem. Better name than plesk-stat anyway but the link from the CP should be changed too, as it is it's dead
     
  3. MaRiOs

    MaRiOs Guest

    0
     
    I did solved the problem.

    The solution was :
    I created an .htaccess file in each folder

    /home/httpd/vhosts/grserver.gr/statistics/webstat and /home/httpd/vhosts/grserver.gr/statistics/ftpstat

    the .htaccess has only this line :

    DirectoryIndex index.html

    Now tha statistics links works even if you press the buttons from inside the panel.
     
  4. madsere

    madsere Regular Pleskian

    26
    57%
    Joined:
    May 8, 2005
    Messages:
    200
    Likes Received:
    0
    Thanks but not really a viable solution for hundrede of websites on multiple servers....
     
  5. MaRiOs

    MaRiOs Guest

    0
     
    Yes thats true,but to be honest i dont have any problems with my other domains.

    I figured this solution out by checking the conf/
    folder.
    it had one vhost_ssl.conf file,and it seemed that this file was overrinding the directory index option of apache.
    So you have to add this in all your vhost or vhost.ssl confs files i think...
     
Loading...